Disapointment with Inovelli Blue switches

Usually I’m the kind of person to be quite reasonable with technology and problems, however this has became a little infuriating. First, my switches arrived DOA when I had learned there was an issue with the Zigbee range. Inovelli support was fantastic at getting me my new switches in an extremely timely manner considering the back order which I much appreciate. However, when my two replacements came in, I hopped right on installing one of them. Everything was great, I wasn’t overly impressed with how dim they were able to go compared to my cheap $20 TRIAC dimmers, but with the impressive feature set that was something I was willing to overlook.

Two days into having this new switch installed, it freezes up. Does not respond to being turned on or off, the switch is not in local mode and I have tried to reset it multiple times with no response. The switch was no longer connecting to my Home Assistant instance via. the Zigbee adapter. Holding the configuration button for well over a minute multiple times did not do anything. No flashing lights whatsoever. I then had tried manually pairing the switch again, with no indication the switch recognized my commands. So, currently I’m stuck with a switch that won’t turn the lights on or off, won’t connect to my Home Assistant instance. I had tried switching the breaker and leaving the main power off to it for a few minutes with still no results. I’ve concluded this switch is dead.

What should I be doing now?

Holding the configuration button for well over a minute multiple times did not do anything.

Not sure if it will help, but to reset the blue series you need to press and hold the config button AND the up paddle at the same time

1 Like

And the config button needs to be released first.


Read the user manual. As you mentioned, these devices have a very rich feature set including some that may change or disable some button functions, so it’s worth reading. And as the others have mentioned, you’re not using the correct procedure to factory reset

1 Like

Thank you for the constructive remarks, tried resetting again with no luck. I was able to successfully reset & manually pair my other Blue, but trying the same combination on this switch does nothing.

Just a thought as it wasn’t clear from your original post whether or not you had any lights on the unit, but have you checked to make sure that the airgap switch fully in? It might be worth a quick pull just to make sure it’s seated properly.

Great suggestion! Bottom air gap switch is fully inserted. Tried pulling and reinserting as well. Unfortunately however no luck.

Is the LED bar lit up at all? If not, it may be worth checking to see if a wire has come loose, if you haven’t already checked that.

Is this a neutral set up? Is it just a single switch, or part of a 3/4-way? If it is a multi-way set up are you using dumb switches or AUXes? If it is a multi-way or non-neutral, there may be other things to check.

BTW: They are looking into a firware update to allow the switches to dim down further.

Yes, the LED bar is lit up with the color I configured when I initially set up the switch. The switch is running with a neutral in a new home that was built last year and is in a single pole configuration, no 3-way setup. I’m excited to see if we can get some more stable low light dimming, I’m currently using the Phillips Warm Glow dimmable LED’s. I wonder when we will see animations added to ZHA.

Still experiencing the same issues. Was easily able to re-pair and reset my other switch, so I know the procedure I’m doing is good. Also, I tried installing the switch on a different circuit just in case. I have my other Inovelli Blue on the circuit that was initially giving me trouble, and it works just fine.

How do I proceed with a warranty claim on my switch?

1 Like
1 Like

I would submit a ticket on the main site inovelli.com. At the top, go to support and submit a ticket. They have been very responsive on the tickets. I submitted a ticket on Monday and got a reply same day with way more info than I was expecting.