Error using the Device Firmware Updater in 2.2.4 with Inovelli LZW36 Firmware v1.36 (Beta)

What is the driver method? Can I just try the Device Firmware Updater again?

Yeah, sorry – that’s what I meant by the driver method.

So I tried to do the firmware upgrade again. This time it went much faster, taking only 1/2 hour. (I had gracefully shut down the hub, unplugged it, shut down my internet and then brought the internet back up and then the hub).

However, I still got the exact same error message:

So I deleted both copies I had downloaded and tried it for a 3rd time.
Here is what I uploaded to the Hub:

This is what I told it to do:

Here it is starting to run:

Here it is saying it is done and sending the last fragment:

But, once again, it says there is an error:

Here are the logs:

Any idea why this could possibly be? At this point is doing an exclude and include the only thing I can do? If I do an exclude will I have to re-pair the switch to the fan?

Ok, sorry for the confusion. I meant the driver firmware updater as shown here:

Outside of that, I’d contact Hubitat as I’m not sure what to do :frowning:

So I then did an exclude and when I re-included it I turned all security off.

I then went to the Fan + Light Firmware Update Start Page

I copied the link for the 1.36 gbl:

Then went to How To: Hubitat Firmware Upgrade Tool

Got the new version at:

Following the instructions I changed my Type/Drive to the Z-Wave Frirmware Updater

I pasted in the 1.36 gbl URL and clicked the Update Firmware button. This was the fastest yet, taking just under 14 min. As you’ll see from the screenshots below it said the Upload was 100% and that it is “Complete device is flashing…”

Start of sending firmware:

Sent Last fragment. Waiting on device (Just after that is were Hubitat’s Device Firmware Updater always crashed):

Upload shows 100% and Update Progress is: Complete device is flashing…

But now is has been over 20 minutes saying Complete device is flashing…

So how long should that (what I hope is the final step) take? Will the message change when the flashing is complete? The instructions stop after saying to click the Upgrade Firmware button.

Good news, it should be finished :slight_smile:

Idk why that verbiage isn’t updated as it’s confusing, but when it says, “Complete device is flashing”, it means it’s completed, so you should be good to go.

Feel free to switch it back to the Inovelli LZW36 driver and then click on, “Save Preferences” and it should show 1.36.

My fingers are truly crossed for you as I felt like we just went on a roller-coaster ride!

So I’m at 1.36. Yippee. So now I used “Disable Physical On/Off Delay” and made it “Yes” and the light turns on and off virtually like it was the mechanical hard wired switch!! YEA!

Just BTW, I changed that to yes, and that worked, but I could have sworn that I had seen past posts that instead of just that heading or the Yes/No choices it would have said something about the 700ms delay.

I know you/Inovelli added some numbers for the parameters for the Red Dimmer, and the code looked like it was just literally adding the numbers in before the description. It would be fantastic if you could number all the parameters for the 5 switches (Black Switch/Dimmer, Red Switch/Dimmer and Fan+Light).

So I guess the moral of this story is that I’m going to have to go around excluding all my switches (some 20+) and then reincluding them with zero security so I’ll be able to upgrade the firmware. Will I then have to redo all the rules I created using them or should they just get picked up if I keep the device with the exact same name?

At least it seems to be 2 steps forward, 1 step back instead of the other way around!

I don’t have a Fan/Light switch installed here at the office and I can’t pull up my dashboard, but all I can say is to make sure you have the latest driver installed.

Then, maybe do a CTL+F (or Command+F) on the page and search for, “Delay”

It should be labeled, “Disable Physical On/Off Delay”.


Yes, this is the magic one! Hopefully this gets you squared away :slight_smile: