Error using the Device Firmware Updater in 2.2.4 with Inovelli LZW36 Firmware v1.36 (Beta)

I just tried to use the device firmware updater in the new 2.2.4 to update the firmware of one of my Inovelli LZW36 + Light - Red Series to Firmware v1.36 (Beta). I uploaded the firmware, once it was transferred to the switch, I get the following error:
### Firmware Update Status

Device Firmware Updater: ERROR: The transferred image does not match the Firmware Target

The last few log entries:
dev:1352020-11-16 17:21:13.287 debugGB Inovelli Fan + Light LZW36: MeterReport(meterType: 1, precision: 1, scale: 2, size: 4, meterValue: [], rateType: 1, deltaTime: 0, previousMeterValue: [])

[dev:135]( 17:21:12.709 [debug]( Inovelli Fan + Light LZW36: MeterReport(meterType: 1, precision: 3, scale: 0, size: 4, meterValue: [0, 0, 1, 185], rateType: 1, deltaTime: 0, previousMeterValue: [0, 0, 0, 0])

[dev:135]( 17:21:12.171 [debug]( Inovelli Fan + Light LZW36 Unhandled Event: FirmwareUpdateMdStatusReport(status:4)

[dev:135]( 17:21:08.539 [debug]( Inovelli Fan + Light LZW36 Unhandled Event: FirmwareUpdateMdGet(numberOfReports:1, reportNumber:7448)

I tried this a few times, and even re-downloaded the firmware and re-uploaded it to the hub. I am not sure what I am doing wrong. I also asked about this in the Hubitat community:

Not sure if it is me, Hubitat, or the switch.

I believe you need to use the binary updater. The other one is deprecated.

I am using the built in tool that comes with 2.2.4, which was just released today.

I was able to update them with no issues using a Z-Wave stick as a secondary controller with the PC Controller software. Uploading the firmware was much faster that way too. I am not sure why the Hubitat device firmware updater wasn’t working.

Question for you – did it get to 100% but then said, “FAILED” along with some reasoning as to why?

We’ve been beta testing some lightstrip firmware and it worked perfectly through the updater on 2.2.3, but when we started beta testing 2.2.4, we all got the FAILED warning with the new firmware, so we had to use the Z-Stick.

Yes, it goes to 100% and then displays the following message:

I am using a Hubitat C7 hub version 2.2.5131. For my Inovelli Fan/Lights LZW36’s I currently have firmware 1.34. I decided to try Hubitat’s built in Firmware Updater as I the Z-Wave updater kept saying I had a sleepy device. Things did not go any better.

I went to the below URL to follow Hubitat’s instructions:

First I made sure it would support the GBL file I downloaded:

Here is the link to where I got the file to use for the LZW36 (Fan/Light):

That auto-downloaded it to my Downloads. I left the file there but also copied it to my Inovelli\Firmware\LZW36 folder. Then I chose the copied file and uploaded it successfully:

I then clicked the Update Z-Wave Firmware button in their step 5. When I did I got this error message:

This is what was in the Logs:

I have no idea what the getWeatherData() would have to do with the Device Firmware Updater. I’m not sure what to do about that.

Since the Update Z-Wave Firmware button should have taken me to the screen where I pick the device and version to update (Step 6) it was device independent at that point, and pulling the airgap, resetting the device, etc. would have no effect on this initiaal step. So I have no idea why I keep getting the error message.

BTW, I deleted the file then went back and did everything again starting with the file upload, but from my Downloads folder, and I got the exact same error message.

Any idea on why I’m getting this error message and what to do about it?

BTW, I’ll post this over on Hubitat’s community board too.


I removed Weather Dot Gov but still got a getCurrentData() error. However, when I went into the logs I didn’t see anything marked as an error.

So I then removed the Device Firmware Updater and re-added it. This time it is now running but extremely slowly. It took 8:20 minutes to get to 1%, then another 15:07 minutes to get to 2% and 15:25 minutes to get to 3%. My router, the hub and the switch are all in the same room so I don’t know why it is going so slowly. Here is a screenshot of the device details from Hubitat.

BTW, just to let you know that initial speed wasn’t an anomaly, I just got to 10% after 2 hours and 25 minutes. At this pace it will take about 24 hours to update one switch! Has anybody seen anything like this? Is there anything I can do?

I’ve seen this a couple times throughout the community. I’m not really sure what causes it. I don’t think I’ve had a switch take more than 20 minutes, except for when I ran into the sleepy device situation.

This is both on the C5 and C7.

In fact, I just updated a ton of switches this weekend to 1.52 (I know you’re talking about the fan/light, but just thought I’d throw it out there).

One thing you may try is investing in a Z-Stick and going that route with the PC Controller. I know it’s an added expense, but that way always works great and is fast.

By a PC controller do you mean something like a Raspberry Pi? I purposely went with Hubitat as I didn’t want to get even further into the weeds with that.

I know when I first tried to update the firmware via @bcopeland’s Z-Wave Firmware Updater it said my device was sleepy. But, as you know, it is an LZW26 switch, not a bulb or sensor that goes to sleep. So while that may be related, it shouldn’t be. But if it is somehow, what would cause an LZW36, or any of your other switches, to be “sleepy” and how do I wake it up and keep it awake?

I’m assuming that while it is updating the firmware I can’t use the switch or do anything with it at all, correct?

BTW, the progress bar is still moving and now has gotten up to 24%, but in 6 hours 7 minutes, so again, more than 24 hours to do one firmware upgrade.

He’s talking about the Silicon Labs PC Zwave controller software (free, just need a user account) and something like the aeotec Z-wave usb stick (55-60) to put in your PC and then you have the ability to update it from there.

I see there is an Aeotec one on Amazon for $59.99. I see cheaper ones too, but have heard good things about Aeotec in general. Any idea if this is a good one or not or if it is overkill? Considering all the time and $ I’ve spent so far, $10-$20 different is no big deal if this is the primo one.

I could use it with my Mac laptop and my USB 2 → USB C converter, and get close to the switches, if that would help, but I don’t know what to do with it. How does the firmware updater know to use that vs. the Hubitat, etc.? I’ve never tried this or even read about it before this thread.


There’s a cheaper one on Amazon that works great…~$31.

1 Like

As the name suggests, PC Controller is a PC application. So it won’t run on a Mac. Bootcamp or a VM, maybe.

Can confirm it works on VM via Fusion and/or VirtualBox. Just need to ensure you connect the USB device…

1 Like

I have Parallels on my big Mac ('27" Retina) that runs Windows 10, but it is an all-in-one so I couldn’t take it from room-to-room. It would be about the same average distance from my switches as my Hubitat hub which is in a different room. So would that do any good? Why is a Z Wave stick better than the antenna built into the Hubitat? Is it just bigger?

BTW, I googled Z Wave PC Controller and found this one up on the App Store for the Mac. Any reason this shouldn’t work?

Yes, I have a MacBook as well and run Boot Camp and this works great.

I would suggest the one @harjms suggested. It’s less expensive and over the last 5yrs, I haven’t had an issue with any of them :slight_smile:

I can’t say for certain if it would make a difference.

I’m honestly not sure, I’ve just had better success with it along with the program written by Silicon Labs (who owns Z-Wave).

I can’t speculate how Hubitat does it and for the most part, it works great. The only issues I’ve ever had with Hubitat in updating firmware was on the RGBW Bulbs which for some reason just weren’t working. As soon as I moved to a Z-Stick and PC Controller, they all worked great.

I’ve never had any issues with switches on Hubitat, so I can’t speak to that.

So after 26 hours and 19 minutes it finally got to 100% only to give me this error:

The filed size I used was 186,179 bytes. I looked in the error logs and did not see any errors.

I’m trying to shut down the hub and restart the internet too. I used Hubitat’s command to shutdown the hub from their settings page and will let you know once I can reboot it all.

Ouch. One thing you could try is to remove the device and pair it using no security (ie: uncheck everything during the pairing process) and then either try this again or try the driver method (I prefer this method – however, the sleepy device is a tough problem to overcome).