Fan Light combo switch won’t dim my lights

Hey everyone. I have several Fan Light combo switches and I installed my first one. It can “dim” the fan just fine, slows and speeds up. However, no matter how hard I try it won’t dim the lights. I tried updating to the 1.36 firmware hoping that would help. I got the GE candelabra led bulbs from the known working list in the articles. Still no luck. Any ideas on what I’m missing?


@fatherdoctor uses GE Reveal so he may be able to comment.

I don’t have a fan switch so I’m not sure about this, but if it has a Smart Bulb Mode, make sure it’s turned off.

I also suggest checking to make sure that the ramp rate and dimming settings are either default or something other than set to zero!

1 Like

@chrism.conner I have a few installs of the reveal A19 base bulbs on LZW31-SN dimmers, but none of the candelabra base model. While I have those bulbs as well, I unfortunately only have them on LZW30 switches. Try to manually set the dimmer value to 50% in whatever hub you are using and the light should be near its dimmest setting. The min brightness setting on mine is in the mid-40s. Are you using a neutral wire?

Beyond that, if you can get your hands on an incandescent bulb that is the easiest way to verify the dimming functionality is working on your switch.

As @Sky320 said, it’s very easy to disable the dimming feature if you are playing around with settings. I do that on purpose and actually don’t use mine in a traditional dimmer sense, but instead have mine going from off to a set midpoint on a press up, to max on a hold up, and off on a press or hold down (no ramping) when used from the physical switch.

edit: I’ve ordered an E12 to E26 adapter so I can verify the candelabra bulbs once and for all. I feel bad that the bulb compatibility was entered because of me, but people are having issues.

Thanks for all the insight!! I’ll try all of these options. I am using a neutral wire. That shouldn’t cause issues right?


@chrism.conner that’s a good thing. Just making sure as it eliminates alot of odd behavior. What hub are you using?

It’s really good, actually. The LZW36 won’t work without a neutral.

1 Like

@Bry LOL! I completely forgot we were talking about an LZW36. I need to purchase one for my back porch. Looking at the included driver in Hubitat, it doesn’t appear to support any of the fancy tweaks to ramp rate, etc…

@chrism.conner are you using the default driver or the one available here? If not the Inovelli driver, set it to that and take a screenshot of the state variables.

1 Like

I’m using the INovelli ones. Here are the screenshots:


@chrism.conner parameter 3 and 4 are your ramp rate at the switch and over z-wave, and both are set to 10 seconds, so you should see slow changes and not immediate ones. Similarly, parameter 5 and 6 are your min and max, dim levels which look about right based on my experience with the large base version of the bulb. 12 and 13 are your default level, which should have the switch turn on at 3/4 brightness. Based on that, the switch appears to be configured for dimming appropriately.

You should try holding the up and down buttons on the switch while watching the level state value on your phone. You can verify that the switch is attempting to adjust the brightness level live that way. If that doesn’t work, you might also try resetting the min and max to 1 and 99 respectively, then telling the switch to go to a 1 brightness level through your phone. That should result in flickering if the switch is actually dimming and these bulbs behave like their larger cousins.

@chrism.conner When you installed the switch, did you try it first before you paired it with your hub? If so, did the dimmer work then?

You can evaluate whether or not it’s a driver/hub issue by removing the switch from your hub and factory resetting it. I don’t have a LZW36, but it seems to me that the dimmer should function just fine without pairing. If it doesn’t, it may be the switch or your bulbs.

Another thing to try would be trying your bulbs in another fixture with a working dimmer. I know the model # you stated is dimmable, but it’s worth a shot. Same thing for bulbs that are dimming with another dimmer. Way simpler and quicker than working through hub settings as a first step.

I will give the reset a try. I don’t have another Inovelli dimmer, but these bulbs do work with the GE dimmmers. The lights did not dim at all when the switch was first installed, but I’ll try the reset again just in case.


Thanks! Going to try these tonight.

I got the adapter in, and the bulb appears to behave like I expected it to. Which exact GE bulb did you get?

Thanks! I must have something wrong with my driver settings or my wiring. I’ll keep at it.

Thanks everyone! I still can’t get it to work. My wife got tired of not being able to dim and having stuff hanging out of our ceiling fan. So I had to give up on the Fan Light combo. I went back to an old GE Fan switch I had around for the fan control and then an Inovelli Dimmer switch for the light. The Inovelli Dimmer works without any issues. And of course losing the lag was important for the WAF. I may have to abandon these all together:-(. I’ll play with them more in my office as that’s less impactful on my wife.

At least I know that it was either:

  • The wiring(however, I think this is the same as it is with the current dimmer)
  • The switch
  • The driver(however, like I said, it never worked, even when first installed)