Fan & Light Switch Delay (700ms) - Parameter 51 Issues

Hi Support - hoping i can get some help, very newbie here!

I used the PC Connector to flash my LZW36 to 1.36 but i’m not sure how to activate option 51 to make the buttons work instantly. Right now it takes 3-4 seconds for both switches to shut off.

I am using smartthings and I didn’t have any issues adding it to the hub. I used the smart things app to go to the device settings and turned parameter 51 to yes, but my switch still has a 3-4 delay for both buttons.

So i guess my questions are:

How do I confirm for sure parameter 51 is on
How do I turn it on myself if smartthings device settings didn’t do the trick?

Hi @carsontl , this isn’t Inovelli support, it’s a community board, but there is plenty of help here.

The first think I would check would be to insure you have the 2020-08-14 Device Handler installed.

Hi Bry! I just installed everything yesterday, following the instructions - i’m using the latest version, if that’s 2020-08-14 :slight_smile:

I’m guessing that you turned disabled the delay via the app. I would verify the setting in the device page in the IDE. If the delay is turned off, that value should be “0”.

Hi Bry, I do see under parameter 51 in IDE that the value is set to 0, but my lights are still taking 3-4 seconds to action

Parameters in IDE:

Name	Type	Value
debugEnable	boolean	
disableDebugLogging	number	
disableInfoLogging	number	
enableDefaultLocalChild	boolean	
enableDefaultZWaveChild	boolean	
enableLED1Child	boolean	
enableLED1OffChild	boolean	
enableLED2Child	boolean	
enableLED2OffChild	boolean	
group2e1	string	
group4e1	string	
group5e1	string	
group7e1	string	
infoEnable	boolean	
parameter1	number	
parameter10	number	
parameter11	number	
parameter12	number	
parameter13	number	
parameter14	number	
parameter15	number	
parameter16	number	
parameter17	number	
parameter18	enum	
parameter19	enum	7
parameter2	number	
parameter20	enum	
parameter21	enum	7
parameter22	enum	
parameter23	enum	
parameter24-201a	enum	
parameter24-201b	enum	
parameter24-201c	enum	
parameter24-201d	enum	
parameter24-202a	enum	
parameter24-202b	enum	
parameter24-202c	enum	
parameter24-202d	enum	
parameter24-203a	enum	
parameter24-203b	enum	
parameter24-203c	enum	
parameter24-203d	enum	
parameter24-204a	enum	
parameter24-204b	enum	
parameter24-204c	enum	
parameter24-204d	enum	
parameter24-205a	enum	
parameter24-205b	enum	
parameter24-205c	enum	
parameter24-205d	enum	
parameter25-251a	enum	
parameter25-251b	enum	
parameter25-251c	enum	
parameter25-251d	enum	
parameter25-252a	enum	
parameter25-252b	enum	
parameter25-252c	enum	
parameter25-252d	enum	
parameter25-253a	enum	
parameter25-253b	enum	
parameter25-253c	enum	
parameter25-253d	enum	
parameter25-254a	enum	
parameter25-254b	enum	
parameter25-254c	enum	
parameter25-254d	enum	
parameter25-255a	enum	
parameter25-255b	enum	
parameter25-255c	enum	
parameter25-255d	enum	
parameter26	enum	
parameter27	enum	
parameter28	number	
parameter29	number	
parameter3	number	
parameter30	number	
parameter31	enum	
parameter4	number	
parameter5	number	
parameter51	enum	0
parameter6	number	
parameter7	number	
parameter8	number	80
useVDS	boolean

Hey @carsontl – welcome to the community, we’re glad to have you!

Let’s confirm a few things first.

Can you verify 1.36 is installed? To do this, can you provide the Raw Description data in IDE (or you can check yourself and verify):

Here’s where to specifically find the version number (note: below is just an example)

After verifying, can you switch Parameter 51 to 1 (ie: turn on the delay) and see if there is a noticeable difference between having it on and turning it off? What I’m looking for specifically is – do you notice a delay from when the bulb turns on (at the lowest setting) when the setting is on or off.

Finally, what may help a bit is to calibrate your bulbs to the switch. What I mean here is let’s find the minimum level that the bulbs truly turn on.

In your ST app, try setting the dim level to 10% – does the lightbulb turn on or is it still off?

  • If it’s off, try bumping it up to 15% and so on until you see it turn on ever so faintly. That value will be your minimum dim setting that we’ll set
  • If it turns on at 10%, scroll down to the lowest number before 0% where the bulbs turn off and that will be your minimum dim setting that we’ll set

Now that you found your minimum dim setting, open up the settings on your switch and find where it says something like, “Minimum Dim Level” and enter the number you found above and save.

See if that improves the delay a bit.

Keep us posted. I’m also probably going to move this topic to a separate topic so people can search for this specific issue.

Hang in there!

1 Like

Awesome to meet THE Mr. Inovelli himself :slight_smile: thank you!! It’s been a warm welcome so far! I’m an IT guy by trade so hopefully i’ll get through the hurdles :slight_smile:

I pulled the raw line from IDE and it isn’t 1.36! i’m shocked! I pulled the PC Controller ‘get’ command again and it says 1.36 in the controller

zw:Ls2a type:1100 mfr:031E prod:000E model:0001 ver:1.34 zwv:7.13 lib:03 cc:5E,55,98,9F,22,6C sec:26,70,85,59,8E,86,72,5A,73,75,7A,5B,87,60,32 epc:2

PC Controller page:

I’ll be able to test the parameter change / dimming levels here in a bit at lunch - will get back to you as soon as I can on that.

Thanks again!

Haha, glad to help :slight_smile:

Yeah that is weird… The only thing I can think of is maybe removing the Fan/Light from ST and then re-including it and see if that fixes the version discrepancy.

If it doesn’t, maybe try flashing it again. But it’s just really weird that it shows the correct version on the controller and not in IDE – plus you’re still experiencing the delay.

Awesome, keep us posted!

1 Like

@EricM_Inovelli - That you? J/k @Eric_Inovelli …we all know who’s behind the curtain.


Yes, our secret weapon… which can be found here.


@Eric_Inovelli hey Eric, i just finished flashing the machine again

here’s the refreshed stats for smartthings - looks like it’s still showing 1.34 in raw

But the current states does show firmware at 1.36

Gonna go upstairs and see about the dimming level and flipping p51 over to 1 again to test

Quick question – did you remove the switch from ST and then re-pair it? I forgot to ask if you were using PC Controller and a Z-Stick as a secondary controller on ST or if you removed the switch from ST, paired it to a Z-Stick, upgraded the firmware, then paired back to ST.

1 Like

@Eric_Inovelli - I see what you did there.

1 Like

Hey Eric, I did not actually do that - that’s a great point. I added the 2 device handlers to ST and then added the lzw36 to ST. My original goal was just to get it working in ST. Then realizing the delay and researching into the issue I learned that I needed beta 1.36.

Once added I then connected my zwave hsbs1 to my host pc and installed pc controller (your guys wiki on that is way out of date btw). Took a bit more finagling but once connected I firmware wiped it and left it at that!

I did want to say I went upstairs and tried the dimming test and then dur-dur-dur, I forgot my light was LED and could dim all the way to 1% lol.

I went through the settings in ST, turned most of the transitions to 0, set p51 back to 0, and everything now seems to be instantaneous - feelsgoodman.jpg

I am going to go ahead and delete/readd it back to ST just to do one final connect up

Edit: noticed that i can’t just delete this device, i have to do a zwave exclusion and press some buttons on the lightswitch to reset so i’ll have to try it on my next break

1 Like

Hey Eric I was able to get the device readded back into ST and confirmed the raw data:

zw:Ls2a type:1100 mfr:031E prod:000E model:0001 ver:1.36 zwv:7.13 lib:03 cc:5E,55,98,9F,22,6C sec:26,70,85,59,8E,86,72,5A,73,75,7A,5B,87,60,32 epc:2

and everything’s working great! Just in time for the next 3 LZW36’s to come in for the rest of the task haha :slight_smile:

I think we’re good to go! I also ordered some red series dimmers from you guys which should be arriving sometime soon as well :slight_smile:

Have a great weekend!