Fan/Light Switch (LZW36) Suggestions and/or Improvements 1.0

@Eric_Inovelli started this conversation for 2.0. The items I’ll bring up here, I believe, can be done with 1.x FW and a few driver changes. Tagging @EricM_Inovelli as well. Sorry if this thread was started somewhere else.

I finally had time to install the first of two switches. This thing has surpassed what I was hoping for :slight_smile: and the WAF has already gone up 100% just for having a medium speed again :+1: Hopefully not jinxing myself. But, everything has been rock solid for over 30+ hours :smile:. We really like the breeze mode as it is very quiet, all you can hear is the fan blades spin up or down. Unlike my HB Zigbee unit. It sounded like a Mack Truck changing gears. Making this feature unusable at night in the bedroom.

First, FW improvements (most likely applies to all hubs):

  • When looking at power measurement, I am seeing 1w with both fan and lights off. I am hoping this is not leakage? But rather an offset…

  • The time/lag from when I push the button for the lights On seems to be longer than when they turn Off. It seems noticeably longer than my Red Series Dimmers and switches. to me, this is a “don’t care”. But to others in the house, they have noticed it and perceptually I would agree.

  • Breeze Mode: Currently the breeze mode seems to spend a lot of time at a slow speed then going up. I would like to suggest that there be 2 or 3 breeze modes supported. Examples: Changing from slow to medium or medium to high, and random low to high?

Hubitat Driver Improvement(s):

  • I’ve noticed, when using the Hampton Bay child component in Hubitat, if I use the “Fan” template for the tile in the dashboard, I can set the speed to “Low”, “Medium” or “High” and the fan sets the speed appropriately. However, if I set the speed of the fan at the switch, say low, the “Fan” template is not updated. See the screen capture below. Here I set the speed to High using the Fan tile (And the fan responded by going to high). However, after setting the speed to low at the switch, the Fan tile didn’t update. Note the Dimmer tile below the Fan tile accurately reports the current fan speed. One more thing, If I set the fan speed, using the Fan Tile for “Medium-Low” or “Medium-high”, the fan is actually bumped up to the next highest speed, which is what I would expect to happen. But again the Fan tile reflects the wrong speed.


That’s all I have for now. Thank you for making this product!

1 Like

My $0.02 is to name the three modes Partly Cloudy, Tropical Storm, and Hurricane (to tie into the product name):

Partly Cloudy should be heavy on low, with bounces to medium and an occasional blip to high.

Tropical Storm should be heavy on medium, with bounces to low and high.

Hurricane should be heavy on high, with bounces to medium and an occasional blip to low (since hurricanes have eyes that are calm).

I suspect that Breeze Mode is coded/executed in the canopy module, and also suspect that the canopy module is not OTA firmware updatable. If I’m correct, an updated Breeze Mode will have to be a 2.0 feature… :frowning:

1 Like

This has been implemented/fixed with the latest Hubitat Driver!

1 Like

The 2020-07-10 driver?

I’m also seeing that I can only set low/med/high on the fan. I ended up changing tile to a “dimmer” as a workaround.

@njcorwin Check out this thread: Latest LZW36 Driver Issue

My suggested change seems to work… Whether it is right is another story :slightly_smiling_face:

@Ma2J that seems to have done the trick. however it seems that we are still limited to low/med/high speeds. setting med-low or med-high speeds results in being reset to medium.

This is the power draw from the MCU in the fan module. It is probably like .6W and is rounded up or something. Our switches / dimmers are the same but the firmware is programmed to round down to 0W if the switch is off. Might be something we update in the future.

I think this might be related to the bulbs. What type are they? LED bulbs seem to have a higher % required to turn on. For example, they might not turn on until they get to 15% but after they are on you can dim them down to 10%. If you raise the minimum level to the actual level they turn on at then the response time will seem quicker.

We will definitely look at improvements with breeze mode. Probably some configuration parameters that can be changed. Seems there are lots of combinations here that one user may like over another.

@njcorwin The fan module only supports 3 speeds + breeze mode. The “fan component” driver that is local to Hubitat has those extra speeds in it but they all map back to the medium speed for our fan controller.

1 Like