Fan/Light switch won't include properly on Z-Wave network

Last year I purchased a bunch of fan+light switches, and installed several of them successfully. Today I finally got around to installing the last one, and it won’t include on my Z-Wave network properly.

I am using Home Assistant with the Z-Wave JS integration. I have 44 other Z-Wave devices that work fine. When trying to include this switch, it gets stuck during the early “interview” stage, and never fully registers in Home Assistant – no configuration options, no entities, and it say it’s “Not ready” even after waiting for > 10 minutes for the interview process to complete.

I tried excluding it in order to start over (exclusion didn’t work), so I force-removed it in Z-Wave JS and then did a factory reset on the switch by holding down A and B for 20 seconds.

Start over…exact same behavior. Below are screenshots of where it “stops.”


For reference, this is what one of my other Inovelli fan switches looks like, included successfully:


Any suggestions?

How close is this switch to your HA Z-Wave stick/device???

It’s closer than two of the other fan+light switches, and it’s in the same switchbox as a Red Series dimmer that had no trouble joining the network. It’s about 25 feet and one floor away.

1 Like

Try factory resetting the switch then re attempt inclusion.

It would be interesting to see the zwavejs driver logs. Unfortunately, I don’t know how to do that in the stock zwavejs integration.

I already tried that, as stated in my original post.

I have tried using the Z-Wave JS control panel to force a re-interview of the switch several times, to no effect. The node status alternates between “dead” and “alive”. During a re-interview, it retrieves some values from it, but then it dies:

Again, this thing is surrounded by a bunch of other fully functional Z-Wave plus devices. It’s not too far from the controller. I think it’s defective?

I would test with another controller before reaching that conclusion. If you have a spare Zwave stick, run the SILabs PC Controller. See if you can exclude the switch from there and then re-add it to the PC Controller.