Firmware v1.41 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

I just went through updating firmware on all my LZW31 dimmers. Happy to report that the OTA firmware update itself went smoothly (no lockups, no bricking, etc.). :slight_smile:

HOWEVER, the need to first remove the devices from my SmartThings network, update, then add them back is a royal pain in the a$$. The process is relatively simple, but the fact that they are added back as new devices means all the rules, notifications, routines, smartapps, etc. all have to be manually reset and reprogrammed. :frowning:

Please please please work on a way to update firmware in a device while maintaining its original identity in the zwave network :pray:

I dont think hubs are able to do a firmware update unless it has been included in the network. If your hub supports OTA updates, you do not need to exclude it. I use Home Assistant with a Z-Stick. All I had to do was plug the Z-sick into a windows computer and perform the update, then put it back. No exclusion/inclusion needed.

It sounds like you already updated everything, but you might have been able to do the following (I have not tested this though)

  1. Factory reset your switch (but do not exclude it from SmartThings first)
  2. Include the switch on your Z-Stick
  3. Update Firmware
  4. Exclude the switch from the Z-stick
  5. Do a “Replace Device” in Smartthings to essentially replace the device with itself. This might allow you to keep all your rules/notifications/etc.
1 Like

I use a SmartThings hub and as far as I know, it does not [currently] support OTA updates. [email protected] mentioned they were working on something for OTA with ST but its not out and unknown ETA. I’m strongly suggesting that we need it sooner than later. If you have more than a few switches, its not practical to do the firmware update as documented now (exclude from ST, include to ZWavePC and update, then exclude from ZWavePC and add back to ST as new).

With that said, your suggestion of factory reset without excluding, update, then “replace” might work for keeping rules/scenes/notifications/etc. Unfortuntately, I have already updated and am in the long slow process of reprogramming back all the rules/etc. But I will keep it in mind and will try your suggestion if I need to do it again.

Has anyone use the builtin firmware upgrade device option in Homeseer to update the firmware?

Eric was hinting that Samsung was working on OTA updates in Smart Things, not Inovelli. Inovelli can’t do anything to change how that is handled. That’s up to Silicon Labs and each hub developer.

Yeah, unfortunately it is up to the hub manufacturer to integrate OTA updates into their hub. We have been discussing with SmartThings this capability and are trying to work with them on it. The reason that our instructions show the method that they do is that it is the most straight forward option with the fewest technological hurdles that can apply to the majority of users. As an alternative you do have a few options (for next time).

As @jtronicus mentioned, you can use the replace method that SmartThings has. There is one additional thing to note for this though. When you reset a z-wave device many newer devices (last few years) will send a “Device Reset Locally” report (as per z-wave specs) to the hub before they reset. The hub is supposed to remove the node at this point. SmartThings will respond to this report by removing the device. So, I recommend that you power off the SmartThings hub while you reset it if you want to use the replace option.

The second option is to include the Z-stick into your SmartThings network as a secondary controller. You put the SmartThings hub into inclusion mode and click on the “Learn” icon in the PC Controller Software. This should obtain the S0 security key that will be needed to update the switch.

1 Like

The second option is to include the Z-stick into your SmartThings network as a secondary controller. You put the SmartThings hub into inclusion mode and click on the “Learn” icon in the PC Controller Software. This should obtain the S0 security key that will be needed to update the switch.

Well that seems like the best way (keeping the switch included in the ST z-wave network and have the PC controller join the existing z-wave network to do OTA) I was wondering if that were possible and if it is, why is that not the preferred method? I’ll try it next time

Hi @EricM_Inovelli, can you clarify a few things with the firmware update?

  1. SmartThings classic app says (fw 1.4) after the attempted update; how do we know for sure if the update worked (1.41)?
  2. I downloaded 2 files from the support site (.bin & .otz) but the instruction only give direction for the .otz file. At what point do we use the .bin file?

Thanks

@ny_robert For number two, you use the .bin file to flash target 1. The otz file is for target 0. It’s vague on the webpage, but it’s in one of the notes squares.

I verified firmware on HE after flashing. I just had to hit the configure button and it refreshed. I also used the Zwave pc controller to verify. I hit Get after flashing both target 0 and 1.

I wonder if your SmartThings is cutting off some of the text. Mine is showing the full version.

image

You can look in the current states in the IDE to see as well.

image

The instructions for the two files are also at the top of the page:

Thank @harjms & @EricM_Inovelli. I re-flashed the firmware and the SmartThings IDE says 1.41. Classic App on iPhone still says 1.4, probably just getting cut off as you said.

@EricM_Inovelli just curious if there’s any more details on the idea of splitting firmware so there’s more room for features? There seems to be a fair amount of desire to have the local settings feature dropped for those of us using hubs that can manage those.

Hey @Eric_Inovelli, can you give any indication of how close we are to the final release?

I tried this and appears to not work. For the OTA firmware update I’m using the “Z-Wave PC Controller” software from Silicon Labs with the zwave.me UZB1 stick . I was able to get it to join my SmartThings network as a secondary controller, but that appears to disable the PC Controller’s ability to do OTA as a secondary. Looks like it can only do OTA when its the primary.

It should work but you need to select the node in network management and click on the “Node Info” icon. This will discover that the node is using S0 security and that the PC Controller software needs to use the security key to communicate.

Edit: When you first join the USB stick with PC Controller software to the SmartThings network it obtains the S0 key. If you close the software it may lose the key so make sure you copy it or save it out of the “Security Test Schema” portion of the PC Controller software.

Honestly I thought it would be out by now. The engineers are ghosting me with the last change requests that I made. I think they got annoyed with my OCD about things being perfect. Also, they might be busy with other projects. I will try to bug them again.

@EricM_Inovelli You may want to check out quote below from this thread. I rechecked my settings, and my HA Hub is displaying “Neutral” for A/C type, when the install is definitely non-neutral and functioning entirely correctly. I’ve only installed the beta software at one normal location, but I could update this switch as well and see if this looks to be corrected with the beta? This user’s aux switch wasn’t behaving until settings were set as follows:

00sl_ghosting-articleLarge-v2

5 Likes

I actually upgraded the firmware of one of my switches in a 3 way config with the 1.41 beta and my setup still needs to be configured as I mentioned in the other thread. Oh well, it works as a switch so I can live with this!

I updated to 1.41 on one switch that kept turning off a few seconds after being powered on in the 3-way setup and the switch is still turning off if I set the brightness higher than 80%. I tried switching the power settings to non-neutral and load only and then back again and it still would shut off.