Firmware v1.52 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

It’s working fine now. Weird.

If I recall correctly they are looking to bring firmware development in-house to simplify these changes in the future. That being said I think they also mentioned something about not getting the firmware for the current switches as part of the contract or something. I suspect @Eric_Inovelli might have some thoughts on that front.

That is my recollection also. Hopefully they will be able to bring more of this in-house in the future.

I think they were getting to reverse engineer the firmware

@EricM_Inovelli I flashed the v1.51.otz file and its reporting that its v1.50??? Not a big deal but just wanted to bring that to your attention.
image

Hmmm, I’ll challenge you on this point. I first requested a configurable delay in Nov 2019 :smiley:… I won’t characterize the initial reaction as 700ms was “good enough”. Many others agreed and joined in the request. So some of us have been waiting for way longer than even you :smirk: so are glad it’s finally here! Hehe!

Ahh yes, looking back I see you were the first … and I will concede that point :blush:

What I meant was the initial reaction from Inovelli was that 700ms delay was not noticeable to most people and those of us saying it was too slow were accused of being Super Human Mortal Combat players :laughing:

The good news is that even though Inovelli initially thought it was fine at 700ms they still listened to us and continued in the discussion where any other manufacturer may have just ignored us. I admire and appreciate that Inovelli listens and asks questions of us. :+1:

Agreed :grin: and Much Thanks to Inovelli! :clap:

1 Like

Using Hubitat C7 I have problem updating the firmware of some LZW31-SN to 1.52. I was able to update the OTZ (took about one hour). But it always crashed in the middle of updating the BIN file. What is the impact of NOT having the BIN file at 1.43 when having the OTZ at 1.52 ?

Have you rebooted your hub and tried again? I had to do that a couple times to get all 5 of mine fully flashed.

Yes I did that few times. I don’t understand why the OTZ never crashed. It took very long but it succeed. But the BIN always crashed.

WOW. It worked. As you said reboot did the trick. But I had 3 devices to update and I had to reboot between each of them… I don’t understand, but at least it worked.

1 Like

Are you using the relatively new “Device Firmware Updater” App? Or are you using the legacy “Z-Wave Binary Updater” device driver?

I have not had a good sucess rate with the new App. I was seeing similar to your experience where the .otz would usually work (slow but works) and the .bin would always fail. I have a little better luck with the Device Driver method (need to change the switch device driver first, then update, then switch the driver back to the Inovelli driver).

I’m using the app. I also tried the driver but never find the one to update the bin. I just google it and did not find it. Do you have the link ?

I finally was able to update the bin with the app after shuting down the hub and restarting it.

Here is the link to github where you can find both the Firmware Updater and the Binary Updater

Haaa, I was there but I did not think there was 2 drivers.

Thank you very much !

Is it a bug ?

Using LZW31-SN VERSION 1.52, i’m unable to have (stable)
Disable Physical On/Off Delay = YES and
Disable Local Control Disable ability to control switch from the wall = YES

It works some times and not the other time.

Edited: After many changing from Yes to NO and to Yes in the parameter, it SEEMS to work.

@EricM_Inovelli can you please comment? I’d like to know if the file you posted in the v1.51 folder is actually the v1.50 file, OR is the v1.51 file incorrectly reporting itself as v1.50? I’ve been updating many switches over the weekend and they’re all reporting v1.50 when using the v1.51 file

Hubitat. Using the Z-wave Firmware Updater. I’m able to update the 1.52 Beta OTZ, but I don’t see that line Target 0 or 1. Goes to 100% fine and shows as 1.52 when done. How do I do the next 1.43 Holtek then, or do I not need to do it… ?

I figured it out - there are 2 versions of the Z-wave Firmware Updater - both labelled v 1.00 - how interesting, I figured the one with more lines (706) was the correct one…

Man this is going to be EPIC! Thanks for the continuous improvement on these devices. What a thrill it has been to be along for the ride!

Has anyone started the openzwave PR for this update? On HA and want to be able to implement this firmware on HA, but I’ve never been through this process before.

I’m on OZW 1.6 beta, what is the path to getting that implemented?

@nathanfiscus I see you are a contributor already, just wanted to tag you so you see this firmware update!