Firmware v1.52 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

We are releasing a beta firmware for LZW31-SN users as a follow up to v1.48. It has several bug fixes and enhancements. See the release notes in the link below:

We have not done much internal testing on this version yet, so proceed with caution. Let us know if there is anything abnormal.

4 Likes

Woohoo! Guess I know what I’m doing tonight. One question, why is the bin 1.52_1.43 vs 1.52?

Thanks @EricM_Inovelli . Would we also need a new driver on Hubitat for the configurable delay?

Yes, we’ll have to update the driver. In the meantime, I’ve had luck using this to edit the parameters.

Let me try to find the byte info real fast.

Edit: 1 byte, Values = 1-9 (1 = 100ms, 9 = 900ms, etc - default = 7)

2 Likes

How about smartthings? :grin:

1 Like

Lol - yeah same.

I think you can use Z-Wave Tweaker located in this thread. I haven’t tried it tho!

1 Like

Guys, this works great! Thanks so much for releasing this! I’m torn between 300ms and 400ms. Might settle on 400ms.

Please any timeline on when we should expect these for LZW30-SN?

Finally, unfortunately it appears that this doesn’t affect the dimming delay (hold delay). I have 2 LZW31-SNs side by side. I updated 1 but not the other and tried dimming with both but they still started dimming at the same time. The tap delay is more important to me than the hold delay though so I’m still very pleased!

And can I just add that 400ms is muchhh better than 700ms! You should really ask the manufacturers to make the default 400ms.

1 Like

Do we need the parameter number? I see it in the example.

Oh yeah, my bad - parameter #50

1 Like

Oops. I should have checked the change log. It’s listed there.

1 Like

I ran into issue flashing target 0. I closed and reopen the PC Controller software several times, refreshed the node info, and ran a get on the update screen. It eventually worked but I got the following error several time in version 5.39 and 5.50

“Status: Invalid Fragment Size=0x02”.

Just to make sure I am piecing things together correctly regarding smart bulbs.

If the dimmer is running 1.52 with smart bulb mode enabled (and association configured) - we can leave the relay enabled so the status LED will reflect the bulb brightness again?

If that’s correct, I need to excuse myself to perform an update :smiley:

@amdbuilder verified this morning. With smartbulb mode on and you press down on the paddle the strip dim to off and the power stays on! Power is cut off you turn the bulb off in ST app. I need to do some more experimenting.

1 Like

Damn, I didn’t even know this. So the LED bar officially tracks with the smart bulb now?

I’ve been so busy I haven’t been able to keep up on the firmware updates lol

1 Like

I think so. I didn’t have a smart bulb connected. I had a regular LED in the fixture and it remained at full power while the LED strip dimmed up and down. If I get time tonight I’ll exclude/inclued the dimmer in S0 and swap in my illium. All of my testing was with local control enabled.

Nah. With smart bulb mode on and regular bulbs, you’ll get the LED bar to track, but bulbs remain at full power. This was like that on 1.47.

With 1.47 when the LED bar dims to zero the bulb turns off. With 1.52 the bulb remains on.

2 Likes

ahh, I think I read what you were saying wrong. I can dim the bar all the way down and the bulb(s) remain on; however, if you press paddle down 1 x to turn off, the bulbs now remain on, correct? If so, completely agree on the 1.47. I’ll have to upgrade to 1.52 to check out these new features. I can’t wait until the 1ms adjustment comes to fruition (j/k).

1 Like