Firmware v1.52 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

You got it. Single tap dims all the way down, LED bar turns off, and bulb remains on the whole time.

1 Like

Sorry for not updating the driver / handler yet. Many of you have already figured things out. The main changes are the adjustable delay and the Smart Bulb mode. We have kept the ability to turn off the device via z-wave (in smart bulb mode) in case power needs to be cut. This can be modified or the driver can be changed to not send commands when smart bulb mode is enabled. I thought having the ability to turn off the bulb remotely may still come in handy.

Anyway, I’ll try to update the driver / handler tonight.

2 Likes

I’m trying to include one of my dimmers in S0 using the search nearby function. I recall seeing this is a recent issue. Any advice on how to do this? I’m trying to associate with one of the illium bulbs. Ask I can get is S2_Failed which shows up as zw:L vs zw:LS

I’m pretty sure ST changed something and you’re not going to be successful. This is an ongoing issue.

1 Like

So I just flashed 5 switches with this firmware and am having an issue with 4 of them. They defauled to disabling the 700ms delay even though my preferences have that setting NOT enabled. So i switched it back to No and configured and refreshed the switch but they are still acting like its disabled. Any tips on how to fix this? Those same steps worked on the first switch I flashed last night but the 4 I did today it doesn’t seem to work.

Sounds like you may have tried this already, but toggle the setting to yes, then save, then back to no and save again.

Try setting Parameter 50 back to 7. When a new parameter is added in a firmware update, the memory space that parameter occupies does not appear to be cleared, so the switch may think you set a much shorter delay (mine was set to 1 when I flashed the update).

1 Like

@EricM_Inovelli yup, that fixed my first switch but didnt have any effect on the other 4.

@jtronicus I’ll give this a shot and see how it goes.

@jtronicus I think you might be right. Just double clicked one of my switches at superhuman speed and it sent the scene command properly.

The problem I see with this approach is it makes it impossible to keep the LED strip is in sync with the bulb when controlling via zwave.

Ideally, I would add the bulb in groups 3 and 4, and when I want to control the bulb I send the command to the switch, which will in turn forward the command to the bulb (similar to setting up a virtual 3-way). With the current setup, I can change the brightness from 1-99 via zwave, or control things locally, but I am unable to turn “off” the LED strip via zwave. If I truly need to cut power to the bulb, I can always pull the tab at the bottom of the switch to physically cut power.

I also think a worthwhile enhancement would be for the switch to send a dimming duration value (in the multi-level set command) that matches the values in parameters 2 (when holding the paddle buttons to change the dimming level) and parameter 4 (when turning the light on or off). Right now, the switch sends a dimming duration of 0xFF (default), so there is no way to change the dimming speed of associated devices when controlling them from the switch itself.

1 Like

+1 for modifying firmware so turning off from zwave doesn’t cut power. It’s really useful to have the switch maintain an on/off/dim level that I can use in home automation, without the automation ever causing smart bulb to lose power. For instance an automation that turns everything off at night.

I’m in the process of installing the switches, and for the first one controlling a smart bulb (non zwave, so dimming is laggy but functional) I’ve resorted to hardwiring load to line (would be really nice to be able to change things in the future via settings rather than having to pull the switch out and change the wiring)

1 Like

Hmmm, seems like I may be losing a certain functionality here. If I’m understanding this correctly, enabling “smart bulb mode” now keeps the load power on all the time (unless a specific zwave command is sent to specifically turn it off). Previously, it disabled dimming (kept voltage at 120v) but still turned on/off. While I understand this probably makes more sense with smart bulbs (powered on all the time). I did like the way 1.47 worked where this setting essentially disabled the dimming of the load but still did a true power on/off via the switch.

I have several places where I’m using these switches with non-dimmable loads. I hear you asking “why are you using an LZ31 dimming switch and not an LZ30 on/off switch”? And the answer is three-fold:

  1. I buy in bulk and most all of them are LZ31. Its a bit of a nuisance have to buy single LZ30’s for the few cases where the load doesn’t like dimming (I know it sounds petty, but hey I’m being honest).
  2. I use the LED bar notifications a lot. Its a big feature that sets Inovelli apart and the main reason I chose Inovelli over the other brands. I know I can do some notifications on the LZ30 but its not the same as the LED Bar on the LZ31. The codes are different (what a pain) and it simply doesn’t look the same with one small LED compared to the full LED BAR … especially when there are mixed switches in a multi-gang box.
  3. I may later change bulbs in some of these locations (change non-dimmable to dimmable) and it would be nice to just change bulbs without having to replace switches when this happens.

With V1.47 I could make an LZ31 control a non-dimmable load by enabling Smart Bulb Mode. Everything else works the same and is consistent with all the other switches (and I like consistency :slight_smile: ) But with V1.52 I will no longer be able to switch on/off with Smart Bulb Mode enabled.

I really want to update to v1.52 to get the new settable multi-tap delay, but I don’t want to lose the “disable dimming” capability I have with v1.47 So my question is this: Are there other settings that will allow me to use an LZ31 with non-dimmable load and still be able to turn it on/off at the switch (without having to set up scenes on the hub for every switch)? Ideally, I think the “Minimum Level” setting would be the right answer, but unfortunately that is currently restricted range of 1-45. If I could set Minimum Level to 99 that would effectively disable dimming for non-dimmable loads while keeping all the other functionality. But that is not currently an option.

@jtronicus @joshfee @stu1811 and @mamber – I’m going to start a separate thread to discuss Smart Bulb Mode as we really want to get this dialed in and we’ve tried our best to perfect it, but it sounds like there is still room for improvement.

Hang tight, while I write up a post about it and I’ll look forward to the discussion as this is a major selling point and huge need in the industry right now.

Thanks so much for your input and suggestions, we really appreciate it!

EDIT: 5hrs later, I’ve finished writing all about, “Smart Bulb Mode”: Smart Bulb Mode Optimization Thread – I need a break from smart this topic for a minute lol. It was good to finally talk about it and write everything down though.

2 Likes

You could create a scene for a single down tap that issues an off. The zwave off still kills power.

Thanks Eric, I appreciate it and look forward to participating in the discussion. I realize my use case is not really “Smart Bulb Mode” It just happens that the previous functionality of that setting was very useful to me as a “non dimmable load” setting and I think there is value in having some form of that

Yeah you probably missed this in my lengthy post… :blush:

ooo shiny. distracted. you got it.

LOL. I was thinking more along the lines of some combination of “disable relay”, “disable local control”, and “disable remote control”. Might get me close, but admittedly I don’t fully understand the meaning and function of those settings :thinking:

disable local control - Disables control of the relay via physical interfaction. Commands are still send to the hub via zwave and scenes work. This is useful when a switch is associated with zwave bulb. The dim, on, and off commands are forwarded to the bulb which then does what you want.

disable remote control - same as local except it blocks zwave commands vs physical interaction with switch

1 Like

Just so I’m understanding correctly, is it as simple as you’d like a way to turn on/off a non-dimmable load without using scene control? I’m likely missing something, and the caffeine hasn’t kicked in yet lol.

1 Like