Firmware v1.53 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

Edit: There seems to be some kind of issue with 1.53 that is making some of the parameters not work. The engineer is looking into it. I’m pulling it down for the time being.

We are releasing a beta firmware for LZW31-SN users as a follow up to v1.52. It has several bug fixes and enhancements. See the release notes in the link below.

A quick note is that we are still working on optimizing smart bulb mode. This release makes it so that sending a z-wave “off” command to the dimmer will no longer turn off the load in smart bulb mode. With the communities help we have come to realize that the old way that we used to do smart bulb mode was good for some (those that want to use the dimmer as just an on/off device), but the new way is more optimal for others (those controlling smart bulbs). In the next release we will modify smart bulb mode to have 3 options:

0 - Disable
1 - On / Off mode (ideal for those that want to control a load that cannot be dimmed but they still want to be able to turn it on and off). Will work similar to 1.48.
2 - Always On mode (ideal for those that want their smart bulb to always stay on). Will work like 1.53.

Firmware Change-log: LZW31-SN - Dimmer Switch (Red Series) (


@EricM_Inovelli Looks like the link on the download page still points to 1.52.

1 Like

Thanks, fixed it!

I flashed both the new firmware images to the dimmer and the smart bulb mode behavior works great.

The only issue I am experiencing is that the the LED Strip Color seems to be stuck on blue. I have attempted update the parameter to other colors and never changes from blue.

I am experiencing the same issue on all my dimmers that I updated. LED indicator is stuck on blue.

Edit: Its doing something weird with parameters. When I send a command to get a parameter value, the device appears to be responding with the value of Parameter 1 (not the parameter I am requesting.

The following parameters appear to be affected: 7, 9, 10, 13, 14, 15

Did you do an exclusion and or factory reset?

I am seeing this too after a factory reset. I’m going to pull the file while I check with the engineer.

@EricM_Inovelli – Is there any update on the 1.53 beta (or prod) being available again? Really excited to get that firmware loaded, as I want to use On/Off mode!

Production v1.48 behaves like “on/off” mode when Smart Bulb mode is enabled.
Beta v1.51 also has on/off smart bulb mode AND the adjustable Button Delay.

You only need 1.52 or 1.53 if you want the “always ON” flavor of Smart Bulb mode

I see, thanks for that clarification. I was confused as to what On/Off meant - I had hoped it meant “don’t dim the load up when turning on/off.” I have some non-dimmable smart bulbs, but I do actually want to do a power cut to them on depress of the down button. Right now, I get the dimming behavior, I think, as the smart bulbs flicker on when restoring power to them. I have four of them in a circuit on this switch and have not figured out how to stop the flickering behavior…

There was some miscommunication with 1.53 and the engineer is working on 1.54 to fix the issues. It will probably be a week or two.

For the flickering, you will need to set all of the dimming speeds / ramping rates to 0.


Ok, now I’m a little confused. So the “Smart Bulb On/Off and Dim” actually changes the load to the bulbs?
I didn’t realize any of the smart bulbs would work with the load lowered/dimmed. I guess I could see cutting the load to them so they don’t use power when off, but it seems like that would cause other issues with Zigbee or Zwave networks when nodes appear/disappear.
Is there a table or chart somewhere that shows the different features based on the firmware? I’m been trying to follow the release notes and change-log, but I’m not sure I’m following now :crazy_face:

Yeah, uh, no.

From my perspective, you have the Old Way and the New Way. The New Way is still coming due to circumstances. There is also an Immediate Way, but as they say in New York, fuggedaboutit.

The Old Way is 1.47/1.48 which are essentially the same. There are two things that are manipulated, Smart Bulb Mode and Disable Local Control (the concept formerly known as Disable the Relay, RIP).

Enabling Smart Bulb Mode makes sure that the dimmer always puts out full power, which you want with a Smart Bulb. Enabling Disable Local Control prevents the switch from cutting the power to whatever is attached to it. When using a Smart Bulb you want both enabled. But there are those that want to use the dimmer as the switch, so up to this point the two functions were kept separate. (You can enable Smart Bulb Mode but not Disable Local Control and mimic a switch to some extent.)

And then the Great Relay Wars began, with wailing and gnashing of teeth, and much confusion about why the two functions were separate. And from those ashes arose the Intermediate Way of which I will not speak.

I would wait for 1.54. Basically, the goal is to accommodate the two functions both singly and separately. You’ll be able to turn on the Smart Bulb Mode and have it automatically Disable Local Control for those using Smart Bulbs. It will also allow those who want to use the dimmer as a switch the ability to not Disable Local Control while still enabling the Smart Bulb Mode.

Basically, you’ll have 3 options, off plus the other 2 I just mentioned.


Ah, thank you. I think I’ve got it now.
So “Disable Local Control” is actually to disable the scene control at the switch to remove the delay needed to identify the multiple taps.
That is actually what brought me here. I have a Red series dimmer with the original firmware. I was using it with smart bulbs before, but recently moved it to control non-smart bulbs and the on/off delay is horribly slow.
I hadn’t previously bothered with the firmware update since the “Disable Relay” had been working great with all the Red Series switches. The dimmer however, I never got working as I wanted with smart bulbs so I decided to move it to a bathroom where the large LED could be used as a nightlight.

So it looks like I just need to update to 1.48 to get parameter 51 to remove the delay.

It’s actually disabling whatever the switch is physically wired to. It will still work as a scene controller using the multiple taps.

Yes. Or 1.47 unless you’re on a Hubitat C-7 or some other hub with which there is a S2 bootstrapping issue.

I feel like I need to make a video with all of this spelled out. Or perhaps a wiki article… ERIC H IM LOOKING AT YOU…

Super short version:
Disable local control disables local dimming/offing of the switch. Instead it sends scene data that is used for manipulating devices. The LED bar is then locked at the state when set or as controlled by zwave.

Smart bulb mode keeps the output at 100%. Currently from level 1 to 99 output is at 99. This does enable smart bulbs to operate but yes kills them/therefore the mesh when at level 0. New firmware will say keep on at level 0, which will command the bulb to off (not turn it off) but keep the mesh intact. You will be able to select whether to:

Keep normal operation (dim)
Turn off when at level 0, otherwise 99 (non-dimmable bulb mode?) - (@Eric_Inovelli 2021 sweater?)
Keep at 99 output always no matter what (smart bulb mode).

DIBBS! I want one :smiley:

Hold on here… “kills the mesh”. Are you suggesting that smart bulb mode somehow interrupts the ZWave mesh? I am having horrendous and ongoing problems with ZWave scenes on Hubitat. If there’s a connection here I’d like to know!

I think what he’s saying is that there was a bug in the prior firmware where if the switch went to 0 in SBM, it actually cut power to the smart bulb which would kill the mesh.

This is not the case now (nor should it ever have been) so your mesh will be fine as your bulb is always on.

Say it ONE MORE TIME!!! Lol Killin me :rofl:


Pretty close. Essentially if Smart Bulb Mode is enabled/on in settings, if the switch is set to level 0 (off) it will still kill power to the BULB, and the z-wave radio inside would then no longer be powered.

The z-wave mesh is healing, but on again off again is going to cause heartache in the mesh FOR SURE, which is why I have mine never EVER allowed to go to level 0, just Level 1-99.

What I never though of, is this is GREAT for non-dimmable bulb applications for those who want the fancy bar (and let’s be honest, EVERYONE wants the fancy LED bar)

New fancy 1.5# firmware will allow those, but ALSO an option to keep the load on no matter what the switch level (0-99). I’m very excited for this!