Firmware v1.55 (Beta) | LZW31-SN | Dimmer - Red Series (Gen 2)

Totally a SWAG on my part, but my supposition is that the offshore firmware coder forgot about the Traveler terminal when adding SBM. :thinking:

I flashed 1.54 to a single pole non SMB dimmer. The default value for 52 was 1 (or previous… I forget) and I freaked for a moment when the lights didn’t dim. The led bar did dim! Yay! Changed 52 to 0 and everything was fine. Previous firmware was 1.52.

May have found either a bug or just a 1 off. Flashed three switches and one of them doesnt want to work at all. The light its connected to is on at about 25%, the switch is completely unresponsive and the LED bar is off when it should be 40% pink. If I pull the air gap and put it back in the LED bar comes on like normal, starts to go back to normal by switching to pink but then immediately goes red/blue/green (or whatever the sequence is) then goes off and ends up in the same state as before. I wasn’t able to flash the .bin file because it became unresponsive after flashing the .otz file. I flipped the breaker to it once and saw no change. When trying to use the config button for any of the extra functions like disabling the relay or factory resetting it I get no response. I think I covered everything I tried. Any info would be greatly appreciated.

Forgot to mention, the light is wired with a neutral and no bypass and has worked flawless up until this point.

You can try a factory reset. Hold config button 30 seconds until it turns red. If that works try reflashing the otz.

Sadly I’ve already tried that and got no response from the switch at all.

With this release I am seeing an issue in on / off mode where the physical down button does not turn the light off. Smart Bulb mode does seem to be working.

I had an issue where some scenes were not reporting but after a factory reset they were. Not sure if that was a fluke or not. I did try to change some config options and change them back.

3-way in Smart Bulb mode with a dumb switch hasn’t / doesn’t work. This would require “juggling” the power output across the load and the traveler when the dumb switch is toggled. This can result in power being cut to the bulb for a short amount of time.

1 Like

Agreed. I am seeing the same thing.

Agreed. This could be problematic for smart bulbs in ‘always on mode’ SBM (param52=2). However, it should not be an issue for ‘on/off mode’ SBM (param52=1).

@EricM_Inovelli any thoughts on the issue I posted above?

I suspect the switch behaviour could be unpredictable if you weren’t able to flash the new bin file that goes with the new otz file. Have you tried flashing the new bin file again?

The switch is 100% unresponsive via physical button presses and via Zwave. Hubitat can’t control it or even see it to flash anything.

Version 1.55 is up to fix the physical off button in on / off mode.

@mamber I will see if there is an option to implement 3-way with a dumb switch in on / off mode.

@Byarnell05 If you quickly do a 3x tap of the config button after booting the switch can you do an exclusion?


That was fast. Can you update the beta link to 1.55 on the firmware page

Edit: link is correct but text says 1.54

@EricM_Inovelli the link goes to the .55 file, but the ‘label’ on the link still says .54

1 Like

Yep. I caught that after clicking on it. I edited my post as you were replying.

@EricM_Inovelli the on/off mode now works as expected. Thanks!

1 Like

I concur. Tap off now works with on/off SBM enabled. Thanks @EricM_Inovelli for fixing it so quickly! :+1:

Thanks for looking into it. I look forward to hearing what you find out. :cowboy_hat_face:


@EricM_Inovelli It took a few tries to get the right timing but I was able to get the switch to exclude and that seems to have fixed the problem. Once excluded the LED bar changed to default blue and I was able to include it again with no problems. Thanks for your help!

Well I seem to be having a different issue with a different switch on 1.55 now. I flashed one and it won’t allow me to set any parameters. My 50-52 Parameters won’t change at all and 50 and 51 look to be flopped when it comes to values.

Current Values:
parameter50value : 0 - Can’t get this to change to anything other than 0
parameter51value : 4 - Can’t get this to change to anything other than 4
parameter52value : 1 - Can’t get this to change to anything other than 1

Isn’t Parameter 51 supposed to have only 2 options? 0-1?

I have tried toggling all of these back and forth and have tried using the drop down menus, the set parameter button, and also switching the driver to a zwave tool and setting them that way but they don’t budge. Any help would be greatly appreciated.


I hate to say it, but you may need to do a factory reset on it and re-include.