Frustrated with my LZW36's

So, I pre-ordered 4 LZw6 switches.

1 of them failed, and I ended up getting it replaced, it would not report button presses to my HE.

the other one has to be Airgapped at least every other day otherwise HE will not turn it on or off, or change anything.

the third one, I noticed that the light was on this morning, and when I tried to turn it off on my app it did not respond. so I reluctly went to the switch and turned if off by the button. But then I noticed that it would not respond to HE also. so I did an airgap.

I went into the device, and turned it on. It went on, but did not report that it was on, and hence would now NOT turn off.

After a bunch of fiddleing with it, I refreshed it, to no avail, I messed with the child and parrent devices in the device tab, no go. did a Z-wave refresh and no go. then just randomly, it turned on and showed ON! then I tried to turn it back off, no go.

again, I sat and fiddled and then it just started blinking, going on and then off like a disco!

right now, it was off, I turned it on via the child device, and it turned on but shows OFF! .

I’m tired of these, just frustrated since every other switch in the house works great.

I checked it has the recent 1.36 firmware.

Any ideas, what I am doing wrong here? is there a newer FW that I could try?

I’m on an HE-5 with updated firmware also.

I’m going to hold off for the winter season, but I need to order a few more. do you think this is a fluke, (3 out of 4 switch’s seem to have been giving me issues)