General information on how to install LZW30-SN connectly

Red Series LZW30-SN
Neutral Setup
3 Way - two switches
Dumb switch as the secondary location (can get the add-on if it will solve this problem)

I really really wished I would’ve of taken pictures of the switch where I installed the inovelli product before and after. From what I remember dumb switch had three connections. Two black wires and red one. The neutral wires were tied up and left in the back.


I attempted to install your product yesterday and wanted to verify some information on my installation where it turns on 4 kitchen lights (tube lights ~ 180 watts reported by Inovelli) in a location that can be turned on or off by a total of 2 switches. Both used to be dumb and now one is an inovelli switch.

Currently the inovelli switch will turn on and off my lights correctly without any trouble unless the dumb switch is turned off. At that point the inovelli switch will not turn on or off my lights or have any LED lights on. Did I plug it into the incorrect location?

Also the switch does not have a pretty designation/name in homeassistant did I also make mistakes here? I attempted to follow your instructions for home assistant but the folder location is not available. My installation is just a esxi virtual machine and I have the ability to install add-ons. I got stuck on step 3 of the following KB: installation-setup-lzw31-sn-dimmer-red-series-gen-2-home-assistant

When the Inovelli only works with the accompanying dumb switch in one position, there are two possibilities:
1 - The switch is wired incorrectly
2 - The switch is not configured as a 3-way neutral

#2 is easier to troubleshoot. I can’t help you with HA, but you don’t need it to set the switch parameters. They can be set from the switch itself. By default, the switch should be set as a neutral 2-way installation. So at a minimum, you need to tell the switch the installation is a 3-way. Did you configure the switch at all?

I did not, this is not for the dimmer. This is for the red series switch on/off, is that still something that needs to be configured? If so I am ready. How do we proceed.

Yep, you are correct, that’s generally for the dimmer. The switch is supposed to auto-detect, but some enhancements were made to the switch for such situations, depending on your firmware level. Since you haven’t been able to add to HA, I’m not sure how to determine the firmware level.

Tagging @harjms as he is experienced with this firmware enhancement.

Did you check the other switch’s wiring? Were there 2 blacks and a red connected to that switch as well?

@chris1benassi - I would upgrade to the latest firmware so that you can manually configure; however, I think it’s only an option from a hub. Let me look when I get on my laptop.

I will check second location switch wiring later today.
I just got called into work, luckily its work from home so I will have time to tinker.

Any assistance on checking firmware version is appreciated.

I found this, let me know if it helps

zwave.inovelli_unknown_type_0002_id_0001	ready	node_id: 5

node_name: Inovelli Unknown: type=0002, id=0001
manufacturer_name: Inovelli
product_name: Unknown: type=0002, id=0001
query_stage: Complete
is_awake: true
is_ready: true
is_failed: false
is_info_received: true
max_baud_rate: 40000
is_zwave_plus: true
capabilities: routing, zwave_plus, beaming, listening
neighbors: 2, 3
sentCnt: 12
sentFailed: 0
retries: 0
receivedCnt: 39
receivedDups: 0
receivedUnsolicited: 32
sentTS: 2020-10-13 05:38:22:123
receivedTS: 2020-10-13 17:04:04:467
lastRequestRTT: 109
averageRequestRTT: 94
lastResponseRTT: 134
averageResponseRTT: 184
application_version: 1.20
friendly_name: Inovelli Unknown: type=0002, id=0001

So, firmware 1.17 added parameter 13;

"Add parameter 13, for some special load types. Can be used in certain 3-way dumb switch setups where the load is confusing the switch as to which state it should be in.

Parameter 13
Size: 1 Byte
Default: 0
Range: 0-1
0: Detect Load Type.
1: Manually set for special load type."

However, I would recommend upgrading to 1.19 if you can include it to a Z-Wave stick to upgrade.

I’m not familiar with HA, but you may want to read this thread as it may point you to a solution:

I just wanted to say @chris1benassi – first Mexican flag I’ve seen – welcome!

Thank you for the welcome Eric! Appreciate the flag selection menu, was a bit confused if it represented where I reside or hometown/nationality.

Anyways team, the weather is no longer miserable and felt like tinkering.

Are we still going to investigate if this is a configuration issue with the smart switch? Or is this an issue with where the switch is located? If so it appears I already have the switch added to Home Assistant, it does appear like it fails to register properly however I was able to power on and off (as long as the dumb switch was on).!FrUueRDuJfEnkfdDVXBSSHdrVlJITEUkDA

Here are a few short 1-2 min videos and pictures, please focus on the switch furthest to the right. That is the switch that controls the kitchen light. [Living Room Lights] [Fan on and off] [ Dining Room Light] [Kitchen Light]

This answers Bry question, there is a red and two black and a fudge lot of daisy chaining.

Hoping for some good news, especially since these lights consume 180 watts on average (as measured by Inovelli) but there are other locations I can probably use this. We will still be dealing with 3 way wiring but fewer daisy chains.

I switched from the integrated Z Wave in Home Assistant to Open Z Wave beta. It has a proper description for the device and I think I am moving in a proper direction. Next is updating the firmware after that we can rule out the switch and the issue likely a wiring issue. (I may relocate this switch to a simpler location)

Guide to setting up Home Assistant > Open Z Wave Beta
Edit 1: Looks like firmware is 1.20, so need to update, how do we ensure or verify it is indeed 100% operating in 3-way mode?