Hardware based factory reset method for red series dimmer?

So before any one says it, yes, I do know how to factory reset switches by holding down the configuration button. My problem is a little different and probably self-inflicted but hear me out before you link me to the manual or tell me to hold down config button.

I had several of my red switches configured as dumb zwave slaves (no connected load) to a grouped master switch. Two pairs of master/slave switches grouped with each other. i.e. all button presses etc from slave were sent to the master switch and vice versa. There’s several threads around doing that but long story short that was not the issue exactly, the grouping was working fine. I had other zwave performance issues around the zooz 700 series stick I had. That issue is also being discussed heavily elsewhere, not related so I won’t go into it.

However, because of that I bought a new controller stick for my Home Assistant deployment, reset all my devices, and re-associated everything to the new stick on a fresh HA install. Except the two switches that were “slaved” to other switches are not allowing me to factory reset them. Holding down the config button simply does nothing, no LED change, no reset. I suspect what is happening is that those switches are still trying to send the button presses to their former master switches which were factory reset. Inclusion/exclusion attempts also fail however it does blink like it’s trying to include/exclude. I’ve tried powering up the old stick on the old HA install which still has the associations but that’s failing miserably to connect to either of them at all, just says the device is dead and won’t let me even see the group associations much less clear them.

Looks like I might have dug myself a hole I can’t get out of here. In retrospect I obviously should have cleared the group associations and reset parameter 12 to defaults BEFORE I switched to the new stick and reset everything else but since that ship has already sailed, is there any way for me to do some kind of hardware reset of the switches that does not rely on holding down the config button? Or have I managed to find an innovative way to brick two switches?

Thanks in advance.

p.s. I fear for such an advanced issue I may need to go stright to @EricM_Inovelli

I hate to be the one saying this since changing from one stick to another sounds like a journey you’re just getting started on. There’s a firmware update for the zooz 700 stick which fixes the issues they were having with the zwave 700series chips.

I don’t personally know of another way to reset them, or why the normal reset procedure isn’t working. But something you may be able to try… when reconnecting your old stick, they’re likely showing dead because the route they used to communicate is likely gone. I’d get that stick as close as possible to the devices, force remove the broken nodes that are left on it, and run a network repair. This should re-route them and let you change the config.

1 Like

That doesn’t make sense. The switches don’t send config button presses to the associated devices, only on/off and level changes. Maybe the firmware has a bug that breaks the config button from working?

There is no change at all, you don’t get the green/red range indication or the yellow parameter editing color before the red reset indication?

Usually when an association is “broken” the device will exhibit some time outs as it tries to communicate to the “dead” node. It usually makes things seem slow, but I haven’t seen it break the config button reset.

One thing you might want to try is to pull the air gap and put it back in. Then, immediately after it boots up, hold down the config button and try to do the reset.

Yeah i’m sure the path to those devices is gone and I checked and they never had a direct path to the controller. Might be able to get the old stick closer but it will be a pain. The old install was on a NAS that does not have wireless and is not exactly portable and of course they are hard wired light switches so I really don’t want to have to temporarily install them upstairs. I suppose there is simple zwave stick management software that I could run off my laptop that might allow me to take that stick closer to the switches. I’m used to doing everything in Home Assistant though and i’ve no idea what 3rd party software would let me clear the group associations reliably.

Also, I’ve heard about the firmware updates for the 700 series but that news didn’t break really until a little while after I’d already ordered the replacement stick. I did this all a month or two ago and the new/older 500 series stick has been working like a champ so I’m not sure I’d go back anyway just to gain the provisioning features on the 700. Plus it’s a dual controller that added zigbee which I’ve started using a tiny bit anyway. I’ve just been ignoring the two switches I messed up and have finally gotten back around to trying to fix them.

Maybe it is a bug then but it’s most certainly not bad hardware or a fluke anyway as I was able to reproduce it (albeit unintentionally) on two switches.

I want to say I did try this once but it was a while ago so I tried again and nothing. Lights never change on a long press of config button even waiting upwards of 30-40 seconds there is no reaction. I can triple tap config and it goes into inclusion/exclusion mode or at least the LED blinks just like it was but it will never actually include or exclude and regardless what I really need to do is not exclude but to reset it. Excluding it without clearing the associations might leave me in an even worse situation.

I think maybe I’ll just have to get creative in getting the old controller closer to these switches. I have some long network cables and should be able to move that box within range if there’s no other magic trick to reset these switches. If I do get a connection back into them I’ll grab some screenshots and dumps of the current params since I seem to have stumbled on a new and innovative way to break this product. :rofl:

Maybe you can reproduce it.

Ok. I fixed them. I got some extension cords and long LAN cables and got the controller close enough to one of them to directly talk to it and remove the group associations but that didn’t fix it. Still couldn’t factory reset. (the plot thickens…) Reset param 12 to defaults. Still no go. Started going through every single param and putting them back to factory default manually and finally noticed I had disabled the internal relay aka Local protection state (makes sense as there’s no actual load on these switches). Well apparently that’s the kicker as putting that back to [0] Unprotected allowed me to factory reset the switch the normal way.

Now the other switch I could not get the controller to talk to at all even though I got within 20 feet and clear line of sight to it. However, now that I knew exactly what I was looking for I consulted the manual (thank you by the way for such a well written manual) and did the config x 8 press to toggle internal relay and it did take that command and re-enabled the internal relay. Then it would allow me to factory reset normally. So really that’s all I probably ever needed to do all along was toggle the internal relay. It just never occurred to me that this would be the cause. The group associations issue seemed so much more likely.

2 Likes

Glad you got it working!!

Hot tip that may make it easier for yourself in the future, or others. In a situation where you need to get a switch close to a controller, it’s usually easier to setup a makeshift power source for your light switch than it is to move the entire server. Grab an old extension chord or PC power cable, cut the female end off and you’ve got a hot wire, neutral wire and ground wire. Connect those to your switch and you’re now portable. Just plug the chord into the wall in the server room and you’re all set.

2 Likes

Good to hear.

I have a dimmer working as an associated remote only. I didn’t turn on local protection and it still works fine.

Alternatively, you can also just buy a power cord with an open-end (something like this) for those without an extra cord lying around and/or the equipment to cut open a cord. * This is not an official company suggestion, proceed at your own risk.

2 Likes

So is this a bug or is disabling the internal relay (aka Local Protection State to 1) actually supposed to disable the ability to factory reset the switches?

Sounds like a bug to me.

I could see disabling local control doing that, keeps someone from pressing buttons until something happens which would be the switch resetting.

I didn’t know that enabling local protection blocks a factory reset. Tapping the config button 8x toggles the local protection on / off so I will have to keep that in mind in the future.