Help - Unreal Difficulty with Inovelli Red Switches

Hi All …

Like Obi wan Kenobe … I feel this may be “my only hope.” I’ve sought help on Reddit and some other sites without success to this point.

Long story short - trying to migrate from HomeSeer to HomeAssistant. Most of my z-wave network is Red Series Dimmers and On/Off Switches (LZW31-SN and LZW30-SN). I have a few Zooz scene controllers and a relay as well. I purchased a Zooz ZST39 800 Zwave stick. Unfortunately, I have had nothing but issues with pairing this Z-wave stick with my switches. I tried both Zwave JS and Zwave JS UI. I excluded, reset, included over and over again. I tried using my Z-wave stick on an extension cord right next to the switch. None of this seemed to make much of a difference. I purchased a “ATRIM” Z-wave stick (shows as a Silicon Labs stick). Seems to have the same issues, to be honest - didn’t make a difference.

Of note - I’m having FAR LESS issues with pairing the Zooz controllers vs. the Inovelli controllers. I have no idea why this would be the case.

I did get some suggestions on how to address this, one of which was to upgrade the firmware on all of the switches. Downloaded PC Controller to accomplish this. Used the Atrim stick in my laptop to accomplish this - excluded and then added the switch onto the network. Updated the firmware. Few minutes later - success. Excluded it again, then included it on my Zooz stick which is connected to HomeAssistant.

Did this successfully for about 5-6 switches. Then had one switch fail during firmware update (LZW30-SN) and … everything had ground to a halt. Now the Atrim switch on my laptop with PC Controller won’t add, won’t exclude, won’t allow me to update firmware. It won’t get node info. I’ve reset the switches. Airgapped the switches. unplugged the USB. Reset the network via PC Controller. Nothing is making a difference.

I’m also noticing that the Inovelli switches are giving me an incredibly hard time in adding. Some won’t add secure (S2)… some just seem to not want to exclude/include. It’s like the switches don’t like the Zooz 800 series sticks.

Friends - I’m at a loss. I really don’t know where to go from here. @Eric_Inovelli and @EricM_Inovelli

  • I’m not sure why this is happening or what else I can do to make this work. I’d appreciate any help you all could provide.

Thank you all in advance…


So tonight made a concerted effort:

  • Using the “Atrim” Z-wave stick in my laptop, excluded and then included the device
  • Using the same stick, updated the firmware in each device
  • Using the same stick, excluded the device once firmware update was complete.


  • Added the device back to HomeAssistant - with increased success. Got about 10 devices paired.
  • Seemed to be going well - was able to further update 1 node’s firmware that I hadn’t taken to the most recent version (my mistake).
  • Rebooted the HA system … at which point now 8/11 nodes are “dead” and not able to be contacted.
  • Network heal doesn’t restore the network.
  • Ping doesn’t work.

Really struggling to keep trying to troubleshoot this … nothing is making any sense here…

Are you using a USB extension? IIRC 3ft is the usual recommended length. That helped me setup years ago.

Yes. However I have a 15 ft.

Does the length make a difference?

I’m also plugged into a USB 3 port because that’s all the mini PC I’m using has.

When I ask this question on Reddit, most didn’t seem to think that was an issue.

15ft is probably fine. Is the Atrim stick up to date?

You know, that’s one thought I had late last night but didn’t have the energy to go searching for the firmware, etc.

I will try that this morning.

Thanks. I’ve read through their website - it’s only marginally helpful.

I used PC Controller to attempt the update - I’m getting an error “Serial Upload Aborted File Error - 0x50.” From googling, it seems to indicate it will give this error when the attempted upload version is the same as the current version. So I seem to be running Z-wave 7.17 which seems current as of at most 2 months ago.

1 Like

These devices all were paired and worked with Homeseer? Because if they were then that is pointing to an issue with your HA hardware.

Try moving the USB from HA to your laptop and check if the devices are alive and accessible with PC Controller. I can’t recall all of what PC Controller does but I believe you can at least watch the log to see them turn on and off or something like that.

If you don’t know, the pairings are in the stick, you can put the stick to new software and it will see the devices paired. You could pair them all with PC Controller then plug it into HA and zwave-js will see the same paired devices.

I do have a few devices that don’t want to add S2 and some that I can’t update using zwave-js-ui. They all connect fine and most of the ones I have do update and pair S2 fine. It’s like 3 or 4 out of about 30 that had issues. I used the barcode and SmartStart to pair most of mine when I changed to a new zwave stick.

However, I have found that sometimes doing a heal on every device one at a time is needed to get the network to work properly. This applies if a network heal doesn’t complete.

@PJF - Yes, they were working with Homeseer for the last 6-12 months without any issues.

I have moved the USB - will try it again. Last time I did it I was able to see all the paired devices and yes -you can trigger the basic function (i.e. for lights = on and off) via PC Controller. I will try it once more.

I think you mean “the pairings are in the stick” and yes I do realize that. So I did try to pair one via PC Controller. When I moved that stick back to Home Assistant it did not work - while I could see the node entry the device was “unidentified” and would not heal/update information.

So I’ve allowed a few devices i had issues with to pair unsecured. I’m not that worried about security here. That said, some of the devices when trying to pair with the Atrim stick and PC Controller don’t even get THAT far to ask what level of security I want to pair with.

Smartstart also does not seem to be working for me. I use a QR scanner to get the DSK ID and load it up - but then nothing ever happens. Have tried air-gapping the switch, have tried holding the config button for reset, inclusion process, etc - nothing ever seems to happen.

Good idea on the device heal. I can try that on those 3 devices that are holding out rejoining the network this AM. Seems to me that sometimes if they’re listed “dead” they won’t do a heal either…

I’m sure you can tell … I’m frustrated.

Yes, I meant stick.

I’m not clear, the devices always work with the stick and PC Controller but not with zwave-js?

You HA box has internet access, right? I’m not sure what that would screw up, but it needs to pull the config info from the internet unless you manually download the device library and store it locally.

I’d try pairing a bunch of devices with PC Controller, confirm they work then move the stick and see if they still work.

Some of the SmartStart pairings were a pain. It’d try over and over and sometimes work at 2-3 attempts or just never succeed. I’d usually stop it and reset the device and let it try again.

No, the devices do not always work with the the stick. Right now I have at least 3 switches that won’t talk to either. In general - I’d say I’m getting better results with the PC controller and Atrim stick but it is really hit or miss to be honeest.

Yes, HA box has internet access.

I can try pairing devices with the PC controller and then moving the stick over. I did have that idea - but tried it on one and didn’t have great luck with HA appropriately recognizing the device, etc. I can give it another try though for sure.

I’ve pretty much given up on SmartStart unless you think there’s a potential benefit for me there… I did think for a while that maybe I could use it instead since the pairing was going so poorly, but it doesn’t seem to be any better.

I put all my devices into the provisioning list along with names and locations. I can reset a device and it will re-add as if it was before. This worked well to change the stick because I ran a second zwave-js-ui container and build the provisioning list. Then I just went around factory resetting each device and they added automatically and then re-appeared in HA again as they were before.

But, if paring isn’t working then that won’t work either.

Overall, I have no idea what to suggest. You’re having issues that should not exist. I switched to a SLUSB001A and it’s been working well. They are cheap too. I don’t think there is anything wrong with a 800 series stick that might cause the issues you have.

You do hold down the config button for >20s until the LED goes red to reset the dimmers and switches, right?

Yep, I’m holding >20 sec until the lights go red. They usually flash a few times and then go back to light blue…

I agree, it’s literally not making sense.

I’m going to try a few more things…

-try to add using the PC controller as you suggested
-If that doesn’t work, try to set up my ZNET device again. Apparently can be made to work with HA, I think it has a 500mhz radio and that had worked before with all of this hardware. If that worked, I’d be super concerned in the future about upgrading though…
-try a 700 series stick?
-buy new switches… fwiw I have a lot less difficult time pairing with a few Zooz zen32 scene controllers that I have versus the Innovellis…

@Eric_Inovelli or @EricM_Inovelli - any help you can offer here?

Still struggling here. Had some more time to try and play with things today.

  • I tried to pair with the PC controller. I was able to get 1 additional switch that had been “difficult” to pair. I kept going and 4 additional switches still failing. This is after resets/exclusions, etc.

  • Tried to setup the Znet device. Having trouble with that. I reached out to the Homeseer people to see if there’s a way to appropriately setup the device with Homeseer (the newer devices definitely do connect, not sure if the older devices like mine can).

  • I think I may order a 700 series stick for shits and giggles, see if that might allow easier pairing. No idea why that would improve things, but … here we are.

  • My newer switches (mostly Zooz) seem to pair just fine and quickly to boot. I’m thinking there’s some kind of disconnect between the Inovelli Red Switches and the newer 800 series controllers. But that SHOULDN’T be the case, and I’m not seeing a mess of other posts indicating the same. I really want to avoid spending hundreds of dollars to upgrade my switches but … feeling like I"m between a rock and a hard place right now. This is just really crazy …

Appreciate the help you all have offered to this point … still hoping someone from Inovelli might chime in as well …

What method are you trying, secure or insecure?

I’m also using the Zooz ZST 39 800 Series stick, recently moved to it from a Nortek HUSBZB-1, and I’ve had nothing but trouble. The Nortek was flawless for years, but some of my newer Z-Wave devices didn’t fully support the older chipset on my controller.

I’m using ZwaveJS-UI with the HA Z-Wave integration connecting over the WS server. It is far worse than my previous setup of Z-WaveJS UI with HA connecting via MQTT. In fact, I’m seriously considering going back to MQTT and ditching the HA Z-Wave integration.

I have some switches that don’t behave, control is inconsistent, cannot update firmware, cannot control LED indicator on the switch. It’s all very frustrating.

I’m considering a new stick, but I don’t want to have to migrate 80+ Z-Wave devices to another new stick.

@PJF I was trying to do whatever the device would let me do. A few of them seemed to pair S2 secure with no issue. Some of them seem to not want to pair at all.

My plan is to try to pair them all unsecure and see if that helps at all.

@Jonesie that’s interesting. I’m actually in the middle of “troubleshooting” with the Zooz support to see if perhaps it’s a bad stick. In the past they’ve been very helpful to me when I needed questions answered … less so with the stick so far.

As I said, I blew up my prior Z-wave integration thinking this would be a good time to redo the network with the move from HomeSeer to HomeAssistant… has proven to be nothing but trouble.

Your experience is interesting though - because all I’m hearing otherwise is that people have had no issues with the ZST39 and there must be something up with my setup…

I bought the Zooz 800 stick based on those same recommendations. Please keep us posted on the outcome with Zooz support. If it ends up being a bad stick, I may reach out to support assuming it’s a bad batch.

I originally started adding my Red Series Dimmers and Switches as S2 Secured, but it would take 5-10 attempts to get it to succeed, and that just burned Z-wave IDs. Once joined, they were extremely slow to respond. Being simple light switches, I eventually just started over and joined them all as Unsecured.

I made the same decision to rebuild my Z-Wave network when I migrated between sticks. Kicking myself now.

As you (may) know, most of their support is over email. Right now it’s taking them 15-17 hours to reply to each of my emails …

They send me an email saying that if it wasn’t working with Zwave JS they really wouldn’t have any other suggestions (they favored JS over JSUI). So at that point I asked for a replacement - and now they want me to provide logs at the “silly” level.

So I’ve been collecting logs for a few hours here in the hopes they will give me information today on what to do with those logs … and hoping they show something.

Honestly, if I can’t make it work and they won’t take it back, then I’ll do a chargeback on the credit card and try a different stick …

I will let you know. Please let me know if you happen to come up with any other ideas. I’m so incredibly frustrated. I thought this would take 1-2 days to redo the z-wave network and here I am, 2 weeks in …