Home Assistant doesn't show all configuration settings

I’m using Home Assistant with ZHA, and as mentioned in another thread, for some reason, it seems difficult to add switches that are out of range of the controller. “Add device via this device” doesn’t seem to help. But that’s the other thread…

One of my switches is apparently right at the edge of the range of the controller. I was able to add it, but I think due to the low signal strength, it took a lot longer than usual, and when it finished, not all of the configuration parameters are visible. For the rest of my switches, if in HA, I go to Settings, Devices & Services, Devices, and select the switch, under Configuration, there’s Automatic switch shutoff timer, Button delay, Default all LED off color, etc. However, for this one switch, the Configuration section just has 8 items, starting with Button delay, Default all LED off intensity, Default all LED on intensity, and Local dimming up speed. A bunch are missing. I can see them under “Manage Zigbee device”, Inovelli_VZM31SN_Cluster, but it seems like they have to be visible under Configuration to be usable in automations. E.g., I want to have an automation that changes “Local protection”, but while the other switches have a “Turn on … Local protection” action, that’s not in the action list for this one switch.

Is there a way to get HA to query the switch for the list of config parameters again? Preferably without having to remove the switch and attempting to add it again, since it was difficult getting it added the first time. I tried doing “Reconfigure” under the Device info section, but that didn’t help.

Restart Home Assistant and see if it shows up then? That should reapply the quirk and the config that displays it on the frontend is part of HA itself.

I tried that, but no change :frowning:

Unfortunately the only thing I can think to do then would be to remove and readd it :confused:

I would consider opening a bug on Home Assistant core here: GitHub - home-assistant/core: Open source home automation that puts local control and privacy first.. Be very specific about what you thinking is missing.

Since these switches are so new there are bound to be bits that are not setup correctly in the ZHA integration. Just the other day I saw someone supplied a fix for the Blue switch for the zigbee2mqtt integration. I would imagine that ZHA will be a similar situation with some teething pains.

Let us know how it goes!

I don’t think anything’s missing in HA in general; the other Blue switches have all the config parameters I’m interested in. It’s just this one Blue switch that is missing parameters.

I removed and re-added the switch, and it shows the config parameters as expected now.


Mark as resolution so others know it is resolved! Glad to hear it’s working.