Home assistant, LZW31-SN, Hue lights

So I’m very new to Home assistant. This has been a huge learning curve for me, so I might ask dumb things but I just am lost with these switches.

I after 5 hours can now turn my hue light on and off with automations. The automation just uses up and down buttons to turn the lights on and off.

I can’t control dimming, I can’t get the notification light to work (blink strobe, chase, change colour when triggered), the notify light is blue and is on when the hue lights are on, and off when the hue lights are off.

I followed the instructions on here for installing and downloading what I needed from Inovelli’s website all of the github stuff I need but it ended up messing my home assistant up and I had to restart and use a back up. Their site looks to be outdated with how to set up with home assistant.

Everywhere I read I find scripts that would work great but it seems I’m the only one who has no clue on where the script needs to be, how to save it. What file it needs to be in.

I need help, I’m very lost and basically have a light switch that lights up blue when the lights are on.

I’d like to be able to dim my hue lights and the notify light matches the brightness, I’d like to learn how to use notifications for when my ring alarm is set, going off, if someone is at the door, or a window is left open.

If anyone can help out, but keeping in mind this is all very new. I know a lot of basics but when it comes to code I get lost easy.

I don’t really know what needs to be explained or what you guys want to know or need to know to help me. Ask away and I’ll do my best to answer so I can get the help I need

I think this topic will help

1 Like

What did you download that screwed up HA? There isn’t much of anything you need to add for it to work.

This will help too.


Go to the developer tools, services and pick “Z-Wave JS: Bulk set partial configuration parameters for a Z-Wave device (Advanced).” Put 16 for the parameter and the code from the link. When you click on “Go To YAML Mode” it will show the code you use in an automation.

On another note, why can I edit the OP’s post???

If you’re new to HA, I’d completely set aside doing everything through automations and scripts and jump straight to the node-red addon. It’s less of a learning curve and arguably more capable (at least for the avg user) than doing automations in YAML. Follow along to a couple videos from the hookup and you’ll have a grasp on the basics within an hour. And there’s a set of nodes you can add to it that are specifically for Inovelli devices, controlling the multi-taps, led colors and notifications.


I’ve linked the guild I used below, when I went to restart my HA I used Configuration validation first to make sure everything was good, it came back saying something was wrong in the config yaml file but not what it was. I remembered I added

usb_path: /dev/ttyUSB0
config_path: /config/open-zwave/config

in to my config yaml file, thinking that’s was it I removed that and restarted HA and it just never booted up right, no web UI, nothing. But below I linked the article and it seems a bit out dated? So since then I haven’t used that, I just have a zwave USB, and the switches, I can use scripts to trigger the LED notifications, I can turn a light on and off with the switch.

I can’t control the brightness with the switch, if I turn the light on in HA it doesn’t reflect on the switch, if I dim the light it don’t reflect on the switch. So where I’m stuck now I can’t use the switch for brightness/dimming, HA telling the switch the light is on, and HA telling the switch what the brightness of the light is, 25%, 50%, 77% for example. So if I turn the light on and set it too 50% the switch either shows it’s off, or at 100% brightness. And I don’t have 2, 3, 4… tapping, I only have single tap right now. On and off.

So all I have done, no downloads, nothing. Setup my zwave usb, and added my swtiches. I haven’t installed -anything- to do with these switches. I can see in my z-wave logs when pressing on and off that it works, but if I try dimming (holding up/down) I get this “2022-01-02T07:07:19.444Z DRIVER Dropping message with invalid payload” even just pressing on and off the logs show “dropping message” the odd time not sure why yet.

So it doesn’t seem dimming works, double taps, and I think I’m missing drivers? or files for the switch to run right. All i did was connect it up with zwave

Not sure why you can edit? Don’t know how to stop that

I’ll check that out, I just got Red node, if you have any other advice I’ll take it! Do you know where I can the nodes to add on for the inovelli devices?

I think you need to remove any zwave stuff you added because it sounds like you’re using one of the old zwave integrations.

Go to the store and add the zwavejs2mqtt addon. Open it’s web interface and put the USB device in there and make sure it’s working. In the setup also disable the MQTT Gateway and turn on the WS Server under the HA part.

Then, go to the config and pick Devices and Services. Click the add and find the zwaveJS integration and add it. I’m not positive, but I think you just click through the defaults and it’ll be good to go.

When it’s working the ZwaveJS box should appear in the integrations and it should list the number of added devices and the entities.

You don’t need to unpair and re-pair the devices with the stick when doing this.

Personally, I disable the WS Server and add the devices in the zwaveJS2MQTT interface as well as naming the device and giving it the locaiton. Then, that transfers to HA as the nice name and entity name. If you don’t get the re-name in before it copies to HA the entity name ends up being the device name and it doesn’t make sense. I’ve also had the HA zwave integration screw up and I simply deleted and re-added the integration and the zwave comes right back with all the names the same.

1 Like

node-red-contrib-ha-inovelli-manager (node) - Node-RED (nodered.org)

Add this to your pallet and it’s great for controlling your Inovelli devices.

Okay I’ll do that, I also installed open-zwave through terminal as per the inovelli link I posted above, would you remove that too?

So update! I can see the switch it shows under entity ID


So I can see the switch, I just don’t know how to do any kind of dimming, so it brings me back to the original issue. How do I dim my hue lights from the light switch? if I turn on the hue lights from HA on my phone how do I get the light switch to reflect that and show dim level and on/off? And multi button taps

BUT z-wave to MQTT noticed the switch and knew what it was, so that’s a huge step for me as before I was using open-zwave fro github and that had it’s own issues

But I am still back to square one, I can’t dim. I can’t use 1,2,3… tap, I can’t turn the light on in HA cause it only turns the switch on and I have a smart bulb so the notify light turns on 100% but the light stays off.

You put the switch in smart bulb mode, right?
You can still set or adjust the brightness even though the output stays at 100% and the light stay on, right?
The bar shows the dim level, right?

I think this help will help. Basically, when the level of the dimmer changes, you pass it to the bulbs.

I don’t know how to get the bulb brightness back to the dimmer without creating a loop where they keep updating each other. Check this thread, maybe there is something there that can help. I will say one way you could do it is by only adjusting the brightness through the dimmer and letting the automation adjust the bulbs.


You are a life saver, I honestly owe you. That first thread you linked saved me, it works amazing. I was almost going to give up but thank you!!!

Glad you’re getting there. Starting out in HA is hard. So much of the stuff posted is outdated, I’d suggest when searching try to stick to the stuff posted within the last 6 months or so first.

1 Like

I think Inovelli should remove the HA setup which references OpenZwave as it’s creating a lot of unnecessary problems. I nearly went down thst path but prior to that I read a lot that OpenZWave was deprecated so I avoided it… At least a foot note update that the instructions are outdated.

Or maybe the wiki that’s been mentioned so often and the community can self document and update.

Tag @Eric_Inovelli


Yes, it should. That isn’t even for openzwave, it’s for the old integrated zwave, the steps give it the config files needed since it wasn’t being updated anymore and didn’t contain them.

@Eric_Inovelli - the page here should be revised or deleted, it’s completely outdated. At least mark it as outdated.

1 Like

yeah that’s the biggest thing I’m dealing with, anything a year old and it’s nearly impossible. Either because the thing I’m hooking up to HA had updated and the instructions are out dated or HA has updated a bunch. I’ll take note of the last 6 months, think knoeing that will be good

It would be cool if Inovelli made an integration for their products in HA rather than jumping through so many hoops just to get it to work. They have nice switches and dimmers but it kind of seems they just went “here’s a switch and it has a light on it that can change colour and blink, some instructions too. Enjoy making it work”

Certainly, thanks for letting me know.

@EricM_Inovelli – tagging for reference.

More than happy to support HA into the future. Just tag me!