House full of LZW31-SN's all stopped working through SmartThings at the same time

Yesterday morning all (~45) of my LZW31-SN’s (Red Series Dimmer Switches) stopped working through SmartThings. If I switch their driver to a default Z-Wave Switch, they work again, but I’ll be missing all the features of the Edge driver they were all previously assigned to (2023-03-28T23:07:14.066865864). I can’t find that there’s an updated version of the Edge driver, and I don’t know if something got updated on the SmartThings side. I’m not sure how to get this resolved.

Has anyone else had this happen? Any ideas on what’s causing it and how to resolve it?

1 Like

@EricM_Inovelli did you update the Edge driver?

I’m guessing not because the driver version is from 2023-03.

Mine are 2023-03 as well. I’m not having any issues.

Are you able to capture any logs with the smartthings-cli tool? Also, it would probably be a good idea to open a ticket with SmartThings to get them involved. Most likely scenario is that they changed something on their end and it is causing issues.

SmartThingsCommunity/smartthings-cli: Command-line Interface for the SmartThings APIs. (

1 Like

First time using the CLI, and trying to find my way around. I’m not sure how to capture logs yet. I did notice that my Inovelli switches show a Provisioning State of “DRIVER_SWITCH” which seems odd…?

Hmmm, yeah, I don’t remember seeing that. Where is it at?

I view the logs via this command:

smartthings edge:drivers:logcat --hub-address

The ip address is the ip of the hub.

You would then select the driver the switch is using: “Inovelli Dimmer Red Series”

@SwitchVII - if it’s any consolation, all my switches stopped working too (Blue Series tho).

I think it may have something to do with the recent update SmartThings rolled out bc everything worked great until the update (unless it’s just a weird coincidence).

Don’t worry, we’re investigating! But know I’m suffering with you lol

EDIT: I just tried switching to a generic driver and it’s working as well, so the upgrade to ST must have broken something on the Inovelli driver.

1 Like

Clearly, it’s telling you it’s time to move to Home Assistant!


With all the posts about Home Assistant issues, I don’t think I could stomach it!

Dumb question @EricM_Inovelli - but could ST implemented the keep alive cluster issue with their last update? Seems to be very similar to the few of us HE users that @Eric_Inovelli and a couple others have experienced…

Could just be ST woes though too.

I think this is different because it is causing problems on both Z-Wave and Zigbee.

I just created a tutorial here if it helps:

1 Like

@Eric_Inovelli and @EricM_Inovelli , thank you for digging into this.

I do believe it’s a memory issue, but I also believe it’s been there way before the latest hub firmware (beta or non beta) release but it’s just now more exposed.

I have 47 Blue switches, but I can only run ~30 of them with Inovelli’s driver. For me, this goes back to August of 2023 where we exchanged IM’s and many, many CLI logs.

Update on this. I found that if I moved my switches back to the default Z-Wave driver, they began working again. Thinking it was a driver issue, I moved them all back. Once I did, they didn’t work again and now if I moved them back to the Inovelli driver, they did work. Using that approach, I slowly added more and more back to the Inovelli driver to see if I could identify a source. At this point I have almost all of my switches back on the Inovelli driver. I did run into the issue again along the way after adding a bigger group than I had been previously. Undoing just that grouping, everything came back. I’ve put most of that group back in but stopped short with a few that I didn’t really need much more than the default Z-Wave driver offered.

At this point I’d say the issue is either 1) too many devices on the same driver or 2) one of my switches isn’t playing nice, though I’d say that’s less likely.

I’ve been running with the current number of devices for nearly a year, though, so even if it is that I’ve got too many devices on a driver, it hasn’t been an issue until recently.