How do I get my Red Series switch to stop power reporting?

I have no need for energy monitoring on my switches and I’d rather not have those added messages slowing down my zwave. How do I shut this off? I tried setting the parameters in a way that I thought would:

parameter 10 - 0
parameter 11 - 32767
parameter 12 - 0

Yet I still get energy reports.

Is this something I can disable?

Note, firmware is 1.21 since I saw some posts saying there used to be a bug with this.

1 Like

This is a WAG, but try setting parameter 10 to 100. My thought process is that Zwave can’t make a 100% change, effectively disabling the reporting.

I agree that parameter 11 at 32767 (or anything high) doesn’t seem to have an effect on the interval.

It doesn’t help that some of the parameter descriptions aren’t as clear as they could be. :roll_eyes:

I actually had it at 100% and it was still reporting. I changed it to 0 when I read a forum post here saying to use 0.

Hmmm. I just started playing with the settings out of curiosity. On SmartThings, I’m set at:


I haven’t had any power reports since setting p10 to 100.

LZW30-SN, 1.20

Actually I just tried again and you’re right. I think I had 12 set to 100 before, not 10. In any case, this isn’t just “confusing” documentation, it’s wrong documentation. On Hubitat the driver says “The value is a percentage of the previous report. 0 = disabled. Range: 0…100 Default: 10” so it clearly says set it to 0 to disable.

I know what you’re saying, and I have no idea, really. 0 may be disabled, but what is disabled? 0 i.e. disabled may mean the percentage delta isn’t considered so any delta will cause a report.

At least to my thinking, Zwave goes 0 - 99, so a 100% change isn’t possible. I don’t actually know if that’s why it’s working, but it sounds good . . .

It would be much better if the documentation would simply say “If you don’t want power reporting, use these settings.”


Agreed. Either way, thanks for the help, it’s working the way I wanted now!

1 Like

Actually after seeing this I decided to go through and disable power reporting on all devices where I’m not using it. I tried this on my LZW30-SN and it doesn’t matter if I set parameter 10 to 0 or 100, it still reports energy use. I’m also on 1.21 (apparently my LZW30-SN’s came with 1.21). I have two of these switches and tried it on both, same results. I noticed in the firmware change log that firmware 1.16 was supposed to fix this issue.
“Fixed Energy & power reporting not being disabled when configuration options are set to 0.”
My LZW31-SN work correctly when setting parameter 18 to 0.

1 Like

I don’t have any on 1.21, but what I posted works on 1.20. Did you set all three parameters to match what I posted?

@dmeglio What firmware version do you have my settings working on?

Yup. I’m using Home Assistant with ZWaveJS. Here’s a screenshot of the settings with the specific parameters shown in red boxes.
Parameter 10 is 100, Parameter 11 is 32766, Parameter 12 is 0.

Here’s the energy reporting when I turn the light on

Hmm. Maybe something changed w/1.21? Let’s see what version @dmeglio is on.

I don’t know HA at all. Maybe a HA user can weigh in about making sure those settings are properly working in HA. I’m only saying this because I know there are some intricacies. That being said, I have no idea what I’m talking about with HA . . .

I’m on ST.


I believe @dmeglio said he was also on 1.21, but I’m guessing he upgraded to it, at least that’s how his first post makes it sound.

Interestingly, I just went back and looked at the switch where those settings had been working and I now see that it’s reporting energy consumption again, so I have no idea.

While it’s possible, I can’t imagine it would be switch specific considering I don’t have the issue with my LZW31-SN’s. For the LZW31-SN’s I have them set:
Parameter 18: 0
Parameter 19: 3600
Parameter 20: 0

This has effectively disabled energy reporting on those. I won’t rule out that it could be ZWaveJS though. I’m still waiting for them to implement the ability to set a transition time from off to on so I don’t blind myself when I wake up in the morning :laughing: It’s one thing I miss about the OpenZwave 1.6 beta.

I just checked mine again, nope, no longer working. It worked for a little bit but it’s reporting power again. I’m thinking it’s a bug. Seems weird that production devices shipped with beta firmware?

On firmware 1.22, with all 3 parameters set to 0, I can confirm that it does send a power report. However, it only sends a single power report, and only when the state of the switch changes. A second or 2 after turning the switch on or off, it will send a single report. Unscrewing the bulb (to change the amount of current drawn) does not cause a new report to send).

I am not sure if this is intended behavior or not, but it is unlikely to flood the zwave network (at least from my observations).

1 Like

Interesting. That’s good to know. I’ll set them to 0 with the assumption that it’ll only send reports the one time which is good enough for me for now. I’m also guessing that’s not the intended behavior since the LZW31-SN’s don’t do that. They just don’t report once you set the parameters to 0.

Yeah that’s what mine does. However, I wasn’t sure if it was because it was only reporting once or just because the watt load doesn’t change. I’m running a low wattage LED on this switch so I figured it could just be the fluctuations are so low the switch doesn’t detect any changes.

Just as a side note the adaptive lighting integration works really well for setting default z-wave and local levels through the night, alonside sleep mode where it sets at 1%. If you are interested in my setup I can share!

I remember reading/hearing about it before and at the time a while ago I didn’t have a use for it. But now…tempting. Just looked it up and supposedly it was supposed to become part of the core of HA, though I don’t see it and I’m on the most recent version. I guess it still needs to be added as a custom repository?