How to create a trigger for the LZW31-SN buttons when the internal relay is disabled?

I’m a noob with Home Assistant and have been trying for three days to configure the buttons for the LZW31-SN Red Series Dimmer Switches with Hue Bulbs, all connected to a Smart Things hub. The switch is set up in a neutral-wire single-pole installation, with the internal relay disabled.

The closest I’m able to get to reading the button state is with the Events tab in Developer Tools when I listen for all evens (using * as the event to subscribe to). I’m able to duplicate this result in Node-RED when I subscribe to all the events, and this is the output:

	"event_type": "smartthings.button",  <-- this is the most detail I'm able to get
	"event": {
		"component_id": "main",
		"device_id": "ecfe857d-c154-48ce-8bca-7503eb3a3a9c",    <-- this value stays the same, regardless of which button is pressed
		"location_id": "33627aae-5cb6-4d0b-878f-571b89393d59",  <-- same for this one
		"value": "pushed",  <-- or held
		"name": "Inovelli Dimmer Switch",
		"data": {}
	"origin": "LOCAL",
	"time_fired": "2020-09-29T02:16:49.772069+00:00",
	"context": {
		"id": "d50b90f601f911eba36c8dbfb3c52508",  <-- this value changes on each event
		"parent_id": null,
		"user_id": null

All I’m trying to do is trigger a scene to turn on/off the 4 hue lights in the room when button 1 or 2 is pressed, basically to operate as a switch without actually killing power to the Hue bulbs.

I’m running Home Assistant OS in a virtual machine. And then I have a customized Node-RED, mosquitto and smartthings-mqtt-bridge in docker containers on Rancher.

I did install the Device Handler for Smart Things. I was not able to use the Smart Things app to configure the buttons to trigger a scene. I got it all set up but then the buttons did nothing.

I was not able to follow this guide, as I don’t have a USB dongle connected to Home Assistant and therefore can’t use OZW. Furthermore, I wasn’t able to find the configuration files directory on Home Assistant OS, since they’ve changed a lot of things since that guide was written.

Thanks for any help!

Pushed and Held would be the correct terminology coming from SmartThings.

The issue I see with your sample event you posted is that it doesn’t contain any indicator to which button was pushed or held.

There might be someone else here that is using SmartThings and HA together, but I would suggest getting some help from some of the other SmartThings users here in the forums (maybe a new post in the SmartThings forum) to make sure you can trigger scenes correctly in SmartThings and then seeing if that changes the output in HA. If it doesn’t work in SmartThings then it probably isn’t going to transfer over the bridge correctly to start with.

I use ABC Controller in ST. Works great, highly recommended.

Hey @kreene1987, the ABC Controller sounds great, but after installing it, I just can’t get it to configure in the SmartThings App. I tried both the old app and the new one. Both times, after clicking on “ABC Manager”, and “New Button Mapping”, I get:

“We’re having trouble connecting. Check your network connection and try again.”

I agree with @nathanfiscus that the problem here seems to be with SmartThings not picking up and forwarding the events. I’ll see about posting in one of the SmartThings forums.

In the meantime, with this and other challenges I’ve had with the SmartThings hub, I’ve ordered a Z-Wave + Zigbee USB dongle so I can try using that directly with Home Assistant via USB passthrough to the VM.

If anyone’s wondering, here’s a link to the other Topic in the SmartThings group: Cross-post from Home Assistant: how to get button presses from the LZW31-SN?

Alright, I have one thing working: the up and down buttons now are able to trigger a scene to turn the lights on and off, so at least that much is working.

What got me that far was a small case of “RTFM”. I decided to go through the documentation again to see if I missed anything and realized I had at some point enabled the “disable physical delay” setting on the switch, which of course disabled all the scene controls. With that changed back, I also found this document:

I thought for sure I had read everything there was, but hat one page helped out quite a bit. While I had tried to do that before, I was incorrectly choosing the “Up” and “Down” buttons instead of just choosing the switch itself.

Now back to what’s not working: The combo presses (more than one) don’t do anything, as the app doesn’t have the option for “hold”, just “pushed”, so all those extra buttons are not available.

Looking more closely at the events I get from MQTT, I do see that I get “pushed” for the up button and “held” for the down button, but there’s still no payload to indicate which button is being acted upon.

However, (and much to my frustration) I do see that all this data is being received on the smartthings side. It’s just not sharing it with anyone else on the network

(screenshot showing the logs).

1 Like

If you have a firewall you might temporarily disable it and/or whitelist a few sites. I forget the list but it’s over in ST forums if you search whitelist. I believe it’s 3 sites it needs access to.

Once again my SmartThings terminology is weak and I haven’t looked into the code for the bridge, but maybe based off of this it is missing some support for scenes?