How to do scene control Red series Edge Drivers

I just installed an old LZW31-SN on my SmartThings hub. Wanting to do it the “right way” so I installed the edge driver on my hub. The install went fine and everything is working, I can see in the device information that it’s using the edge driver, but I can’t figure out how to utilize the double, triple, tap for scene control in automations?

You code with a routine. For the trigger part, select Device Status, then the LZW31 - SN. Scroll down and you’ll see the button press actions for the up and down presses.

For the execution part either individually select what you want to operate on or create a scene and invoke that.


If this fixed it @mabeatty1978 can you mark thread as resolved with Bry’s post as the solution?

Have the same problem. Don’t see the option to select different button presses. Installed edge driver. Can’t remove the switch in Smart Things. Tried force delete. It says ut can’t because device is functioning normally

You are doing this with a Routine, right? In the “IF” section, select “Device Status” and then select Inovelli that you want to do the multitaps on. The following screen should have a number of sections, Main, Down Button, Up Button and Config Button. In each of the last three sections, you’ll see Pressed, Held, Pressed 2 times, Pressed 3 times, etc.

Are you not seeing that?

1 Like

No that doesn’t show up. Smart Things - Automations - Create Routine - If + - Device Status - Inovelli switch - Options shown are On or Off, On, Off, Dimmer, Power Meter, and Energy Consumption. No other options for Pressed, Held, etc.

Hmmm, Red Switch or Red Dimmer?

In the App, go to the Devices tab and open the switch or dimmer you’re having an issue with. Select the 3-dot menu top right and then the “Driver” menu. Post a screenshot of the Driver page that is displayed.

It’s the Red Dimmer. If I select it and the 3-dot menu, the choices are Edit, Settings, and Information. Doesn’t give an option for Driver.

If it doesn’t give an option for driver in the drop down then something likely went wrong with the edge driver install, if it is using the edge driver then you should have driver listed there.

If you go to the if section of the automation and select, device status, select your switch and then scroll down to the bottom and you should see something similar to this picture, select what you want to do, for instance, up button, pressed 2 times, then save and create your actions you want to happen when you prees the up button twice and you should be good.

What @PJones said. You’re going to have to remove and re-add the switch to SmartThings to pick up the Edge driver. You are still running the old Groovy DH.

Go through these steps to remove and re-add. They are redundant, but go through all nonetheless:

  1. Delete the device from SmartThings via the app. Force delete if need be. If it won’t delete, move on.
  2. Go into the IDE and make sure that the device is gone there as well. If it’s still in the IDE, delete it there.
  3. Exclude the device doing a general exclude. You can either do this via the IDE or the app. Make sure that you get a confirmation of one device excluded. This is from the hub utilities. Run the exclude then press config 3x. You should get a message that one device was excluded.
  4. Factory reset the switch by doing a long press of the config, about 40 seconds until the LED turns red.
  5. Add the switch back using Scan Nearby. I don’t add my switches with S2, but if you really want S2, use the QR code.

If you are uncertain how to perform any of these, post back and I’ll provide details.

If the Edge driver is successfully being utilized, you’ll see the “Driver” menu we referred to.

1 Like

If I select the Smart Things Hub in the app, hit the 3-dot button and the driver option, it shows Inovelli Switch Red Series as installed on the hub. On the If status, it doesn’t list Presses, etc.

I’ve tried to delete the switch. I found the IDE. It says I don’t have any devices or device handlers. It does say I have a smart app: tonesto7 : ST-Community-Installer It also says I don’t have any hubs. Not sure how to exclude. Sorry, I’m new to all this.

Ok, let’s take this one step at a time. First try to delete the device from the app. I know you said you tired that but let’s make sure you’re doing it correctly.

In the App on your phone, select the Devices tab and then the room that the dimmer you want to delete is in. Then click on that dimmer to open that device’s page. From the device’s page, click the 3-dot menu top right, Edit and Remove Device. If it won’t remove try Force Deleting it. What happens?




Tried Force Delete. It says

This device can’t be deleted because it is operating normally.

Ok, next stop is the IDE.

My Devices, select your device. Delete button at the bottom of the page for the specific device.


Ok, in the App, open the page for your hub. 3-dot menu, Settings, Z-wave utilities.

Press Z-wave exclusion, and when it’s running, press config 3x. That should exclude the device from your hub and you should see a message. If for some reason you don’t see that go to the next step, which is . .

Factory reset the switch. Long press on the config about 40 seconds until the LED turns red.

Have you already installed the Inovelli Edge Drivers?

It excluded the device. On the hub under drivers, it shows Inovelli Switch Red Series.

And right below that “Inovelli Edge Drivers”, right?

If yours is a dimmer, you should have the driver that says “Inovelli Dimmer Red Series, Inovelli Edge Drivers”

Go ahead and re-add the switch if you have the Dimmer driver installed. If not, add that one. It should pick up the Edge driver now.

Under the Inovelli Switch Red Series, it says registered to Inovelli Edge Drivers. Don’t see Inovelli Dimmer Red Series. Remind me again, how to get the Inovelli Dimmer Red Series.