Inovelli Black Series Dimmer Disable Local Control Not Functioning

I’ve recently installed a whole house setup (new build) with ~25 inovelli switches (mostly red series on / off and dimmers). I recently purchased a black series dimmer for a room I had missed and had it installed properly by an electrician. When going through the entire house, I was able to setup a routine that turned all of the recessed lights for that particular room (tied to the switch) either off (button 1 held) or on (button 1 press). This worked fine for every switch in the house except the last room in which I installed the black series dimmer.

I verified the rule actually works by running the rule (via rule machine) and it works properly. I have installed the LZW31 dimmer driver for the black series as a custom driver and installed via the device page in hubitat.

Whenever I disable local control (either via the child component for the device or 8x config button press) the device no longer registers button presses. It doesn’t activate the associated rules or anything.

I’ve included a screenshot of the log demonstrating the events before disabling local control (turning the switch on / off a couple of times), showing the local control being disabled, and then…well showing nothing…because it’s not registering a button press.

A screenshot of the current firmware is also attached. I don’t have a way to update the firmware if that’s what’s required.

Any help is appreciated!

image

This is probably due to it being a black series device. It doesn’t have the enabled features that correspond with multi-taps like the red series devices do.

I’m not exactly sure what you’re trying to do. Can you attach the screen shot of the rule?

1 Like

I don’t have access to that hubitat atm (new build and using temp internet connection). I was basically setting up each switch to control the corresponding set of recessed zigbee sylvania rgb lights using rule machine with a rule similar to:

Trigger if button 1 pushed
Set dimmer level to spare bathroom recessed group 100

Another rule:
Trigger if button 1 held
Set dimmer level to spare bathroom recessed group 0

Disabling local control to activate the rules so power wouldn’t be lost to the bulbs when down paddle is pressed. I’m guessing I didn’t read the specs close enough to realize that’s not possible on black series.

It’s not a deal breaker because I can just turn on/off the switch via hubitat but zwave grouping is slow where as zigbee protocol (for just dimming recessed cans to 0) is much faster.

@dalingle1986 - You may be able to achieve what you want by using something similar to my rule. I have a black series device and just use the trigger on to activate the rule vs button 1 pushed/held.

You may have to rewire or use smart bulb mode to have power delivered continuously to the bulb(s). Just a thought. But ultimately you will be limited by black series.

Ok thanks for the info @harjms! Much appreciated!