Inovelli LZW31-SN out of sync with Home assistant

Being forced to use the Openzwave integration, my switches go out of sync, everyday and every now and then.

To get them back in sync I need to adjust the dimmer levels on the switch, wait until it works… then it’s back in sync.

I’m using Openzwave integration and Openzwave (beta) add on. Latest version of Homeassistant, fresh install. 115.3.

Anyone got any tips on how to keep them in sync.

The old integration, worked great for me.

Sucks I can’t add config_path anymore in the old integration.

Did you include the switches as secure or non-secure devices?

Using Openzwave do you get a choice?
Think “Secure” is the only option.

I added my switch as non-secure, and it seems to work well with the same variables you have (OZW, HA). Maybe test by removing one, and re-adding as non-secured.

How do you add as non-secured?

To my understanding, In Home Assistant - Configuration -> Integrations -> OpenZWave (beta) Configure button -> Add Node

That’s how you add nodes yup. But aren’t they added “securely” by default.
Non-secure isn’t an option.

OpenZWave Reference



This service will set the controller into inclusion mode and should be used to add a device (node) to the Z-Wave network. Call the service and then perform the device-specific procedure, according to the device manual, to add your device to the network. Make sure the controller is connected to the host where the ozwdaemon is running, when performing this operation.

Service Data Attribute Required Description
secure no Add the new node with secure communications. Secure network key must be set. This process will fallback to add_node (unsecure) for unsupported devices. Note that insecure devices can’t directly talk to secure devices.
instance_id no The OZW Instance/Controller to use, defaults to 1.

I saw this. All my 48 nodes were added this way and they’re all added “secure”. It says “Secure” isn’t required but theres no option (that I can see anyway.) to add unsecure. It’s not possible to change it either.

Grr. Got it. What an idiot haha. I’ll try re-add everything non-secure. This works for you?

I installed the OZW admin tool and use it. When you click add node it asked which way.

It’s pretty easy to use, when you start it pick open and enter the IP address where the OZW daemon is running and click start.

Going unsecure,(unencrypted) changes everything…

I have the LZW30 but when trying to add unsecure it fails… Anyone seen this?