Inovelli Switch not updating status on hubitat

Just installed 2 switches…

Switch is not updating current status in Hubitat

Any idea why ?

Does it respond to the “On” and “Off” commands (click the buttons on that page) from Hubitat? One possibility is that the device either “fell off” the network or never finished joining during pairing (in which case it probably wouldn’t have created a device on Hubitat, but I guess stranger things have happened).

If you’re not using this device in any automations yet (or if they wouldn’t be too much work to set up again), you could try removing the device and re-pairing. To remove, I’d try to click “Remove” on the page in your screenshot above, initiate the exclusion process on the switch (3 taps on the config button) and see if Hubitat responds (in which case it will delete the device and navigate back to the Devices page or wherever you came from before that). If Hubitat doesn’t respond to that (i.e., if it takes long enough that Hubitat asks you to “Force Remove”), then the best idea and your only option is probably to go follow through with the force remove, then reset the switch (hold the config button for 20 seconds). After whichever of these options works for you, try pairing again (put Hubitat in Z-Wave inclusion mode, then tap 3x on the config button). Not sure why it wouldn’t have worked the first time, but it’s probably the only thing you can try now.

A couple other ideas: if you’re not sure about Z-Wave range on the switch to your hub or a nearby repeater (which could also cause this problem), you could try the “range test” tool. Hold the config button for 5-10 seconds, and it should turn green if within range of your network or red if not. (I think this only works if the switch has already been included, so it may be good to try before you exclude or reset if you’re curious.) That could be helpful in determining if you need another repeater between this device and the hub. The only other thing I can think of to try might be a Z-Wave repair on Hubitat, but you shouldn’t need to do that if the switch was paired in-place and you didn’t move around any repeaters shortly before or after pairing.

Hopefully one of these things will help!

Thanks so much for replying… I have done what you suggested and still no status… Zwave Range is Green.

I excluded first… Then included as new device after resetting it for 20 seconds.
I then did a force remove and then did a reset and included it back as new device. Sane thing… no status

I can turn the switches on and off… just no status… Any more ideas?

I do see this in the log when clicking the button in hubitat. .

skip:SecurityMessageEncapsulation(commandByte:[0], commandClassIdentifier:37, commandIdentifier:3, secondFrame:false, sequenceCounter:0, sequenced:false)
dev:16372020-04-18 07:17:22.889 pm debugparse description: zw device: 3A, command: 9881, payload: 00 25 03 00 ,

@Mike - Hit the configure button and see if it starts filling in.

Oh also I recommend using Inovelli Hubitat driver instead of Hubitats driver. That may fix it.

Where do i find the drivers?

I hit configure… Nothing filled in.

@Mike - what model you have?

Inovelli Z-Wave Switch | ZWave Light Switch Works with SmartThings | Repeater, 3-Way Smart Switch Technology, Signal Indicator | Z-Wave Plus w/S2 SmartStart

Scene or no scene?

Follow this:

@Mike - Follow the support link I posted above for the LZW-30 driver.

I did… here is what is shows now.

Here’s my version of Black series on/off.

Did all the other variables become present ie the additional features below on/off/configure?

The Hubitat driver does not control the buttons… But the default one does. i can also use the devices in automation… not the hubitat driver.

The Hubitat driver does not control the buttons… But the default one does. i can also use the devices in automation… not the hubitat driver.

1 Like

Hmm. Maybe give it a few mins. You saved the device after switching to the Inovelli driver right?

First things first… I would un-pair and re-pair without security… The message you are getting is showing that you paired with security… And not all drivers support securely joined switches and can provide some unexpected results…

Go to settings -> Z-Wave Settings -> and select “locks and garage doors” under secure join…

If you unpair and re-pair without security … You should be fine with the built in drivers

Go to settings -> z-wave settings and the select secure join “locks and keypads”

1 Like