Integrating Zigbee Canless Lights For Entire Home - Juno Connect

We have sent some Juno lights to our manufacturer to investigate. They got shipped off yesterday. Our engineer says he is looking into it, but he is stretched for time between projects.

1 Like

crosses fingers

Thanks for staying on this!

2 Likes

One thing I have been thinking the last few days is if there is some kind of funky bind in the binding table (more likely after a factory reset or after a different device gets removed from the network). This causes the switch to send out a lot of broadcast traffic to try to find the route for the device. Excessive traffic may fill up the memory on the switch. As annoying as it is, it might be worth it to factory reset some switches and recreate their binds to see if it makes a difference. Of course, doing a packet sniff would help see if this is happening and whether that would make a difference or not.

I’m not sure how often devices (like switches) are supposed to notify of their state, but I can confirm I have a lot of traffic happening, like this message when there has been no recent action (passive/automated or manual) for at least a few hours

Info 2024-07-11 12:23:36z2m:mqtt: MQTT publish: topic 'zigbee2mqtt/Hallway Can Light Dimmer', payload '{"action":null,"activeEnergyReports":null,"activePowerReports":null,"autoTimerOff":null,"auxSwitchUniqueScenes":null,"bindingOffToOnSyncLevel":null,"brightness":254,"brightnessLevelForDoubleTapDown":null,"brightnessLevelForDoubleTapUp":null,"buttonDelay":null,"defaultLed1ColorWhenOff":null,"defaultLed1ColorWhenOn":null,"defaultLed1IntensityWhenOff":null,"defaultLed1IntensityWhenOn":null,"defaultLed2ColorWhenOff":null,"defaultLed2ColorWhenOn":null,"defaultLed2IntensityWhenOff":null,"defaultLed2IntensityWhenOn":null,"defaultLed3ColorWhenOff":null,"defaultLed3ColorWhenOn":null,"defaultLed3IntensityWhenOff":null,"defaultLed3IntensityWhenOn":null,"defaultLed4ColorWhenOff":null,"defaultLed4ColorWhenOn":null,"defaultLed4IntensityWhenOff":null,"defaultLed4IntensityWhenOn":null,"defaultLed5ColorWhenOff":null,"defaultLed5ColorWhenOn":null,"defaultLed5IntensityWhenOff":null,"defaultLed5IntensityWhenOn":null,"defaultLed6ColorWhenOff":null,"defaultLed6ColorWhenOn":null,"defaultLed6IntensityWhenOff":null,"defaultLed6IntensityWhenOn":null,"defaultLed7ColorWhenOff":null,"defaultLed7ColorWhenOn":null,"defaultLed7IntensityWhenOff":null,"defaultLed7IntensityWhenOn":null,"defaultLevelLocal":null,"defaultLevelRemote":null,"deviceBindNumber":null,"dimmingSpeedDownLocal":null,"dimmingSpeedDownRemote":null,"dimmingSpeedUpLocal":null,"dimmingSpeedUpRemote":8,"doubleTapClearNotifications":null,"doubleTapDownToParam56":null,"doubleTapUpToParam55":null,"energy":4.37,"fanControlMode":null,"fanLedLevelType":null,"firmwareUpdateInProgressIndicator":null,"highLevelForFanControlMode":null,"higherOutputInNonNeutral":null,"individual_led_effect":null,"internalTemperature":null,"invertSwitch":null,"ledBarScaling":null,"ledColorForFanControlMode":null,"ledColorWhenOff":null,"ledColorWhenOn":null,"ledIntensityWhenOff":null,"ledIntensityWhenOn":null,"led_effect":null,"linkquality":51,"loadLevelIndicatorTimeout":null,"localProtection":null,"lowLevelForFanControlMode":null,"maximumLevel":null,"mediumLevelForFanControlMode":null,"minimumLevel":null,"onOffLedMode":null,"outputMode":null,"overheat":null,"periodicPowerAndEnergyReports":null,"power":2.6,"powerType":null,"quickStartLevel":null,"quickStartTime":null,"rampRateOffToOnLocal":null,"rampRateOffToOnRemote":null,"rampRateOnToOffLocal":null,"rampRateOnToOffRemote":127,"relayClick":"Enabled (Click Sound Off)","remoteProtection":null,"singleTapBehavior":null,"smartBulbMode":"Smart Bulb Mode","state":"OFF","stateAfterPowerRestored":null,"switchType":"3-Way Aux Switch","update":{"installed_version":16908818,"latest_version":16908818,"state":"idle"},"update_available":false}'

If there’s anything I can do to help here, I’m happy to do it.

@lavid You might want to adjust your power reporting. I have noticed that on some smart bulbs, there is a power fluctuation (usually when the bulbs are off) that can cause excess reports. Especially if there are a lot of devices involved. So, I would disable the ActivePowerReports from the exposes tab (set it to 0).

Then, on the reporting tab change “activePower” Min rep change. If you watch the logs, you can see the power bouncing back and forth. With my 6 hue bulbs it would bounce from 2 to 18 (.2W to 1.8W). I set my min rep change to 25 to cover the difference between 2 to 18 (could have done 20, but did 25 for good measure). I also set the min rep interval to 5 so that when I turn the switch from off to on it will only take a max of 5 seconds to show the power change in the GUI.

Thank you! I’ll try these settings.