Is it possible to "UnBrick" an LZW42 Color bulb?

@EricM_Inovelli I attempted to update the firmware on my LZW42 color bulb. I’m using the @bcopeland Z-Wave Updater and file “LZW42_2_30.hex”
At first I had trouble getting the correct URL for the HEX file located on my Hub.
Then with that sorted out, the firmware was uploaded waiting for it to be flashed. Hung there and never came back.

I had to force the device from the hub (normal procedure didn’t work) I tried factory reset 6Xpower in 0.5 to 2 Sec. Many times with no response from the bulb. So right now it is sitting on my bench with no signs of life.
Is there a CPR method I could try?


Last Events Recorded:

Just asking because you didn’t state…did you try the reset with a mechanical switch? There’s no way a smart switch will toggle the required number of times in that timeframe. Wishing you luck…updating bulb 7 of 42 now over here…

Thanks for the thought. In fact I used bare wires. It was on a bench with easy access to both wires.
I also tried with one of those inline switches, you know the ones you turn the little wheel on.

Or course now I have to figure out what to do with my frizzy hair :slight_smile:

1 Like

I Just also tried to update my firmware with the file saved on the hub’s new file manager feature. No luck. However, I just released the lock, checked the firmware and switched back to the normal driver and it works again. Didn’t need to turn of power reset or anything else…

Thanks, unfortunately my situation has gone beyond that. Currently mine is on the bench, excluded from my hub and not responding to anything. Light is off :skull_and_crossbones:

Did you use the URL in this format: ?
one of the earlier posts did not include the :8080

Nop, I didn’t include the :8080… I just pasted it as it got copied:

That said… I only read your post after I had tried this and failed… So if :8080 is required, this may have been a good thing as I am concerned that had it worked, I might have also bricked my bulb… I ordered during a sale and for whatever reason didn’t think to buy at least 1 spare!!!

So if I brick it, I’m out of a bulb and would have to buy a new one at full price + shipping (which is about the same price as the bulb)… Boy I wish it was easier to buy from US companies here in Canada… That tiny « imaginary » line makes things so much more expensive for us north of the boarder!

The sad thing is… I only (attempted) to update the firmware our of curiosity. I was having no issues with it.

That makes it even more frustrating! I’m in a similar situation… I have a low connectivity (I think) and there are some additional features in 2.30 that may be of use to me… But that said, it works… I will therefore wait…

Hopefully, you have a spare!

Hey @JohnRob, I wonder what happened. It sounds like you did all the necessary troubleshooting. @Eric_Inovelli used the Hubitat updater tool on like 26 bulbs at the restaurant next to the office and I don’t think they saw that on any of them. I’ve been posting update URLs in the community posts but I haven’t made one for the bulb yet. I’ve been trying to keep them here as well as in the KB article:

So the URL you could use would be:


I updated an LZW42 last night using the BCopeland Hubitat Firmware Update tool using the URL and it went fine. I didn’t have to do anything special it did take a long time though like maybe 25 minutes. But when it finished I clicked the get firmware version button again and it came back with 2.30 it had 2.23 I think (don’t remember for sure but I know it was 2.2x) before.


I think we were affected by a solar flair :slight_smile:

I understand the basics of OTA programming (we used it in Automotive). In theory this cannot happen. Thinking over the steps the only thing I can think of is the lock did not “engage” when I finally got the right URL spelling for the on the Hubitat file.

There was no loss of power as the bulb fixture plugs right into the wall outlet…

I think I stay with solar flair as the cause :slight_smile:

If you guys feel like sending a replacement that would be fine but I don’t really expect it. I’m going to mark this one “brick” and throw it in the cellar for now.


1 Like

I think they shipped with 2.28 if I’m not mistaken. But no matter.

The firmware updater tool and our driver keep the firmware version in different ‘variables’. After you switch back to our driver just hit ‘Save Preferences’ and it should update with the new version number. I wish there was a method called by hubitat when you switch drivers as I would put the firmware request there.

With the LZW30-SN driver I see the firmware in Hubitat but with the LZW42 driver I don’t.

I verified I have the current driver installed 4/16/2020 was the last update.

I don’t know if this will help or not. But “Boris the Cat” wrote this driver for hubitat

Hubitat input URL

When you select it as a driver it will allow you to “clean” you driver space. i.e. it will clean all the state variables etc.

Sorry about that, I had a version of the driver installed that I hadn’t updated in Github. It is updated now and if you switch to it and hit “Save Preferences” it should show the firmware version.

1 Like