Is there a parameter to turn scene "on" for red series dimmer?

Is there a setting on need to set on red series dimmer to get it to send out a zwave.scene_activated?

I’m seeing a scene activated on an older, (still gen2), red series dimmer, but I just bought a 10pk and not one of them will send scene activated out. I must be missing something.

You installed the Inovelli drivers?


Drivers on the switch itself?? I know my hub (home assistant) isn’t the issue because as I said I can see a “zwave.scene_activated” in my debug log when I double tap on other dimmer switch. But nothing when I double tap on other dimmer switches.

Do you have the 700ms physical delay disabled? That disables scene control. You can only use the config button to trigger.

@nappyjim - I’m not familiar with HA so I’m not sure, but Hubitat requires drivers to be loaded into the hub to make the features usable. HA may not? I’d look at @stu1811 suggestion too. You may need to define that parameter.

How do I check that? The paperwork that came with the switches doesnt list that.

It’s parameter 51. It was added in firmware 1.47.


So this parameter list on the website, isnt the most up to date?

Correct. I request was made to update that list. The other one not listed is 52 which enables smart bulb mode.

OK, Ill check that, I dont think the delay is off, as when I tap up 1x, the light ramps up to full brightness. That appears to be saying if the delay is off, the light just goes from off to full brightness.

edit: or is that just saying with the delay ON, it will wait 700ms and then ramp up light. With the delay off, it will ramp up the light right away.

Ill have to check it either way.

The delay parameter was an option after multiple requests. It allows a user to have an “instant on” feel for the switches/dimmers instead of waiting 700ms before turning on/off. This delay was built in for monitoring multiple taps. So if you wanted to tap up 6 times, it’d give the individual enough time to tap and send the 6x command to the hub. When delay is removed, most scene captures are disabled as there’s no way for it to monitor multiple taps.

Set 51 to a 1, no go. Still no z wave scene, seen.

So heres what I see on node red when i tap 2x on the other dimmer. I see the zwave scene in the debug log. And the debug is not looking at a specific switch. Its monitoring the entire zwave network and will show anytime, any switch, sends a scene.

I just dont get it! Do I get black series switches with a red series shell??? lol

So it seems like you’ve checked everything I would have checked in my own instance of HA. Because I haven’t seen anyone suggest it, have you tried removing and reassociating the switch? The only thing I can think of is maybe when it was added to your zwave network it somehow loaded the config for a black series instead of a red? The last RGBW bulb I paired ended up not loading the right config so it wouldn’t let me change colors. It may be worth comparing the node info from one of the red series that is sending scenes to one that isn’t and see if anything is different, that’s the only way I figured out why I had one bulb acting different than the others.

Alright so I figured it out. After i sent a help ticket to inovelli, they recommended drivers as well. And I was like, “i dont remember ever loading drivers!!”

So I did a search for what they sent me and a results triggered something in my mind,

So long story short, when I setup the first dimmer, in order to get scenes to work I obviously found a old post that said to go into the zwcfg_xxxxxxx.xml and I had to add some lines of code to the CommandClass line for the node I wanted scenes to work on.

When first setting up my zwave, I never saw this tutorial ( about setting up customer configurations. So I went and did that, and scenes worked! Didnt even need to add the commandclass lines.