Issue with HA automation resetting Blue Dim Level

I’ve run into an annoying issue with my Blues and Home Assistant automations. Just curious whether anyone has any ideas on working around this.

Anytime a Blue is turned off via a HA automation using the “Light: Turn Off” service, the next time I turn them on manually using the switch, they are dimmed all the way down. (Actually, this happens even if the light is already off when the automation is triggered.) This doesn’t happen with my Reds.

For example, my living room has 1 Red and 1 Blue. If I trigger my “Goodnight” automation, it does a “Light: Turn Off” on that room. The next time I use the switches to turn them on, the Red comes on at full brightness, and the Blue comes on dimmed to minimal brightness.

Anybody know what’s going on?

On your Blue Dimmer what do you have P14 (Default Level Remote) set to? This parameter tells the dimmer what level to start at when you turn it on remotely

1 Like

It’s set to 255.

FWIW, the issue happens when it’s turned off remotely, and then turned on locally.

What is P13 set to?

And when you turn it off remotely, is HA sending the off command or setLevel(0) command

P13 is also 255.

I’m just calling the LIGHT.TURN_OFF service. Not sure how to determine what that does behind the scenes.

I have learned something new. The problem only occurs when I have a transition time set in the LIGHT.TURN_OFF call. (Maybe it uses setLevel when there’s a transition time, and off otherwise?) So I can just stop using transition time in my automations as a work around.

Well, Zigbee.on and don’t have an optional transition time, so it sounds like HA is sending setLevel. Which probably means HA is doing a setLevel(0) when you tell it to turn off. That would make it turn on at minimum when P13/P14 is set to 255.

If you want it to turn on locally to 100% then set P13 to 254

For whatever reason, P13/14 aren’t exposed in the UI in HA, but I can get at them through cluster commands. I’m going to consider this issue solved. Thanks!

1 Like