LED bar not changing color 🤔 (LZW-31SN)

Hey all! Back with another question that I’ve been unable to fix.

One of my LZW-31SN dimmers refuses to let me change it’s LED bar. Both the bar and the dimmer are on the latest firmware, and the rest of my Inovellis are running normally when I change the bar color. This one unit just seems to not want me to let it change.

Short of a factory reset, does anyone have any thoughts on what’s going on and how to fix it? I had another one with a similar behavior, but its location was inconspicuous enough to where I didn’t worry about it, and eventually reset it when I transferred hubs. I’m hoping I’ve just overlooked some configuration pattern or something.

Try re-flashing the 1.47.bin file. Sometimes it does not update correctly.

1 Like

What version of FW is being reported by the driver?

Are you trying to change the color with RM or with the driver itself?

1.48 (all of mine are on that flavor). I’ve just been using the child driver/manually setting it in the device preferences.

I’m re-flashing it now—hopefully it will yield some results.

I would make sure you reflash the Holtek FW, as well as I, believe that was required to add the “White” color to the LED Bar…


Just tried both. No luck. :confused:

So I am just assuming (ouch!) you’re using the Inovelli driver for this dimmer just like the other ones. Does this switch do everything else correctly - Scenes, Dimmer functions etc?

If yes, sounds like we need to bring in the big guns @EricM_Inovelli to see what he would suggest for next steps…

All on the Inovelli drivers, and sure does! That’s why I’m so perplexed. Hopefully the answer isn’t “factory reset”, but I’ll await further orders.

What if I said exclude and re include? I’m assuming you can control the switch from the hub directly (Zwave) correct?

I would also factory reset at that point, since I’d lose my associations :sunglasses:

Yes. I have full control of the device from my hub.

Using the usb z-wave controller as a secondary controller in hubitat I had an issue with my switches when I tried to install the two firmware files back to back in quick succession. I had similar issues if I recall not being able to change colors on LED bar. The frustrating thing was the software made it seem like the firmware update took, even though it didn’t. Waiting a few minutes between the two 1.48 firmware files worked for me.
I’m assuming you’ve tried air-gapping or resetting breaker.

Yup, even had our power go out yesterday for 30 minutes :joy:

1 Like

Can you check in the device preferences to make sure there is no “Custom RGB” value there? If that value is filled in then it will take priority over the drop down menu.

If that isn’t it then record the logs after trying to change the parameter to see what it says.


There is—but I keep changing it, and then the driver changes it back.

Here’s the logs, following an attempted change to Hue 360, Level 1.

Parameter 13 keeps changing back to 17.

Additionally, I tried to manually set the value of parameter 13 with Mike’s Z-Wave tool on Hubitat …


I see what happened.

I have Disable Hubitat Control enabled, which apparently stops you from changing that parameter. Odd, as I thought that only disabled the switch—not the ability to modify the LED bar?

Disabling control literally disables everything on the switch except for being able to turn control back on. I use this, but have disable local control enabled, but leave remote control available so I can use the LED notifications. It does suck that if I tell google home to turn off all the lights, it still turns off these switches since you can’t exclude devices from syncing over from SmartThings anymore.

I really wish the disabling local and remote controls only affected on/off/dimming and not all the other functionality.

1 Like

@adamkempenich @benk016, the disable remote control is a part of the Z-wave “protection” command class. The specifications dictate what it disables. It’s been a while, but the spec say that in remote protection level 1 any command that can change the state of the device is disabled (which is the one we use). In protection level 2 all commands are disabled (even getting the level of the device or that value of a parameter). You can kind of think of it as level 1 can perform “read-only” functions. Level 2 can’t do anything at all.

I don’t know of many people that use remote protection other than possibly disabling a device when they go on vacation.

1 Like