Light always on

I installed a blue 2-1 in a non-neutral setup controlling 10 dimmable LED recessed lights. Did the initial programming on the switch (single-pole, dimmer) and everything worked fine. At some point in the next day or two the switch stopped working. The lights are always on unless I pull the air gap switch. When I hit the switch to turn it on or off the notification lights react correctly and I am able to see the status change in Z2M. I have tried rebooting the switch and reprogram it via the paddle and config button but the light always stays on. Is it possible the switch got put in smart mode and got stuck or the the switch get burnt out?

Edit: Added link to lights

Seems like smart bulb mode was turned on.

Turn it off lol?

Check in Z2M and it doesn’t show as in smart mode, also tried reprogramming it with the config button with no effect.

At this point, it’s probably easier to exclude it and factory reset it. Sort of like shaking hands and calling it a draw.

I ended up taking the switch out and wiring it up in the garage in the same configuration. Removed it from Z2M and did a factory reset on the switch. Still behaves the same, with the notification LEDs responding correctly but the light always stays on.

If you factory reset it then it is not in the smart bulb mode, even though I know you check that before. What process did you use to factory reset it?

Holding the paddle up and config button for 20 seconds until if flashes red, then release the config button then release the paddle.

Yep that’s correct and it can’t be in the smart bulb mode after a factory reset so you may have a defective one.

For the heck of it, can you hold down on the paddle and tap the config button 4x (the LED should flash Blue)? Maybe for some reason SBM isn’t clearing when it’s factory reset.

Flashes blue as expected but no change in the behavior.