Lights always appear offline - automations intermittently work

Hi! I had the red series on off gen 2 switch installed by an electrician on Friday. I set up automations in the smart apps/ smart lighting in the ST app. I’ve asked some questions in the ST community about my automations. Seems they’re looking ok but not functioning the way they should. I have to turn the light on and off at the switch 5 times to get the next automation to activate. I have 2 LIFX lights set up to the switch. When I go into the app, it shows the lights as being offline. I’m not sure what’s causing that.

How are the bulb and switch set up? Do you have the relay disabled on the switch?

A LIFX is a smart bulb and should not have power cut to it. If your switch is turning the power on and off to the bulb, then the bulb is going to go offline.

@Bry, forgive me, I’m not sure how to disable the relay. I would however like the switch to be able to control the on /off function so my wife doesn’t kill me! I set up button 2 (double push up) to override any lighting settings other than full brightness at 3500k. I’m gathering I’d need to reconfigure what the buttons do on the switch.

Well your wife not killing you is important, so let’s see if we can get you going. :thinking:

So is this light bulb in a lamp that’s plugged into a switched receptacle that is controlled by the Inovelli switch you just installed? If that’s the case, we need to make sure the switch isn’t actually controlling the receptacle. At this point I’m thinking that it is, and that’s part of the problem.

Post back and we’ll work the rest out.

@Bry, not a lamp, the switch is installed to control the light fixtures in the ceiling of the bathroom.


Ok, thanks. So the LIFX(s) are installed in the fixture that the Inovelli switch is connected to. So your issue is that right now your switch is acting like a dumb switch in that it is turning power to the light bulbs on and off when you press the switch up or down. While that is what you want with non-smart light bulbs, it’s not what you want for your LIFXs.

What is happening is that when you turn the switch off, it cuts power to the bulb. So then the bulb is no longer online, which is why the bulb shows as offline in SmartThings. To remedy this, we configure the switch to not act like a dumb switch by telling the switch to constantly provide power to the light bulbs so that they remain online with SmartThings. Once that is done, we use one of two techniques (Scenes or Direct Association) to turn the bulbs on or off and the other cool stuff you do with a smart bulb. You’ll still use the switch, but the switch will be controlling the bulbs through the scenes or via direct association.

So you need to do two things:
1 - Disable the relay so that the bulbs are provided constant power, and
2 - Set up control of the bulbs either using scenes or direct association

You mentioned that you already set up a double-tap for the switch, so I’m guessing you may be at least somewhat familiar with scenes. To simply turn the light on or off, you’ll do the same thing, configuring the switch to run scenes that do that on a single press up or down.

Take a look at the attached guide. It tells you how to disable the relay, which is disabling local and remote control. It also tells you how to then control the bulbs via scenes or direct association. You can try one of the other. Some here use scenes and some direct association.

1 Like

Thank you, @Bry. I’m gonna get going on this!

@Bry This worked!!! Thank you!

1 Like