Lights flickering at low dim level with Blue 2-1

I have a Blue 2-1 switch controlling 4 “dimmable” LED BR30 bulbs. (UPDATE: see new posts below — the flickering also occurs with 4 incandescent bulbs.) The switch firmware is 0x0102020f (2.15) and it’s installed with a neutral wire.

When the lights are dimmed, there is sometimes a noticeable flicker — they don’t turn completely off, but the brightness level wavers a bit. All the bulbs flicker in unison. They don’t flicker constantly, sometimes going several minutes without flickering. But when they do flicker, it’s enough to be noticeable and annoying:

I looked at the power usage in Home Assistant and saw that power seems to occasionally increase slightly, for anywhere from a few seconds to a few minutes at a time. I noticed that the flickering occurs during these periods of elevated power usage.

  • I tried both leading and trailing edge mode (parameter 26), and while the perceived brightness level was different between these 2 options, the flickering was about the same.

  • Per this thread I tried disabling power reporting (parameters 18, 19, 20) but that didn’t help. (Oddly I noticed that Home Assistant graphs kept updating when I had these parameters set to 0. Does this mean I didn’t set them correctly? I did check that the parameters showed a 0 value when read. I also tried power cycling the switch using the air gap after changing the parameters.)

  • Per this Stack Exchange post I tried replacing one of the bulbs with an incandescent bulb, but that didn’t help (the LEDs and the incandescent bulb all flickered in unison).

What else could be going on and what more can I do to troubleshoot?

I’m having this same issue. As of right now I have 3 of these switches installed with all the same LED can lights. Only 1 switch is doing this that I can notice but when it happens it’s pretty annoying to see.

You can see in my screenshot that the power usage fluctuates much more when they are damned versus when they are not.

Firmware: 0x0102020e

This is common with LED bulbs, very few of them are able to truly get down to 1% and stay lit. Some may be 10%, others 18%. Find where the lowest level is, and use that as the switches “minimum dim level”.

For the record I’m not trying to use them at 1% — I already set the min dim level based on where I observed the bulbs actually would not light up on the low end, and where they didn’t increase in brightness on the high end (min parameter is set to ~50 and max is ~190). This flickering is happening now when I set the brightness to 28%, which if I did my math right means that should be roughly 35% if I hadn’t adjusted the min/max params. (50 + (190-50)*.28)/255 ≈ 0.35 (28% is not the min or max level where I observe the flickering, it’s just what I happened to test with yesterday so I’m giving it as an example.)

Also — would your theory that it’s the bulbs’ fault explain why the bulbs would all flicker in unison, and why an incandescent bulb would also flicker when I swap it in for one of the LEDs?

It’s good(?) to hear that this isn’t happening with all your switches! Some other things I haven’t tried but may try soon as part of troubleshooting:

  • Swapping these bulbs in on another circuit where I currently have smart bulb mode enabled (to test the same bulbs with a different Blue 2-1 switch)

  • Swapping all the bulbs for incandescent

  • Swapping the Blue 2-1 for an old non-smart dimmer switch (trying to avoid this test since it’s more work!)

In my experience, how power is distributed within a fixture does make a difference. My dining room is a 6 bulb fixture, and it’s “flicker point” is significantly higher than the bedroom 2-bulb fixture with the same bulbs. And they do tend to flicker together since they’d all hit that point at the same power level.

Now you mention smart bulb mode, in that mode it should be fine dimming to 1% since the power deliver to the bulbs is constant and the bulb dims with firmware. So if you’re dealing with standard flickering LED bulbs, instead of going incandescent this could be an excuse to upgrade to smart bulbs and setup circadian lighting. At least this is how I’d justify it with my wife :wink: LOL

I can say I had dumb dimmer switches on these lights before and I didn’t have this issue. The problem i have is I can’t change the bulbs to non LED.

Most dumb dimmers are triac based. Inovelli smart switches are not triacs.

Bad news: still flickers with 4 incandescent bulbs.

:sweat_smile: Believe me, I’ve been working on that project across several other rooms, just finished installing my 10th Blue switch today. It wouldn’t be a huge leap to do it in one more room…but I wasn’t planning to shell out for more bulbs because the product was supposed to work as a regular dimmer. However it seems like it may not be working as advertised :frowning:

Just adding…
I love my blue 2-1’s but do have some issues with a very similar flicker/pulsing at lower output levels and found that it wasn’t the LED bulbs, 40 watt incandescent ones had the same pulse/flicker.

  • Changing between leading edge and trailing edge does not seem to change the pulsing.
  • It also seems to come and go sometimes, like at some times the switch is hunting between two output level steps

My Leviton Z-wave switches with the same bulbs do not exhibit this (I believe they are leading edge).


Curious if it would make a difference if you disable all power monitoring. Just as a test.

For me usually switching to trailing edge takes care of any flickering. You might want to try the button combo method of changing this option just to make sure it has gone through. Hold the down button and press config button 13 times. I think it will flash teal if successful.

How can I verify that I’ve disabled power monitoring? I tried changing the relevant parameters (as mentioned in my original post) but I still saw power values in Home Assistant.

If you have set all the power/energy parameters to 0 then maybe there is still a zigbee reporting configuration. I am not sure how to see this on ZHA though. Maybe there is someone else that can help with that.

Is it possible to test with just incandescent? Even if it means you just unscrew the LEDs enough so they are not making contact and not powering?

Also, is there a link to be able to purchase the bulbs?

I did try with 4 incandescent already here and still saw flickering: Lights flickering at low dim level with Blue 2-1 - #8 by jtbandes

What do you mean by “zigbee reporting configuration”? Would that be like another parameter that isn’t documented somewhere? I have found the ZHA Toolkit component to be more helpful than the ZHA interface itself when trying to do low-level things so maybe you can look in there — I’m not quite sure what to look for.

I have a few different LED bulbs lying around, some of which came with the house. Philips, Ecosmart, and GE bulbs pictured here:

And here are some of the boxes I have lying around:

Currently I have 4 of the Philips bulbs in, and am still experiencing flickering. I believe when I made the original post it was 4 of these other, unlabeled bulbs which look almost identical to the Ecosmarts above so maybe they are an older model (or maybe the “LED Technology” brand matching the brown box):

In Z2M there is a separate tab to configure zdo reporting. I don’t know if there is something similar in ZHA. There could be power/energy reporting configured in multiple places.

Another thought I had is that if the devices received a firmware update (especially from an early firmware) a factory reset should be performed. There are a lot of configuration options that got changed / added and there may be some cobwebs that need to be cleared out.

1 Like

I’m trying this and nothing happens at all — no flash to confirm I did it right. Also no response when I try up+13x config for the other mode. What might I be doing wrong?

There is a slight learning curve to the process that once you figure it out it is pretty easy, but it can be tricky at first. There are a few videos of it in our help site:

Blue Series 2-1 Switch • Button Combinations, Quick Tap Sequences & Local Configuration Options | Inovelli Help Center

If you are doing it right and there is still no response make sure you have firmware 2.15.

Sorry for the silence…life gets in the way :sweat_smile:

With some practice I was able to enable trailing edge mode using the buttons. The bad news is there is still noticeable flickering. The flickering seems a bit different — a little less “pulsey” and more instantaneous brightness changes if that makes sense, and maybe happens a bit less often — but it’s still annoying. I have not yet tried the factory reset idea.

No worries, I’m glad that trailing edge did help out a little. Unfortunately, I think the next step is the factory reset just to make sure there are no “cobwebs” from the firmware update.

I have now done a factory reset and am still seeing flickering. I looked again at disabling the power/energy reporting, and I was able to disable active power and energy reports, but for some reason the periodic reporting (parameter 19) is not responding to changes:

Any ideas on why this would happen?