Looking for instructions for Red Series On/Off + always on power to smart bulbs

hi all,

i hope/thing i’m missing something obvious in the documentation, but i can’t find the instructions on how to set the switch to be always-on power for the smart bulbs and to act as a scene controller for smartthings. i’ve installed both of the custom device handlers and at least the main one is working in the classic app, but i don’t see where in the instructions i would set it up to leave the power on to the bulbs.

to complicate things just a touch, i’m using it in a 3-way setting, so i need to ensure that regardless of the position of the second (dumb) switch, that the power to the bulbs remains on and that it is just triggering a scene change when the dumb switch is toggled.

thanks in advance,


1 Like

Just making sure I’m clear of your setup:

  • 3 way setting with [1 Red Series On/Off Switch & 1 dumb switch] to control smart bulbs.

If you have the above setup, I doubt you would be able to do both (3 way & smart bulb control). Example: If someone switch the dumb switch that will cut power to the bulbs and you will loose control of the bulbs. If you put in a add-on switch or the Lutron - Aurora. That might work. Maybe someone else can give other options.

Any reason why you want to control smart bulbs in a 3-way?

To control smart bulbs - disable local control & use scenes to control the bulb

thanks for the reply here. and yes, you’re clear on the setup. i have sylvania zigbee RGB bulbs that i want to control via the wall, so having power always on for them is desired/necessary-ish. the idea would be that the wall switches are there for standard on/off usage, and i can trigger dimming/color changes with tap patterns or voice. i want the switches to behave like normal on/off for the uninitiated user so that i don’t end up with no power to the bulbs and therefore no control over them.

so i guess the question is if local control is disabled and the dumb switch is flipped on/off, will that end up cutting power to the bulbs or will the red series switch send a scene command based on the flip?

so in the classic app, i set “Disable Local Control” to Yes, and i’m assuming that i need to also flip the slider to on for “disable local control” to on under “Child Devices”

i have the device handler “inovelliUSA : Switch Child Device” installed and published in the IDE, but when i save the changes in the app, i get an error "child device creation failed. make sure the device handler for “Switch Level Child Device” is installed.

do i need to add the child device myself separately in the app for this? it is worded like it would automatically create it for me. i’m assuming that the switch level child device is where i would set which scene the button press activates.

I had a similar issue. I believe the correct way to do it is to disable the main local control but to not disable local control under “child devices” . To be honest, I’m not too sure what that option does but I got the same error when I selected it.
@EricM_Inovelli can help here

thanks for that @gbenrus25 - so after you changed the setting in the main control, what steps did you do to have the physical button press turn the bulbs on/off. i’ve been poking about a bit and am guessing maybe it’s to make two scenes, one for lights on and another for lights off, then to make a smart lighting smart app to execute them when the button is pressed?

Yes you would create scenes (single tap, double tap, triple tap, etc) to turn On/Off, change color. You can use the ABC Manager SmartApp or Button Controller to create scenes.

The thing to worry about is what happens when someone flip the switch on the other end of the 3-way?

thanks @ny_robert. i have set up the button controller smart app with button 1 push and hold both configured against the set of lights that are to be controlled. that is working (albeit with quite a delay) to send an on/off command to the bulbs. i didn’t seem to need any scenes to make this work, it was just in the button controller functionality assigned to the switch.

as for the other end of the 3-way, unless someone from inovelli can do some magic, i’ll have to get an add-on/aux. i tested it out as-is and the 3-way switch will definitely cut power to the lights vs acting like a button press on the smart switch.

it’s funny, but after all this, i may just have the switch cut power to the lights. i don’t think i’m really gaining much in terms of control and the delay is really significant in button mode. aside from being constantly online to get periodic firmware updates, having the rgb lights constantly powered doesn’t really seem to make much difference unless i wanted to have them turn on with a specific color, at which point i could likely create a scene where the switch turns them on and then the color is set…

The child device is if you would like the option to control the ability to “disable local control” via another app. Like, if you want to disable local control on a schedule you could turn on / off the child device on that schedule. To use that feature you would need to make sure the “Switch Level Child Device” was installed, but it doesn’t seem like you are looking for that feature.

As for the delay, I have also noticed the slight delay with SmartThings. It is that wonderful cloud processing that they have going on. With local hubs (such as Hubitat), the processing is instant.

Lastly, the 3-way dumb switch issue is because of how the light circuit is setup, and as you mentioned, it would take magic to fix the issue. When the dumb switch is toggled the circuit is broken and the light turns off. Also as you mentioned, using an aux switch is really the only way around that problem. :wink:

thanks @EricM_Inovelli, that’s all good to know. i figured it was the cloud being the delay, and it’s longer than i would have expected, somehow voice via an echo seems faster.

very much appreciate you all and the community here, it’s nice to get this level of support and the product seems really solid so far.

1 Like

So what will be correct strategy to use smart switches with smart bulbs? Disable local relays and recreate behavior all the default functionality (paddle up for ON, paddle down for OFF) using smartapps?

Hi @2vanger, at this time that would be one of the options. Our dimmers also support direct z-wave device to device association. So the dimmer will send on / off & dim up / down down commands directly the the bulbs

I tried doing that but I had couple of problems:

  1. as I mentioned in earlier - there is 5-6 seconds delay when using your app for creating association.
  2. To create the association - I will need to disable local relay to keep bulbs always on, right? But then physical buttons on a switch stop working - how would it control the bulbs?

This is what I was wondering as well. It seems that if you use the direct association method, you’ll have to power through bulbs independently, like bypassing the dimmer. It seems when you disable the internal relay, you also disable all switch functions except scene controls.

Hi @EricM_Inovelli, Are there instructions out there that explain how to setup the z-wave device to device association? I have 10 Red series switches and 4 smart bulbs along with 20 other black series dimmers or on off switches. I would love to get them all working how I want to. Thanks!


Can you do this with the black series? I didn’t think they had scene controls. Or do all switches have scene controls?

The black switches lack direct association*, scene control, notifications and power monitoring. You would need a red switch in that situation.

(*) That’s based on my assumption of “Smart Bulb Controller” meaning direct association and/or the ability to disable the relay. Their series comparison image on the product page could be more clear on this front.

Ok so continuing the conversation, how does one get

  1. local dimmer control (up is on, down is off, hold up/down dims up or down) of
  2. smart bulbs (ilumin) with
  3. minimum lag (via z-wave association?)

You can disable the internal relay with the black series though. See image. Why would this info be included in the manual with the device if it weren’t useful?

1 Like

Just as a follow up to my own post, it looks like z-wave association on group 2 and 4 and disabling the internal control via settings still allows the switch to dim the lights.

The only issue now is that the light bar shows 100% all of the time instead of reflecting the level of the lights. I feel like this is something that could be done, but will look at elsewhere.