LZW30 - Is it possible to set parameter 51 with the config button?


I have paired a LZW30 to a Hubitat C7 in S2 authentication. Currently the available driver does not work with switches paired with S2. So I am wondering, is it possible to set parameter 51 to instant on with the config button on the switch?

I’m not 100% certain, but could you try going to the device page and selecting the latest Inovelli driver, set parameter 51, then swap back to the Hubitat S2 driver? I don’t know if it’ll save the parameter change or not after the driver change, but it would be worth a shot.

I know @EricM_Inovelli is working on the S2 drivers, so it may be available shortly.

I had tried that already and unfortunately the commands doesn’t even go to the device :frowning:

Have you tried Hubitat’s Basic Z-Wave Tool? (Just temporarily apply the driver, make the change, then switch the driver back.) I haven’t verified if this works with S2 devices yet, but if it does, it would be easy: in “Set Parameter”, put 51 for the parameter number, 1 for size, and either 0 or 1 for the value (0 being the “no delay” one). If it doesn’t work with S2 devices, they should be able to easily modify it to work, but I suppose you’re still out of luck in the meantime.

But to directly answer your question, I doubt it’s do-able from the switch/config button alone. They didn’t mention this in the release notes, and they were apparently already pushing the limits of what they could do in that regard before. :slight_smile:

1 Like

That was a great tip, but didn’t work unfortunately. I suppose it has to do with S2 auth. Thanks for the advice however! Learned something new today

I have been working on the drivers, but have gotten to a point where I can’t proceed. I used the reference driver that I was given to modify our driver and the new commands produce errors. Even when I use the Hubitat provided example driver it throws errors. So something is not right. It might be that I am not on the beta firmware for my C7, but it is weird that the Hubitat built in drivers are working if this is the case.


Thanks! I was able to figure it out by looking at the file in the github history.

@mraz.camren Can you try the new driver to see if you can set the parameter with it?

1 Like


I can now remotely control the switches with your latest driver and I can see the parameter changes are applied to the switches in Hubitat logs

Switches are instance on/off now :smiley:

Ok I may have spoken too soon. Shortly after applying the latest drivers to all my LZW30, all of them stopped responding to commands and automations. Switches were still controllable physically though. I had to reboot the hub and switch back to Hubitat’s built-in S2 driver, now everything is back to normal

On a positive note, the parameter 51 setting stuck even after changing the drivers. So switches are still instant on/off

There is some kind of issue with the C7 where the z-wave will crash under certain scenarios. The only way to fix it is to reboot the hub. I’m sure they will figure out what is going on.

That’s scary. I hope it’s not a hardware issue, and can be remedied with a software update…

I have experienced the crash twice now…

Thanks again for the updated driver. Truly appreciated.

1 Like