LZW30 Latest Firmware? Investigating inclusions issues with Homeseer system

According to my Homeseer hub, the latest firmware installed on these is 1.11. Is that the latest firmware? If not, can I get the latest sent to me?

Reason I ask, I have been following this thread: Homeseer and LZW31-SN - Issues adding node and have also been having issue adding Inovelli switches using S2 security.

I have followed all the suggestions on the mentioned thread, and can successfully add using “non-secure” with no errors, but alas, without the much needed scenes features. If I add using the secure inclusion method using the web interface hub (zstick), it loads the central scene device and gives an error that it could not read the Central scenes. It does not pick up multiple presses. Why is this a must for me? I came from Homeseer because Homeseer seemingly doesn’t see the importance in having a bypass to control smart bulbs. Their answer was wire it always hot?!?

Without the ability to get the central scenes switch to work, the switch is useless to me unfortunately. I did try and reset the switch, I did try and move the hub one foot from the switch, and I did try non-secure which actually worked fine but only loaded 2 devices and omitted the central scene device.

Before I pester Homeseer, I wanted to give a crack at seeing if I needed to update firmware on the switches.

Anyways, I’m just now hearing about your brand and so far am really really impressed! Your name is getting around on the Homeseer forums and I do hope that translates into sales.

Hi there. I have homeseer and without any issues, I was able to add my switches/dimmers in unsecured and get the central scene device. In device view, have you clicked on Show All? Sometimes homeseer hides odd device types from view.

I’ll try it but I also monitored the console and it said created 2 devices vice the created 3 devices that adding it secure gave me. In other words, I could see right from the inclusion process that I was getting one less device. But I’ll give it another crack.

I also have another older intermatic Zwave controller, maybe it’s possible to include via that older controller and import the node.

I’ll also check to see if a device is hidden.

Oh and one more comment, when I investigated the properties of the switch in the Zwave node section on homeseer it showed that the scenes were only available on the “secure” class. Doesn’t that imply you can’t access scenes on the LZW30 unless you add via secure? Just a question to understand if non-secure inclusion is not the right answer.

That would be a question more for the Inovelli team. However, I will say that none of my switches and dimmers have been added via S2. They’re all added via S0.

Also, it appears that using S2 works fine, a security handshake is successful, the only error, which is the original issue with my post, is that it fails to read the Central Scene keys…here is a snippet of my Homeseer Log:

Jan-05 12:36:49 AM Z-Wave 3 out of 3 Child devices of node 35 were created successfully.
Jan-05 12:36:48 AM Z-Wave Getting association information for Node 35 Z-Wave Switch
Jan-05 12:36:46 AM Z-Wave Assigning return route from node 1 to Node 35 Z-Wave Switch
Jan-05 12:36:45 AM Z-Wave SmartStick+: Adding association for Z-Wave device Node 35 Z-Wave Switch (Node 35, Group 1) to HomeSeer
Jan-05 12:36:45 AM Z-Wave Root Node Device Node 35 Z-Wave Switch was created for node 35 on network E349484D
Jan-05 12:36:45 AM Z-Wave All associations for node 35 have been retrieved successfully, it supports associations on these groups: 1, 2.
Jan-05 12:36:45 AM Z-Wave Node 35 Association Group 2 can have 5 associations, and currently has 0
Jan-05 12:36:45 AM Z-Wave Node 35 Association Group 1 can have 5 associations, and currently has 0
Jan-05 12:36:45 AM Z-Wave Getting association information for node 35
Jan-05 12:36:44 AM Z-Wave Warning Failed to get the list of Central Scene Keys for Node 35. Scene triggers may not be able to be used.
Jan-05 12:36:38 AM Z-Wave Node 35 is a Z-Wave Plus node. Retrieving ZWPlus Info…
Jan-05 12:36:38 AM Z-Wave Node 35 is Z-Wave version: Lib: 6.04 App: 1.11
Jan-05 12:36:37 AM Z-Wave Z-Wave manufacturer information for node 35, ID: 798=31EH (UNKNOWN), Type: 4=4H, ID: 1=1H
Jan-05 12:36:37 AM Z-Wave Received information on 16 secure command classes from node 35
Jan-05 12:36:37 AM Z-Wave Getting SECURITY class information for node 35
Jan-05 12:36:37 AM Z-Wave S2 Security key exchange successful
Jan-05 12:36:25 AM Z-Wave Waiting for device to generate key…
Jan-05 12:36:20 AM Z-Wave Node supports S0 Legacy mode
Jan-05 12:36:20 AM Z-Wave Node supports S2 UnAuthenticated mode
Jan-05 12:36:20 AM Z-Wave Node supports S2 Authenticated mode
Jan-05 12:36:20 AM Z-Wave Negotiating Security S2 for node 35
Jan-05 12:36:20 AM Z-Wave Synchronize nodes finished. Number of device nodes to be created/added = 1
Jan-05 12:36:16 AM Z-Wave Done. Node 35 Added.

As you can see, all is well except for that stingy error that really is preventing me from utilizing this switch for why I bought it.

Adding it via non-secure works fine as well, again, with the only exception is that it only creates 3 devices, the parent, and 2 childs, one being the on/off control, the other the “application status” device. I have tried re-adding, rescanning, holding the usb stick on a laptop right next to the paddle, nearly everything I could think of just to get it to load the central scene device properly. I’m at a complete and utter loss.

One thing I was thinking…could it be that the LZW30 is not scene-capable? I only say this because the product info page makes it a point to say the LZW30-SN is scene capable but the LZW30 page doesn’t really call that feature out.

If the former is true, seems weird to not have the switch be scene capable if the switch has the ability to disable the internal relay for smart bulb use.

Was the dimmer listed as a black or red series switch? If it was black, then there are no scenes available and it’s been working as designed. EDIT: after re-looking at my paperwork, yes, the LZW30 (without the -SN) is a black series switch and thus incapable of reporting scenes.

Well shoot that explains it. Ugggh. Guess I need to buy a different switch! Thanks all!

Question for Inovelli then, if it is not scene capable, what other utility do I get out of the switch in “internal bypass” mode. If the switch won’t register button presses, and I have disconnected the button from the load, is the switch useless at this point other than an LED indicator?

Don’t get me wrong, I’ll probably ending buying a Red series switch, but it seems that I purchased the bypass capable switch black series with the assumption you can still “tell” the hub to turn off the light at the switch (via a Zwave command somehow). Without scenes how else am I passing commands on to the Homeseer hub? All I’m after is a one button press scene.

Um… On the black switch, I don’t think there’s an answer for you on that one. I’d be just as interested to see if someone does reply with a use case.

Once you undo the parameter setting for relay, you now have a standard z-wave switch you can put elsewhere in the house while you wait for a red-series switch or dimmer to arrive?

You read my mind, basically I need to move it to a non scene needing, non smart bulb load carrying place, then its back to being useful. It’s still cheaper than Homeseers or Lutrons equivalent capability switch so it wasn’t a complete bust.

Hey just going through trying to clean up the forums and sorry I missed this (although we may have talked offline as I vaguely remember this topic). So, the Black Series switches can still be used to control smart bulbs, but they need to be Z-Wave (and preferably ours as we haven’t tested out other ones yet – in theory it should work though). You can do this by disabling the relay and then Associating the switch and bulbs together via Group 2 (On/Off) and Group 4 (Dimming).

More info here: https://support.inovelli.com/portal/kb/articles/how-to-control-a-smart-bulb-from-a-smart-switch-smartthings (I know this is a SmartThings article, but the same applies to HomeSeer).

Hope this helps and have a great day!