LZW30 & LZW30-SN HE Firmware Update

So I tried update every single LZW30 and LZW30-SN I have installed in my house (10 units between the two of them) using the community Z-Wave Firmware Updater driver (v1.00), and none of them even respond to a getVersionReport. I thought I was doing something wrong, but went through the pain of getting a PC controller and including them there.

Firmware updated from 1.09 (on the red) and 1.11 (on the black) to 1.19 without a hiccup using my Z-Stick. Now that they are all updated, I tried doing a getVersionReport on them again, and still nothing from any of the units on the HE. When I turn debug logging on, nothing is logged.

My single LZW31 dimmer on the other hand has no problems updating firmware using the same driver. When I turn debug logging on I see VersionReport- applicationVersion:1.45 // VersionReport- zWaveProtocolVersion:6.4 Is there a difference in how they report firmware versions? It’s a pain to have to do firmware updates via PC when excluding from the HE breaks all of my rules.

Hey @fatherdoctor – sorry for the inconveniences – question for you… what model of the Hubitat hub are you using (ie: C5, C7)? Also, what is the current firmware of the hub?

I’ve updated quite a few of the LZW30’s, 31’s, and 36’s via the Firmware updater without a hitch on my C5, but admittedly, I haven’t done anything on the C7 other than update the bulbs.

Hey Eric,

It’s a C7 running When I attempt to install firmware I get the sleepy device error, but I suspect that’s because it’s waiting on verification of the firmware version. In the attached screenshot I’ve clicked all of the buttons except the updateFirmware button.

For the dimmer, here is the same screen when I change the driver.

A post was split to a new topic: LZW30 Firmware and Quality Question

I had the same issue with two switches and had to factory reset them. Once I paired them them back up to the hub I was able to update the firmware on both

One random question and maybe @bcopeland and/or @EricM_Inovelli can help as I haven’t been able to dig too deep into the latest firmware updates on Hubitat and the C7… But there were two different drivers posted by Bryan.

I remember at one point, I had to download a different driver.

Bryan – is there a difference between the drivers or does the latest one encompass the On/Off Switch update? In other words, I know you wrote one to allow 700 Series (.gbl) and non-OTZ files (ie: our Dimmer Switch Holtek file)… will this driver also work for the On/Off’s which are .otz?

1 Like

Yes… It works for otz… There is a bug in it for hex files though, specifically ones that include boot-loader and have to have bytes padded. It’s the padding that’s broken.

So in this case, with the LZW30/30-SN, is what @fatherdoctor experiencing normal? If so, how can we solve it :slight_smile:?

@bcopeland I have an LZW30-SN right next to my desk to serve as your experimental playground.

I just read through this thread and I wonder if the issue could be that I included the switches as S2 devices? I believe my dimmer was also set up the same way, but I could be wrong.

There was an S2 inclusion bug on the LZW31 that made it so the Hubitat would downgrade the security during inclusion. It is likely that your LZW30 is using S2 and the LZW31 is not. I feel like I have seen certain reports not being parsed correctly with S2 and the C7 which may be what you are seeing.

I’m not sure which community is the right one to post this in, but in my near 100% ignorance of how most of this works I started poking around. The switch reports its firmware via firmware0Version (based on my adding the 1 and 2 to the Firmware report received string that is shown in the logs), indicating a null value being returned by applicationVersion (line 859) while the Firmware updater tool is only using applicationVersion.


I am trying to update the firmware on my LZW30s. I just found out about the community Z-Wave Firmware Updater driver (v1.00) tool for Hubitat. The tool/driver requires a URL as a pointer to the firmware. However, Inovelli’s firmware page (https://support.inovelli.com/portal/en/kb/articles/firmware-v1-19-beta-lzw30-switch-black-series-gen-2) only offers to download the file. What should I put in the firmware update tool’s URL field?


These URLs work in that updater:

Thanks. The URL helped. I’m now able to reach the firmware. However, now I get the dreaded " *Please wake up your sleepy device **" message. I recycled the hub and power cycled the LZW30 switch. As far as I know, I am using the correct firmware update tool “https://raw.githubusercontent.com/djdizzyd/hubitat/master/Drivers/Z-Wave-Firmware-Updater/zwaveFirmwareUpdater.groovy”. Any thoughts?

The LZW30 switches I have never been able to update using the Hubitat Community Firmware Updater tool. I suspect the sleepy device error is because the firmware version is being reported using a different command, and that’s breaking the driver. I can only recommend getting a z-stick or something similar to update via your PC until the driver is fixed.

Thanks for saving me from beating my head against the wall :grin: