LZW30-SN How to disable relay without SmartThings

Hi! I am using the amazing Red Series On/Off switches with Home Assistant and Zwave JS. These are working well in this setup, however I want disable the local relay to use these with smart bulbs. I don’t see an option in the Zwave_JS to do this. Is there a parameter and value pair I can use with ZWAVE_JS.SET_CONFIG_PARAMETER or ZWAVE_JS.BULK_SET_PARTIAL_CONFIG_PARAMETERS to do this?

Thanks!

In HA it’s under protection. *I’m using zwavejs2mqtt

I am currently using the base ZWave JS add on, but I am planning on switching over to ZWaveJS2MQTT shortly.

Thanks!

Update, the great support folks at inovelli reached out to me and offered an even easier way: hit the config button 8 times quickly while the switch is on and it will disable local control. Awesome!

1 Like

via Home Assistant you can use a service call to enable/disable the relay as well, here’s an example:

    - service: zwave_js.set_value
      target:
        entity_id:
          - switch.loft_lights_switch
      data:
        command_class: 117
        endpoint: 0
        property: local
        value: 1 # Disable local control
1 Like

Thanks! are those command_class and values documented somewhere?

Yes. They are documented here in the forums, and in the fold out instructions that came with the device. I do not see the parameter number on my instructions sheet, but I do see the press 8x option to disable the relay in the config button table for the red series. And I see it in the black series switch instruction. Also, neither have the parameter number but it does refer you to this community to more details.

FYI – you can set configurations via Home Assistant directly when using Z-Wave JS. Just navigate the device within Home Assistant and click the ‘Configure Device’ button.

For lzw30, it looks like under zwaveJS to mqtt protection settings are all unknown.

for lzw31 they are fine.

You can still use the zwave_js.set_value service to force the value. According to the zwavejs driver devs this is a firmware issue that causes the values to bit shift.

Yes, I am aware of that and that works , but it would be great to have it in the UI like the lzw31-sn and lzw36. I have opened a ticket with Homeassiatnt core and zwavejs2mqtt, but they are suggesting that this is something that needs toi be fixed inovelli.

Yes the zwavejs dev told me the value’s are bit shifted and that has to be resolved in the firmware.

I have no idea how the firmware is coded, nor do I know if any of it is bit shifted. But when you write low-level code, bit shifting is used as a means of efficiency to reduce the load on the processor, usually related to calculations.

So if there is bit shifting going on, my guess would be that it is intentional and is not going to be something that would be “resolved”. Of course, only the manufacturer can really answer that.

If the zwavejs dev realizes that a value is bit shifted, he ought to be able to un-bit shift it (my term) to derive the value he or she is seeking. It could be more complicated than that, of course. Just a thought.

1 Like

I’m from the zwavejs project. We do not, as a rule, include one-off device quirks like that to overcome device bugs. That’s part of what led to OZW’s inflated and confusing codebase. We aim to be a standard compliant driver.

I reported this via message to @EricM_Inovelli. The issue isn’t that there is a bit shift. They have an extra zero in their bit mask that encodes the supported protection modes, leading to incorrect values. The zwave spec defines the values so I really don’t think this was intentional.

1 Like

This is an issue that has been reported to our manufacturer. I’m not sure on when a fix will be released, but it’s been confirmed an issue on our end.

2 Likes

Thanks for confirming, Eric!

1 Like

We will try to get this issue resolved with the manufacturer. So, as a workaround the settings needs to be manually set via this method:

LZW30-SN How to disable relay without SmartThings - Switches / General Discussion - Inovelli Community

Also, you can 8x the config button to enable / disable the setting.