LZW30-SN how to get node red to recognize a scene?

So I picked up the red series because of the scene control. But I want to use node red to control that. How do I get node red to see that I have pressed up on the paddle 3 times ( and not that I just tried to turn the light on 3 times) ?

Am I missing something simple? I’ve went through a bunch of faqs but cant find anything.

Subflow already created that handles processing of the zwave.scene_activated events. Further in that post, others have made adjustments to the subflow as they see fit.

If you are on the built-in zwave integration, you need to make the adjustments to the config files if you haven’t already. This I want to say is the best route to go about it.


So I have the event triggering but its not making it past the “SWITCH” node? Why? See pics. I have debug node attached and when I double tapped down, it triggered it but the other switch did turn off.

So I figured it out, I had to edit the subflow. But why? Why did I have to change it to look at scene_data for? Why isnt mine outputting a scene_value_id as the subflow was originally looking for?

I believe its due to the way you have zwave integrated in HomeAssistant. I use the OpenZWave integration and am able to use the scene_value_id in NodeRed.

Ahhh, gotcha