LZW30-SN unknown device


I have successfully added my switch to HA. Everything seems to work fine, I can switch on/off from HA, the sensor works and status are updated in HA when I use the switch directly.

One thing that bugs me is that the entity id is zwave.inovelli_unknown_type_0002_id_0001. I tried to unpair the device, update the open zwave config files and reboot HA, but I still have this id.

Am I missing something? Is it an “expected” behavior?

Check out this thread, and the linked reply specifically. Home Assistant is running a multi year-unsupported version of Open Z Wave by default, meaning you have import and alter the files to get these to run as intended.

Unless you convert your install to OZW version 1.6. HINT HINT :smiley:.

Yeah, I need to at some point here. Was troubleshooting the new LED light strips, and HA developers on discord basically told me they won’t work with 1.4 because required features plain don’t exist. I just haven’t gotten to it yet.

1 Like

Thanks for the answers.

@doublepedaldylan I already tried this, but it still shows as Unknown.

@kreene1987, HA and ZWave are new to me. Do you mean to upgrade using an MQTT server and the open zwave beta in HA?

Correct. There is a way to migrate your existing installation over to “test” OZW (beta) 1.6, but honestly I’d recommend just starting from scratch as there are so many new features.

If you stop your zwave network, go into your zwcfg_*.xml file and delete the entire node from the file (i.e. in my case all the way from “<Node id=“12”…” to the following “”) and restart, it will reload the information from the appropriate xml’s.

If you did the linked procedure before adding or re-adding the node, something was missed. Usually it’s attempting to edit files while the network is running. There shouldn’t be a need to remove and re-add the device to the network as resetting the node’s cache as stated at the top of this post should fix the issue as long as the customized configuration procedure has been followed.

But really, I’d consider moving to the new system. I’m only on the old system because of a lack of time to move it over.