LZW31 3way issue

So today I installed a LZW31 switch into a 3way setup, hoping to use it as a simple on/off.
Based on what I’ve read here, it appears to be acting like parameter 22 is wrong. (Multi-Switch (Dumb Switch).

Everything seems to work correctly when the dumb switch is in the up position (including via HA), however in the down position, the LZW31 seems to have no affect on the light. The status in HA seems to follow properly but the light remains on.

The wiring diagram I used is the one that came with the switch and uses the Line and Load in separate boxes. Pretty much the same as the previous wiring however with the additional neutral connection on the Line side.

I gave up trying to get it to work and decided to set it up on my work bench to make sure I wasn’t making a mistake identifying things, and unfortunately it worked the same way on my bench.

One thing that stands out to me, using HA Zwave JS was that the Version v2 parameter shows 1.57, 1.34 for the firmware. Where as all my other LZW31 switches show 1.57, 1.44. I tried installing 1.44 to target 1, again and it seems to install without issue, but it continues to show 1.34 even after hitting refresh a number of times. Also when choosing to update the firmware, target 1, wasn’t an option, but as others have stated, I was able to just type it in.

Would love to hear any ideas.


Can’t speak to HA, but since you have it on the bench, if you have a spare Zwave stick, you could try using SILabs PC Controller. Add the switch to that to get an accurate analysis of the firmware and flash it if need be.

You could also try factory resetting it and then see what HA thinks it’s running.

From what I could find, 1.57/1.44 is the most recent. This is Gen2 Black Series

For the Black Series, that is correct. 1.61 was never implemented for Black series.

1 Like

I’ll post this, just to close this off and if it somehow helps someone else out, great. Unlikely

I waited about a day, and then as the device was still showing 1.57/1.34, I attempted to update the firmware again. The only thing I noted differently this time was when I typed in target 1, I noticed it changed to a circled 1 with a grey background rather than just a 1 in a text field. (I am using HA with Z-Wave JS). I watched the update via the debug window as well as the progress indicator in the Control Panel view. The progress indicator seemed to stop at 98.7% and in the debug window it got to segment 320 something out of 337 (not sure these numbers are 100% but close).

It never proceeded any further with the segment count, but activity did continue as it showed the firmware field being updated from 1.57/1.44 → 1.57/1.44, (so seemingly no change). There were a number of other entries relating to settings as well.

The control panel remained at 98.7%, put after closing it, and reopening it, the indicator was gone. I then checked the version V2 field and it now showed the proper entry 1.57/1.44 and the switch worked properly.

Unless someone else has any ideas, I can only guess that there was some firmware corruption previously on the switch, although not sure why it took 3 tries to correct, or why the seemingly incomplete one fixed it.