LZW31 Dimmer Wiring Help - 4 Way

It may worth checking. @EricM_Inovelli May be able to confirm this configuration byte or tell me I’m way off.

Take a look at the comment in this post from today, relating to the speed of pressing the buttons. @thiagomp will hopefully post the videos he is referring to, I’m guessing it’s one of the ones on Inovelli’s support site but not sure which one addresses the button presssing.

@laundrymatt - Worth trying this too:


I did think this might be something, but I’ve made sure to watch the led status and it blinks 1 long and 2 short/3 short like I like it should for parameter 22/23. I’ll try again just to be safe.

For Parameter 22/23 do we know these settings? I don’t want to mess anything up.

  1. Number = Parameter Number
  2. Data Type = Data Size (usually hex or decimal)
  3. Desired Value = The Value you’d like this Parameter to be set to.

1 and 3 I feel like I know, 22 and 0 and 23 and 1 I would think, just not sure on Data Type.

@laundrymatt - I found this for HomeSeer

Parameter = 21
Hexadecimal = 0x015
Decimal = 21
Bytes = 1
Value = 1

Parameter = 22
Hexadecimal = 0x016
Decimal = 22
Bytes = 1
Value = 1

Just change the value to what you want.

Edit: The basic idea is changing parameter 21 & 22 to something else and then changing them back to the correct setting. For reference:

Parameter 21: AC Power Type - This is where you configure the dimmer to use either Neutral or Non-Neutral.
Range: 0-1
Default: 1 *
Size: 1 Byte

0 = Non-neutral
1 = Neutral

Important Note: The default for this parameter is supposed to be 1 (Neutral) and if you query the parameter right after including it into your network it will report that it is 1. But, the dimmer acts like it is set to 0. So we are working with the engineers to fix this issue and treating it like the parameter needs to be set each time.

Parameter 22: External Switch Type - This tells the dimmer if there is a 3-way switch setup to it and what type.
Range: 0-2
Default: 0
Size: 1 Byte

0 = Single Pole (Just the Inovelli Switch)
1 = Dumb Switch
2 = Aux Switch (GE, Homeseer, Leviton aux switch)
(Orig) The basic idea is changing parameter 21 & 22 to something else and then changing them back to the correct setting. For reference:

It seems like changing settings is doing something. Before when I would turn the light off at the dumb switch, the smart switch led would stay at full power. Now it turns off, but I still cannot turn the light back on from the smart switch. I have tried setting each on the switch itself manually to 0/2 and then back to 1. And I have done the same on Vera changing both to 0 and then back to 1. However I keep getting this error message:

Device failed to configure
ERROR: Unable to get any information on node…

Luckily it does seem to be a switch programming issue and not my wiring so at least that makes me feel good, haha.

Any thoughts on getting it to switch better? I’ve tried to buy a new hub to test but Hubitat is completely sold out everywhere I look, and not sure what else makes sense for offline capability.

@laundrymatt - Maybe it’s worth removing it from your network and performing a factory reset (hold config down for 20 secs until it starts flashing red). Then retry the changing parameters via the config button before adding to your hub.

You can take a look at this video that shows the symptoms when your are not programmed properly. It demonstrates a couple tests so that you can confirm it is your settings.

Unfortunately this says coming soon! @anon14959390, anything you can share here re setting up via Vera, since @laundrymatt is having an issue programming his switch manually?

Probably will have a link to Hubitat’s website :slight_smile:


I actually had done a factory reset when I first posted this, but I will try again.

Maybe this?

@laundrymatt - Just try changing the parameters before adding it to your Z-Wave network. See if we can get the 4 way to work before adding in the Z-Wave.

So I removed it from Vera, then did a factory reset.

I set 21 to 1 and 22 to 1. Didn’t work, I then moved 21 to 0 and 22 to 2 and the switch didn’t click anymore like it does in multi mode. I then moved both back to 1 and it sounded like it should. But it still doesn’t work perfectly.

The LED works mostly fully now where before today it would not. However if I turn the light on with the smart switch and it turns on, I then turn off the light with a different switch and the light turns off. If I go back to the smart switch and turn the light on the led goes up but no light turns on. If I go back to the dumb switch and flip it the turns quickly turn on, but then turn off and I can hear the smart switch click.


Almost back to wiring. In @bry diagram, which switch is the Inovelli going in (L, C, R?). It should be in the L position chasing the line, but R would work too.

The parameters are working, but I wonder if the wiring is just a bit off…

Smart switch is in L where the neutrals and power are. The wires match his diagram exactly, and I’ve hooked up my meter to everything to check probably 50 times now :confused:

1 Like

@Eric_Inovelli @EricM_Inovelli @JohnRob - Any ideas? Seems like the parameters are taking the fact that the switches work somewhat. Only other thing I can suggest is Aux Switches…

I did buy some aux switches so I can use them where I don’t have neutrals, but i can try them here as well.