[TIP] Gen 2 Dimmer Shutting Off - Possible Solution

Note: This is for the Inovelli Black & Red Series Dimmer (LZW31 & LZW31-SN).

This solution seems to be working for many, so I want to throw it out to the community for testing. It was actually mentioned somewhere in the community and I can’t remember where. Thanks to whoever it was! :slight_smile:

The basic idea is changing parameter 21 & 22 to something else and then changing them back to the correct setting. For reference:

Parameter 21: AC Power Type - This is where you configure the dimmer to use either Neutral or Non-Neutral.
Range: 0-1
Default: 1*
Size: 1 Byte

0 = Non-neutral
1 = Neutral

Important Note: The default for this parameter is supposed to be 1 (Neutral) and if you query the parameter right after including it into your network it will report that it is 1. But, the dimmer acts like it is set to 0. So we are working with the engineers to fix this issue and treating it like the parameter needs to be set each time.

Parameter 22: External Switch Type - This tells the dimmer if there is a 3-way switch setup to it and what type.
Range: 0-2
Default: 0
Size: 1 Byte

0 = Single Pole (Just the Inovelli Switch)
1 = Dumb Switch
2 = Aux Switch (GE, Homeseer, Leviton aux switch)

So the procedure is to change the parameters to something different and then setting them back. So, if I have a Neutral Single Pole configuration I would change parameter 21 to 0 and parameter 22 to 1 and then change parameter 21 back to 1 and parameter 22 back to 0. This ensures that the configuration is correctly applied. So, how do you change the parameter?

In SmartThings and Hubitat, you install our custom device handler and driver. They are located in our Github: InovelliUSA · GitHub

SmartThings: The two options are accessed through the app by clicking on the gear (old app) or the three dots (new app) and “Edit Settings”.

Note: Make sure you SAVE the preferences each time you save them.

Hubitat: Similar to SmartThings, but you use the Hubitat web interface to make the change.

Note: Make sure you SAVE the preferences each time you save them.

Others: Most other hubs (Home Assistant, OpenHAB, Fibaro, Vera, Homeseer, etc.) allow you to go into the device settings and change the parameter. I don’t have a guide for all of these systems yet, but the process should be pretty straight forward if you have the information about the parameters above.

Manual: We recommend you use the hub to set these parameters when possible. If not possible there is a way to configure them from the switch itself. Here are instructions for those of you using this method.

Aux Switch:

Dumb Switch:


I’m putting this to the test! I just used Home Assistant to change both my switches to “load only” and “non-neutral” and then back to “3 way toggle” and “Neutral”. I also set the maximum brightness back to to 99 on both switches. I did this from my office, but we’ll see tonight when everyone is home how everything is working.

Edit: No good. A few hours later I was having issues with one of the dimmers flipping back off after 1 or 2 seconds. I’ve got them both set back to 80% max now.

I think I’m having this same issue. If I go above say 90-95% my lights shut off after a second or two. Tried the switching of settings. I also originally made changes at the switch when I set them up. So not sure what’s up but I’m sure it’s a firmware thing?

Dang, it has worked for several people so far. Are you using neutral or non-neutral? 3-way or no?

Just wanted to add to this thread… I installed a new Red Dimmer tonight, and it’s experiencing this problem (lights flipping off after a few seconds when the dumb three-way is on one side, lights are fine if it’s on the other side). Resetting the settings through SmartThings as described here didn’t fix the problem.

For the moment the problem seems to be mitigated by setting the max brightness to 90 (I actually stumbled across that fix on my own prior to finding this thread, thinking maybe the switch was going into some sort of overload protection or something).

Setup has a single dumb three-way switch, with neutral. Lights are 3 40W G9 halogen bulbs and a single 9W dimmable LED (and I did try taking that LED out of the picture, thinking it might have been an issue with two different types of loads; didn’t help).

I’ve experienced this issue too and it seems to recur after manually changing param 21/22 to a different setting and back again. Some other things I’ve noticed:
turning the dumb switch “on” for a period of time (~15 min?) causes the smart switch to operate as expected for awhile (haven’t tested thoroughly - but many hours). Also pulling and resetting the air gap switch causes it to operate as expected for a period of time as well.

This is something that we have corrected in a firmware update. Can you let us know the hub and firmware version on your device?

I’m running hubitat and the LZW31-SN switches are all running 1.48

Sorry about that!

It sounds like there might be something weird going on with the load. What type of bulbs do you have and what kind of setup? Neutral vs Non, 3-way toggle vs. 3-way Aux, vs Single Pole, etc. ?

I’m experiencing this intermittently on 4 different switches (I have ~20 installed). All are neutral/toggle, three of them are 3-way, one of them is 4-way.

I can’t easily get to one set of bulbs - but the others are Philips 281550 and Feit A800/850/10KLED/10.
However, I have the Feit bulbs on at least one other switch and I haven’t experienced the same issue.

I’ve now had a slightly different behavior on a 3-way, toggle, neutral switch (with the same Feit bulbs) - light turns on, but turns off after 10-60 seconds.

Can you check the version of Target 1 through the Hubitat firmware updater? It should say 1.41.

That’s what it shows:


I know this is a little late, but I am wondering if doing a complete factory reset on one of the devices might fix the problem. Do an exclusion, hold the button down for 20+ seconds until the LED bar turns red, and then release.

I’ll try that. It’s fixed on most of the switches, but I still have one where it persists (the only switch that I haven’t been able to replace the bulbs. As a side note: are there any known florescent LEDs that are known to work?)

5 posts were split to a new topic: Two Smart Switches + Association + LED Bar Sync