LZW31 + Embrighten Add-On Switch 3-Way Woes

I have two 3-way installations using the LZW31 + Enbrighten combination.

I used zwavejs2mqtt docker container (Z-Wave JS Version 8.9.1 zwavejs2mqtt Version 6.2.0) to apply the firmware upgrades to each device.

After upgrading Firmware from v1.38 to v1.57 and upgrading to v1.44 Holtek, the LZW31 dimming functions work completely. The Enbrighten switches only work when turning the lights off or going from bright to dim.

Use cases detailed below.

Lights Off:

  • LZW31 - Tap upper rocker turns on the lights. (Expected)

  • LZW31 - Hold upper rocker dims on the lights. (Expected)

  • LZW31 - Tap lower rocker does nothing (Expected)

  • LZW31 - Hold lower rocker does nothing (Expected)

  • Enbrighten - Tap upper rocker does nothing. (Not Expected)

  • Enbrighten - Hold upper rocker does nothing. (Not Expected)

  • Enbrighten - Tap lower rocker does nothing (Expected)

  • Enbrighten - Hold lower rocker does nothing (Expected)

Lights 100% On

  • LZW31 - Tap upper rocker does nothing. (Expected)

  • LZW31 - Hold upper rocker does nothing. (Expected)

  • LZW31 - Tap lower rocker turns off the lights (Expected)

  • LZW31 - Hold lower rocker dims the lights (Expected)

  • Enbrighten - Tap upper rocker turns off the lights. (Not Expected)

  • Enbrighten - Hold upper rocker dims the lights. (Not Expected)

  • Enbrighten - Tap lower rocker turns off the lights (Expected)

  • Enbrighten - Hold lower rocker dims the lights (Expected)

  1. What did I do wrong?
  2. How do I fix it?

The switch thinks it’s a dumb 3-way or not in 3-way mode at all. Go into the config and set the neutral, 3-way, mode and delay parameters all to another value and then back to what they should be. Or if it won’t screw things up remove, factory reset and add the dimmer again. Software updates sometime screw up the parameters.

1 Like

Went through the manual to try and figure out which parameters you’re talking about.

Neutral: 21 (AC Power Type)
3-way: 22 (Switch Type)
Mode: No clue which parameter.
Delay: No mention in the manual, but zwavejs shows parameters 50 and 51. (Configure Physical On/Off Delay and Physical On/Off Delay)

Which mode and delay are you talking about?

Parameter 22 needs to be set to 2.

1 Like

Here’s a screenshot of the settings. Anything else that’s set incorrectly?

You got them, mode is 52. The ones added or changed with the newer software are not in the manual.

As an example of what gets messed up, 50 can appear as 0 which is not a valid setting.

1 Like

ading my 2 cents, I found that in addition to what PJF said, I had to flip “Switch Type” 2 single pole. Click on the main switch and dumb switch, then go back to HA and set back to auxillary and save. It’s wierd having to fiddle with it like this but it might help

1 Like

Apologies for the delay. Finally got some time this weekend to figure it out.

I tried implementing @PJF’s solution and saving the configuration with each step:

  1. Set 22 from 2 to 0
  2. Set 22 from 0 to 2
  3. Set 21 from 1 to 0
  4. Set 21 from 0 to 1
  5. Set 52 from 0 to 1
  6. Set 52 from 1 to 0
  7. Set 51 from 1 to 0
  8. Set 51 from 0 to 1

The main control turns the light on and off, and can do the full range of dimming. Pressing any button (top or bottom of the rocker) on the auxiliary control just turns the light off.

I also tried the sequence above again, but with @miker2069’s suggestion of activating the switch while 22 was set with value 0 (single pole switch). The auxiliary switch has no effect on the lights then.

Also tried following the instructions here. The same behavior keeps happening.

Anything else I can try?

I’ll ask a noob question, is dimming supported from an aux switch? I’m only asking as up until last week I went through something similar eith scene control from an aux switch (thinking it should work only to find out its not supported from an aux). I wonder if dimming is supported from an aux as well.

Yes, dimming works from an aux switch like one would think when connected to a dimmer. Just scenes are not supported from an aux switch.

1 Like

The aux switch definitely used to control dimming, back when I had the switches on firmware 1.37–or whichever version was installed on devices sold around August 2020.

All I can suggest is factory resetting the switch and trying it again. You need to exclude it first and then hold the config button down for >20 seconds and then include it again. Excluding it should factory reset it, but do the config reset anyways.

Optionally, you could also try setting the neutral and aux switch settings 21=1 and 22=2 via the config button while it’s excluded to see if it works.

Tried the factory reset.

  1. Excluded the device from z-wave
  2. Held the config button down for 20s, and then the switch flashed red 3x.

I let the switch go through its routine for factory resetting. Interestingly enough, after turning on the switch, I tried using the aux switch on that same circuit. The same behavior happens.

Just to make sure the settings were being reset, I changed the dimming speed to the minimum, then did a factory reset, all without including the switch at the z-wave network.

The same phenomenon with the aux switch continues to happen where either paddle causes the light to turn off.

At this point, I’m gonna put in an order for two new switches. Thank you @PJF for your help and suggestions. I’m frankly stumped why this is happening.

You did set the parameters with the config button, right? It won’t simply work after a factory reset.

Yes, I tried setting two parameters according to the manual (config x12 + 1x up and confix x13 + 2x up). I assume the settings took–as I also changed the dimming speed–but the aux switch still just turns the lights off.

I tried setting up an aux switch with the config once. It took me 2 or 3 tries to get it working.

Good to know. I’ll give it a couple more tries.

  1. Reset
  2. Set config
  3. If working, exit, else go to 1

I hope you have success, I know I had to try it I think 3 times. It might have actually been the 4th time I finally got it.

New switches arrived, and they work perfectly well.

I had a look at the old switches and noticed the firmware versions were 1.57 and 1.44

Looking at the new red switches (no black in stock) the firmware versions are 1.57 and 1.45

Dimmer Black Series shows Holtek 1.44

Dimmer Red Series shows Holtek 1.45

Are those the latest Holtek firmware versions available?

I’m partially curious if that difference is what’s causing the problems I had earlier.

For the black series 1.57/1.44 is the latest production. There is no beta.

For the red series 1.57/.145 is the latest production. There is a 1.61/1.45 beta, however.

For the black, ignore the blue box at the top of the page, it’s incorrect. Scroll down.

1 Like