LZW31-SN / 3-way / LIFX settings

Hi … I’m not sure if this is the right place to post, but I’ve done a bunch of looking around in this community and I think I am missing something or doing something wrong—or more accurately, I feel like I’m missing several things. So apologies if this question is all over the place. I have what feels like a lot of variables so it’s awkward to describe and ask about.

Anyway. Here goes. I have the following setup:

  • 3-way switch: LZW-31-SN + dumb switch + [4 x LIFX BR30 in cans in kitchen ceiling]
  • neutral: yes
  • SmartThings hub
    (also, I’m fine getting an aux or whatever to replace the dumb switch)

I got everything working (I have one other Inovelli dimmer, the same model, but it’s wired to a dumb light, and I have that all set) … and went into the ST handler settings in the old ST app and made these changes from the default:

  • AC power type: neutral
  • Disable local control: yes
  • Disable remote control: yes (because my kid started telling google home to turn the dimmer off)

Child devices:
Disable local control: yes

I originally tried to do the thing where you push the config button 8x and didn’t get a response (like no blinking, no change from the default blue LED). Now I still don’t get a response, but I assume it’s bc I disabled local control.

I have been able to control the lights from the LIFX app, but when I try to turn the dimmer off from ST, it does turn the lights off, but it’s not pretty (like one light definitely flashes green and I think the others flicker). And then when I try to turn them back on, 2-3 come back on but 1-2 disconnect. (Actually, now they have all disconnected … like 20 minutes after I did that.)

And then I can’t do anything from the LIFX app.

Annnnd now as I’m writing this I tried turning the lights on again from ST and they turned on, but the status window said “turning on” and never switched to “on” … and then they turned back off.
Annnnd then ST had them as off, but they were still on, and then when I went to change the color in the LIFX app, they turned back off (as if that made them suddenly respond to the ST command.)

So I am just really confused about what is happening:

  1. did the disabling of local control work? (I think so?)

  2. I feel like there’s another problem, where even though local control is disabled, the apps (ST, google home) are still trying to / able to control the actual power (as opposed to “smartly” controlling the bulbs)

  3. I understand that with smart bulbs I am basically creating a “fake dimmer” that is effectively a remote control that sends commands to the ST hub, which then sends them to the bulbs. So there is absolutely not supposed to be anything happening in the actual wiring when I set the lights to do things (but I guess I’m typing that to get validation on that :slight_smile:).

  4. Ordinarily I’m happy troubleshooting different ideas, but now I’m nervous about doing anything; because of #2 above I don’t know what is ok to set and what’s not.

  5. It’s possible that it’s a wiring problem, although I set the whole thing up with dumb bulbs before switching to smart bulbs + disabling the local control, and it seemed to be checking all the boxes at that point.

Anyway … apologies for this being all over the place. TIA for any advice you have!