LZW31-SN Connects fine for a initially, then loses connection and shows as unavailable, then back and forth

tl;dr;

My LZW31-SN configured through an aeotec z-stick gen 5 and using Home Assistant keeps toggling between unavailable and available and I can’t figure out why! Any advice?

More details:

I’ve installed the LZW31-SN switch and as a “dumb” lightswitch it works perfectly. I’ve connected it to my aeotec z-stick gen 5 and it seems to connect fine to that. I’ve installed the z-wave stick on my mac mini which is running home assistant version core-2021.11.4 in a virtual machine. I was able to get it installed with the z-wave js mqtt add on and everything was working fine. After one day, though, home assistant could no longer find the switch and it showed as “unavailable” with device status “dead”. Even during this time, it worked as a dumb switch that I could turn the light on/off physically.

I tried googling and couldn’t find anything and struggled for several hours to reconnect it. I finally was able to do an exclusion and remove it. I then added it directly to the z-wave stick before plugging it back into the mac mini and configuring it through home assistant. Again, it worked perfectly well for about a day. At that point, I was in home assistant trying to turn the light switch on/off through the UI and noticed it wasn’t responding…I checked its status and it showed as unavailable again. After a few minutes of playing with it, it now shows as available, but I’m not able to use HA to turn it on or off as the button is grayed out (the way it is when it’s unavailable).

After a bit of time, the device was then back to good health, showed available and I could turn it on/off via home assistant. Later that night when my automation ran to turn on the light at sunset, it became unavailable again. You can see the list of events here - the device is called “Entrance Switch Porch Front Lights”.

Then a few hours later, available, then unavailable, and back and forth. I didn’t do anything myself during the time that it was available or unavailable to trigger a change.

I have two automations running - one turns the lights on triggered by “sunset” and the other turns the lights off at midnight.

I can’t figure out if this is an issue with the switch itself, the z-wave stick, or something with my home assistant configuration. But considering it works fine for a period of time (I can turn the light on/off with HA controls, I had an automation to turn it off automatically at midnight, etc) and then just stops working, I’m wondering if there’s a bad connection some place. Anything you can do to point me in the right direction would be very useful!

(This is my first installed Inovelli switch but I have 3 more to install, so I’m hoping to figure out what I’m doing wrong before adding more switches to the problem.)

I’m also running HA with a Nortek stick. I have 23 red series dimmers and 1 red on/off and I personally haven’t seen this. I just checked history on a dozen switches but none appear to have lost connection. Someone posted a similar issue with the bulbs a few days ago, not sure if it’s related

How far away from the stick is your switch? Do you have a small number of zwave devices? I know the switch has a signal strength detector built in, I’ve never used it but I’m wondering if the signal might be weak? Hopefully we can find a solution!

Thanks @flipontheradio … I looked through that discussion you linked and while I have a similar issue, re-interviewing the device or restarting the z-wave js to mqtt add-on do not magically solve my problem :frowning:

The stick is probably 20 feet away through a single interior wall from the switch. It’s the only z-wave device I have connected so far. If I test the signal at the switch (by holding the config button for 5-10 seconds) I get a Green light indicating it’s within range.

Is there anything else I can provide to help narrow down where the issue is?

Should I install another switch (I have other locations I’m planning to add these switches to) to see if I have the same problem? If not, perhaps it’s just this switch itself that has a hardware issue?

Are you running zwave-js?

@smenzer I would definitely be curious if another switch would improve things, if possible one closer to the hub. Each switch you add should increase the strength of your zwave mesh network and hopefully making it more reliable. You could also check the manual for the switch and try running the signal test on the switch itself (while actually working with the hub). I’m not sure how reliable or accurate that test is but I’m pretty sure Inovelli added it to all their switches.

@curtis I am running zwavejs2mqtt which is still zwavejs as I understand it

No, I only have z-wave js to mqtt installed

@flipontheradio the other switches I would install would either be in the opposite direction or further away from the hub…but I will attempt this weekend and see if they have similar troubles.

last night I used home assistant to “reboot host” and when it came back up it seems that the switch was found again (i hit reboot and left the house, so I wasn’t monitoring, but the logs seem to show it was better around that time).

Could this indicate a problem with the z-wave stick and/or the mac and/or the virtual machine side of things, rather than the switch itself?

Something else worth trying, if possible, is to move your hub (Mac) closer to the switch for a couple days and see if the switch becomes unavailable.

I think you’re right that the Mac, VM, zwave stick, or switch could also be the root cause. If moving the hub does not work or isn’t an option you could try a different switch in the same location maybe? I know that there are sometimes issues with running HA as a vm related to USB path… But I’m leaning away from that because your switch does become available again. I’ve also seen certain devices causing interface with USB sticks so trying a USB cable extension might be another option.

I was hoping to use the Mac as a home server and to run HA since it’s more than capable (even if it’s 8 years old), but do you think I’d have much better results if I moved to HA Blue or Yellow (and would you recommend waiting for Yellow or just run Blue and plug my existing z-wave stick into it)?

Moving the mac is possible but a bit annoying, so I’ll try the other options first (installing a 2nd switch and see if I have similar problems). I’ll see if I have a usb cable extension and separate the stick from the mac a bit to see if that helps.

Thanks for all the help so far!

I run a unique setup in my home that has HA Blue on the top floor, raspberry pi 4 in the basement, and an Intel nuc on the main floor. All have their own zwave stick and run HA, the Intel nuc is the main “brains” and talks to the other zwave instances via websocket. I mention this because if you have another device available, raspberry pi or another PC you can setup HA on it, add your zwave stick and connect to it via websocket and still have you main HA on your Mac. Not saying it’s ideal but it’s an option if the Mac, the VM, or range is an issue since you want your Mac in a certain location.

HA yellow isn’t expected to ship until November next year so I’m not sure you want to wait that long. The blue is great though, I’ve gifted a few as presents this year because the case and appearance is classy IMO

ok thanks…will consider the Blue (because yea, don’t want to wait for Q4 next year!)

another update in case this helps at all…as I mentioned earlier, the switch became available yesterday after the restart of the host. it worked fine, with the automation turning off the light at midnight like it’s supposed to. was available all day long and then 30 minutes ago when the automation to turn the light on at sunset happened, it became unavailable.

This seems super bizarre to me especially since it every time the automation to turn the light on is triggered it has died - around 4-5pm each day:

Here’s the automation:

Does this give any clues?

Edit: I just went over and checked and the light is on, which means the automation worked before the switch become unavailable.

I’ve noticed at other times when I was testing things (when the switch was available), that when I would turn the switch on, it would work, but within a minute or two of using HA to turn it on is when it would go unavailable. Again, no idea if this is helpful, but wanted to share in case it is.

Another idea, is that you could buy a z-wave smart plug. This could help with two things:

  1. Act as a repeater in case there is some kind of unexpected interference
  2. Provide another device for you to connect to validate that z-wave is working

Others may have recommendations, but this one seems to be pretty highly recommended and not that expensive:

That’s a good idea…I will look into that.

Fingers crossed and knock on wood…but since earlier today when it went unavailable and then came back on an hour later…it’s been good. Maybe it was just being shy the first few days and needed to warm up? I’ll see how it goes over the weekend and report back.

Check your z2m logs when this happens. It sounds exactly like the issue I’ve been having with zwavejs which has been happening on more than just Inovelli devices. I didn’t copy the log message last time I saw it, but it was something along the lines of “Sent command 3 times and now marking device as unavailable”.

I’ve had a number of zwave devices being marked unavailable by zwavejs in the past week or so, every time is after interacting with them in an automation. The one that’s happening the most is with a bulb. I ram the brightness up and down from 100% to 10% and vice versa by 1% increments over a 20min period of time. So basically every 13s it changes by 1%. It seems like every time this has run in the past week the bulb gets marked unavailable. I changed it yesterday to change by 5% intervals making it change roughly once per minute and it dimmed down last night and back up this morning with no issues.

Interesting, I’ll have to check on this next time it happens. Luckily, the whole weekend was “available” except for a short window where I think I had restarted HA core anyways.

I’ve purchased two smart plugs like what @jl_678 suggested so we’ll see how those do and if they help the inovelli switch stay connected.

I wish I knew what changed, but I don’t think I did anything to make it start working better. Let’s just hope the device just needed a little waking up before it was ready to be available 24/7!

Thanks everyone for the suggestions and advice, even if I’m not sure that it helped here specifically, it was really useful for my own learnings!

1 Like

I’ve had no issues since…so whatever was wrong is now fixed.

2 Likes

Same on my end. The issue seems to be completely gone. The only adjustment I made was changing the transition time on that 1 bulb. I haven’t had a single device drop off my network since. My theory is the zwave network was getting overloading, dropping commands, and then any device that dropped a command was getting automatically marked as unavailabe.