LZW31-SN Dimmer acting like On/Off after firmware update

One of my LZW31-SN (Red Dimmers) was on rare occasions seemingly acting up where the power to the lights would dim for a second and come back up, while the other switches on the same line were fine. While it seemed both more likely to be a power issue (although house is relatively newer build), I figured I hadn’t looked for firmware updates in a while, so I’d update that and the other dimmer switch in the same room before swapping out devices.

Oddly, both now function like on/off - if on, it’s at full brightness, regardless of what the dimmer bar level shows or the switch reports back to the hub. I tried telling it to dim down all the way over 10s, and the bar shows it going down, but everything is full brightness still

  1. Starting firmware: 1.52
  2. Updater: Hubitat C7 Device Firmware Updater app
  3. I updated to the latest beta that was out: LZW31-SN_1.61, confirmed successful
  4. Air gap reset after it was acting weird
  5. Re-saved preferences
  6. Air gap reset again
  7. Downgraded firmware to 1.57
  8. Air gap reset - still same issue
  9. Downgraded back to the original 1.52
  10. Air gap reset, still same issue

Any ideas/suggestions? Or any other info I could provide to help troubleshoot? Thanks!

Check to see if smart bulb mode is enabled? That seems like what it would do in that mode.

1 Like

Agreed toggle SBM on and off


Thanks! It was set to disabled already, but toggling it to Smart Bulb mode, saving, and then back to disabled fixed it! I appreciate both of your responses :slight_smile: