LZW31-SN In Three Way Config with Smartthings

My configuration is as follows:

  • LZW31-SN switch at top of my stairway - connected to the load – light. no neutral wire setup.
  • GE Aux - add on Switch at the bottom of stairway.
  • Smarthings hub version 2 managed by the classic app.
  • Smartthings motion sensor in hallway at top stairs.

All appears to be working as planned from both switches. I can turn the lights on and off from either of the switches.

My issue revolves a smarthing rule that says basically the following:

Turn on the light in the hallway to 50% if motion is detected
and it is between sunrise and sunset
and if the state of the light is off.

Again this works fine except it doesn’t seem to be honoring the last condition which says to process the rule on if the light is off.

What happens now is that I turn the light (full brightness) on at the bottom of the stairs at say 8:00 PM, walk of the stairs, the motion sensor detects me and dims the light. Not a good situation according to the boss (my wife)

Any suggestions - yes I do have the latest drivers as suggested on the Inovelli web site.

Can you post a screenshot of the settings in the app? Using SmartLighting, I presume? Or another smartapp?

Yes using smartapps

This text will be hidden

The parameter “Only if Switch”, is set to “OFF” even though it is not showing in the screen shot.

Maybe that is the problem, that the parameter is not being retained even after I go in, set it and yes save it.

I think so. If you go back in to check the settings and it isn’t displayed, then it didn’t stick. Remove that whole and try again, setting the switch is off parameter first, but by itself. Go out then back in to see if it sticks. Then start progressively adding the other options one at a time. Check after each one to see if the settings remain.

Recreated the automation in the smartthings classic app and ended up with the same results. One additional observation is that it retains all settings for all of the “more options” except the last two. If I try to change “Only if Switch” or “only if illuminance is” parameters these setting are not retained.

Unfortunately you’re not going to get ST to fix that as they are not releasing additional Classic updates.

Do you use webCore? You ought to be able to code that there.

In the submenu for Only if switch, you have to say both is Off and in the option right above it “Only if this switch”, tap it and select the Upstairs Hall Dimmer. Not having both of these parameters set is why you see “Tap to set” still on the main menu.

The way they designed this option, it does not default to the switch you are trying to control. Nothing is selected by default, and you can opt to have the behavior of this automation depend on an entirely different switch’s status.

puzzles that seems to be the trick - thanks for paying such close attention to guide me through what I was missing. The setting took, just have to see if works as I desire. Much appreciated.

1 Like