LZW31-SN & LZW31 do not show config option in HomeAssistant 0.114.4

I have a red and black dimmer that I can not adjust any of the config options in homeassistant. When I got to the z-wave configuration page, and select the node. There is nothing under the Node Configuration Options. It may be a bug because when I click the drop down for Node Configuration Options the page freezes, and I need to reload it. This happens for both the Red and Black Dimmers but not my LZW36 or any of my other z wave devices. Any ideas?

Any one have ideas for this? I am running the native z wave integration, and checked the zwave files, and everything looks good.

I have this issue as well for my LZW31.

I have:

  • Dropped in the manufacturer folders including manufacturer_specific.xml with the files from Inovelli’s github.
  • Added LZW31.xml to the subfolder

HA recognizes it as a LZW31 dimmer, but when I go into the ZWave integration and choose Configuration Options, it just flashes at me.

I saw some threads about deleting the zwcfg_jklfjdlk.xml files, AND also about manually editing them. Unsure which will work, and a little at my end on making this work with HA. :expressionless:

Screen Shot 2020-09-30 at 9.19.20 AM

I was able to get my LZW30 to work by reflushing everything, but the 31 version still won’t show config parameters. So frustrating! If you’re skimming this topic and have some thoughts, please drop them in! I have 15 of these and am about to return or switch back to ST if I can’t get this to work :confused:

It sounds like you are using the old zwave integration?

Have you considered to moving to OpenZWave, which is the new official zwave integration for HA? It’s a bit rough around the edges, but unlike the zwave integration it’s actually using a recent version of OpenZWave.

Thanks for the reply! I’ve been following the instructions here from @petro , given they are Official, but I did try the OpenZWave integration, and with my newness to HA I was unable to get any devices out of the VNC server. Meaning, I could add devices to my USB stick inside the VNC ozwdaemon terminal, but getting those devices to show up in HA didn’t happen. I’m a very technical person but couldn’t see the bridge that happens.

Also, I have noticed that the .XML file from Inovelli contains invalid markup, looks like there are some extra tags. I’ll clean those up and see if thats the issue.

  1. Home assistant is a web based system. That means browsers cache information and display it instead of providing new information. Try hitting CTRL+F5 to clear your cache and refresh the page.

  2. If 1 doesn’t work, when you made all the changes to the config files, did you exclude and include the device? Without doing that, the information doesn’t get updated. I’m sure there might be another way, but I did this to ensure the ozw_xxx.xml cache didn’t need changed/deleted.

  3. Use the .xml file I added in the directions. I doctored them to work with Ozw v1.4 that’s built into HA. I don’t believe (could be wrong) that the versions from v1.6 will work.

nic - MQTT is the bridge that connects them. If the OZW container was working and you could add devices to it then you had a MQTT server running that it was connected to since it won’t run without the MQTT server. So, you need to setup both the MQTT server integration AND the OZW integration inside HA and then it will work.

I run the stand alone OZW admin tool instead of using the terminal. It seems to work better to me. When you run it just click open and put the IP address of the device where the OZW daemon is running. The IP of your HA if you’re using the all in one and installing via the supervisor.

I run everything as Docker containers on unRAID so I use the IP address of the unRAID server for the admin tool.

@PJF thanks - that’s the mental bridge I was looking for. I’d had MQTT, etc all setup, just wasn’t sure thats how OZW was pumping them into OZW. Will try that.

I am a little hesitant as that version is a beta, and given what I’ve encountered with HA I’m learning to stick with the stable stuff. But then we wouldn’t also be talking about trying a beta if that was the true case :grin:

@petro 1) I have refreshed cache 2) I exclude and include every time. 3) I wasn’t able to use your XML files because there isn’t one for the LZW31 (not SN) model. So, to be clear, is this Repo from Inovelli version 1.6 or v.14? I did see your notes in the official thread about how you had to backport, so if you don’t have an LZW31 already backported, I’ll do the same. Someone had commented higher up in the thread that they used that repo, but what I didn’t determine is they actually got it working or not :grin:

thanks everyone, will report back.

Honestly that’s understandable, it’s not very intuitive at the moment. I think it is worth the trouble as the old integration is effectively a dead end.

There are four things needed:

  • Install the Mosquitto Broker supervisor add-on
  • Install the MQTT integration
  • Install the OpenZWave supervisor add-on
  • Install the OpenZWave (beta) integration

It sounds complicated, but its actually pretty straightforward to setup and there is minimal actual configuration needed as the defaults are basically setup to ‘just work’, other than needing to specify the path for the USB device in the OpenZWave supervisore add-on.

Looks like our paths crossed on timing - the OZW beta is up and running! And surprisingly, it just works!

For those reading this from the future:

  • After you add devices in the GUI, you should expect to see them in HA. If not, something broken.
  • On the Supervisor Add-In, I needed to add “localhost” to the Network entries. They get removed later, but thats what kickstarted things for me.
  • Don’t do the reference to /config/openzwave/config as in the past. Leave the defaults.
  • When you go into Configure, and launch the GUI, you don’t need to click Start Local Client, you only need to launch OZWDaemon
  • If you don’t see your USB stick in that list of devices, something isn’t right with your config.
  • The GUI entirely shuts down after a change, you’ll need to refresh the entire HA page to reconnect. (if the screen is blank, don’t wait, refresh)
  • You can use the “Y” key when the GUI asks you 5+ times if you want to cancel a command. (you’ll know what I mean when it happens)

1 Like